Author Topic: Silent mode issue  (Read 3671 times)


  • New to the forum
  • *
  • Posts: 9
Silent mode issue
« on: August 04, 2015, 06:59:58 PM »
Hi everyone, first post here.

Installed Magic Lantern Nightly.2015Jul02.5D2212  on my 5DmarkII recently to experiment with timelapse photography and I've been trying to read most of the info I could find on the forum and elsewhere about ETTR, post deflicker, silent mode, etc.

Of course, I am intrigued by the possibility of shooting timelapse in full resolution silent mode and spare a good number of shutter actuations. However, I understand that this feature is not fully developed.

Having read here:
that some people have managed to use it combined with ETTR (although I read that ETTR would not work in liveview), I have tried to do so myself. After a couple of attempts that seemed to work okay, I started to end up with overexposed .DNG photos every time I activated silent mode. I could also read that this is somehow normal:

I do not know if I'm doing anything wrong though and reading that some people manage to work ETTR and silent mode combined gets my wondering. Especially the fact that yesterday it worked well and now even if I manually set aperture, shutter speed and ISO to a correct exposure and, shooting in silent mode I invariably end up with overexposed pictures. Also, for some reason, the silent mode option in the Magic Lantern menu always appears greyed out, with an orange message below, warning me that the camera should be in Manual mode, which is. I don't know why, but Magic Lantern doesn't seem to register that.

I was wondering if you could confirm that my assumptions are correct or if could help me out in case you were familiar with some of these issues and have found a way to solve them. I did some research on the forum but couldn't find anything more specific than the links I posted. I apologise if I've overlooked some topics and the answers are already out there.

Thanks a lot for your help and the great work on developing Magic Lantern.


  • Freshman
  • **
  • Posts: 55
Re: Silent mode issue
« Reply #1 on: August 04, 2015, 08:31:06 PM »
In short: The main issue with full-res silent pictures is that it simply doesn't do fast shutter speeds. If you set your shutter to faster than 1/10s (may vary a bit with different cameras), you still get about 1/10s with a darker gradient at the top of the image - somewhat like a graduated ND filter, but not as useful. You just need to, lower your ISO, close your aperture some more or use a ND filter for FRSP to work in broad daylight.
I don't think that your problem has anything to do with ETTR. Please check your shutter speed again and report back if the problem persists.

About that warning message: My 50D also displays an orange message about "FRSP only works in Manual (M) photo mode" when video recording is enabled in the ML menu, but it seems to be more of a friendly reminder than anything else. Silent pictures do work, no matter if video mode is active or not. Don't know if something similar happens with your 5D2. Please always report the exact error or warning message when there's a problem... things go a lot faster without the need to guess what you mean.


  • New to the forum
  • *
  • Posts: 9
Re: Silent mode issue
« Reply #2 on: August 05, 2015, 06:49:16 PM »
Thanks for your reply. I think I was confused by the fact that I thought Silent Picture would only work with LiveView activated and therefore could not work with a lower shutter than 1/30. Apparently, I had gotten it all wrong.

As you say, it does work even without LiveView being active, however on my camera it doesn't seem to respect the values I set to the camera, even with a lower shutter speed than 1/10. I've tried switching between 1'', 2''5, 3'' and changing the aperture accordingly, but I still seem to come up with the same underexposed .DNG image, with the same darker gradient at the top, whereas if I take a standard picture actuating the shutter, the picture is perfectly exposed.

So yesterday I ended up with overexposed DNGs (probably because I was using faster shutter values than FRSP can do) and today I'm getting underexposed DNGs, but this time the shutter speed I set is slower than 1/10.

As for the coordination between ETTR and FRSP, I did another test today. I activated ETTR and set values according to the Canon exposure meter (minding to keep shutter speed lower than 1/10) and, after taking a few shots, I let ETTR correct them to reach a histogram ETTR hint of EV 0.1 which should be okay. I then started the intervalometer activating FRSP and the first picture it takes showed an ETTER hint of EV 0.6 in the histogram, which remained constant for a few pictures and then lowered to EV 0.7 before I stopped the series. Is it normal? It seems that ETTR does not affect the photos taken in FRSP mode in any way. The camera beeps like it does when ETTR adjusts the levels, but they don't change, DNGs are underexposed and ETTR hints keep the same value.

One more thing, the Magic Lanter guide seems to say that, with AutoFocus assigned to a back button, the half-shutter button should allow you to take a Silent Picture (at least in liveview, I guess). Currently, I manage to take Silent Pictures only when I start the intervalometer with FRSP on.


  • Developer
  • Hero Member
  • *****
  • Posts: 3218
  • 60Da / 1100D / EOSM
Re: Silent mode issue
« Reply #3 on: August 05, 2015, 10:10:04 PM »
How did you determine that the DNGs were underexposed? Can you post some samples of a normal CR2 versus FRSP DNG with the exact same settings and of the same static scene, that show that the DNG is underexposed compared to the normal CR2?

With all the exact same settings, FRSP should appear slightly overexposed compared to a normal CR2 and there should be an exposure gradient at faster shutter speeds. See:

AutoETTR is not aware of the exposure quirks of FRSP and therefore can't really be expected to function correctly when used with FRSP. I would recommend not using them together until AutoETTR is updated to handle the special cases of FRSP.


  • New to the forum
  • *
  • Posts: 9
Re: Silent mode issue
« Reply #4 on: August 16, 2015, 02:03:55 PM »
Thanks dmilligan, here you can find the cr2 file and the FRSP DNG looking underexposed:

Here's my workflow:

Fixed my exposure manually, then let AutoETTR fine-tune exposure to E0.1, cr2 pic was taken with following settings:

Shutter speed: 0''8
F 4.0
ISO: 100

Switched Intervalometer + FRSP mode on (can't seem to be able to work FRSP alone), took a few DNGs looking like the one in the attached file, with ETTR hints varying between E1.9 and E2.1

Is there anything wrong with this process? At first I though that the exposure shift was due to the camera enabling liveview for the FRSP mode and switching shutter speed to 1/30 but in that case the DNG would be much more underexposed.