Canon 70D

Started by nikfreak, January 15, 2015, 12:22:15 AM

Previous topic - Next topic

0 Members and 2 Guests are viewing this topic.


How use dual pixel:
(it's not mine video)


Ok, no I can definitely not see the Timer A and B registers. I think part of the problem may be that the adtg_gui build I have is a custom build that @dfort provided me with back in March. Now I have the problem that crop_rec_4k doesn't compile for me

and the branch that does compile (crop_rec_4k_mlv_snd) doesn't allow me to make I am also not able to use the from the download page with this build. Am I right in assuming that this is because the 70D isn't really fully integrated into one of the main branches? Either way, pretty much stuck with regard to the crop_rec  720p 60fps experiment :(.


These are some experimental updates that did not work on 700D/650D/EOSM either, but I have yet to implement a fully working solution (at least I know what to do, just need to sit down and code it).

I've updated adtg_gui here; expecting it to work, but didn't test. If it's not working on top of your custom build, I can debug it in QEMU.


The new atdg_gui works nicely, thanks!

With every new possibility it seems there are some new mysteries to be uncovered. The positive first: It seems indeed that my "stuttering" problems in crop mode were related to fps issues. Because, I was able to change fps to roughly 25fps and now I have an (almost) perfect 3x3 crop_rec mlv file!. There is minor ghisting going on but the preview and file are stutter free. However, and here the mysteries begin:

I could not see/find a C0F0 [6008], but a C0F0 [6014] and [6024] which had the same value. I needed to change BOTH of them in order for the image not to freeze. In this manner, I was able to lower the fps in the crop_rec module AND in regular 1080p, but I could only lower fps, not increase.

Needless to say, changing fps also messed up the way I originally changed the CMOS registers to get normal frames in crop_rec. Now all I had to do was change CMOS (b) from 800 -->300 and leave CMOS [a] alone.

There are some minor ghosting effects in this MLV, otherwise it is fine.

As always, hope this somehow helps more than it complicates matters  :P

Here's a frame that shows the defect.


That ghosting is unusual - dual pixel AF messed up?! Not sure what to suggest for fixing it... is there any way to turn off DPAF in Canon menu? You could also try "diff-ing" the two video modes (1080p and 720p), with the "Modified from now on" option in adtg_gui:

Quote from: a1ex on February 10, 2018, 05:36:34 PM
Step by step:
- select 720p50 in Canon menu
- enable ADTG Registers
- go to PLAY mode and back to get all the registers
- select Show -> Modified from now on (also displayed as "since HH:MM:SS")
- go to PLAY mode and back, make sure it shows nothing (if it does, repeat a few times)
- select 1080p25 in Canon menu
- go to ADTG registers menu and notice some registers appeared
- to double-check: go back to 720p50 and make sure it shows nothing
- back to 1080p25 and the registers should appear again
- select Advanced -> Log Registers Now (to save the modified registers to a log file)

That's the general procedure for "diff-ing" two video modes.

6014 and 6024 with the same value? That smells like DIGIC 6.

6008 is set only once when entering LiveView, so you should do that with adtg_gui enabled in order to see it. Going to PLAY mode and back, or pressing MENU twice, will do the trick. This register is interesting only if you want to increase horizontal resolution (and you can only do that in 1:1 crop modes).

Does the latest adtg_gui still show brackets for these? ENGIO registers were added as an afterthought, so it was just easier to display them like that on the existing, but their "name" is without brackets.

FPS issues might be because of adtg_gui overhead - there are a LOT of registers updated at every frame, and keeping track of all of them takes CPU time. For this reason, adtg_gui might not be the best tool for high FPS. For now, you may focus on getting clean image when overriding the line skipping factor the 720p mode.

It would be interesting to find out what Canon does with that DPAF test image; will prepare some more experiments later.


I'll let others eveluate if this is really what I hope it is but I think I had a minor breakthrough! Sometimes the simplest solutions are the best. I thought, well if 60fps is causing too much lag and 25fps works fine, maybe 50fps is low enough in order for things to work properly. So I switched to PAL video mode in canon menu and redid my original changes (without messing with timer A and B) AND IT WORKED!

The vertical resolution is limited to 626 pixels at the moment (I think was to be expected without the timer changes, right?) BUT, the files are not strechted and there is (stretched) real time preview and recording! For me personally (and everyone else with a 70D) this means that slow-mo recording has become at least moire free and the resolution is good enough in 2.35:1 to be incorporated into a 1080p project (in my opinion) :D!

Here's a frame!


I know I'm late with this one, but mind taking the resolution chart pictures as described here?

Quote from: a1ex on January 21, 2016, 08:52:22 AM
If anybody could shoot some resolution charts in LiveView (silent pictures in 5x, 1080p and 720p, without touching the camera - I need more than pixel-perfect alignment), I can verify if these patterns are indeed the correct ones or not. If you don't use a remote release, you can take this test with the "Silent zoom bracket" option from the latest raw_diag to avoid camera movement.

That's to confirm or deny previous reports saying that 70D has worse aliasing compared to other cameras.

Looking for tests in 1080p25, 720p50 and 720p50 3x3.

edit: I'll cross-check the results with a 60D (expecting the same aliasing levels as 600D).


Yes! Will do in the evening when I have time to print/set up. I am curious to see the results myself, from my experience (had a 600D before) I'd say that moire really is a little worse, even in regular 1080p mode.

For now, I can also report that I fixed the ghosting in fps override! turns out i forgot to override the line skipping factor before...  :( . Anyway, here's a frame from 3x3 in 720p mode at 21fps. Sorry for the weird aspect ratio, forgot to change it in ML menu, the frame is not stretched just 1824x466 ^^. This mode (fps override enabled) requires different changes than if I leave timer B untouched.


I hope I did this test  thoroughly enough to do some real pixel peeping, what's apparent either way (at least for me) is 2 things. First, 3x3 binning or whatever this crop_rec magic module does produces insanely less moire than regular 720p mode which is all over the place. But secondly, sadly, it seems I have an offset in the framing in this mode, it's shifted to the top. Here's the DNGs!


Hm... the  "Silent zoom bracket" option from the latest raw_diag didn't work?

That should take a DNG screenshot in plain 1080p and - without you having to touch the camera at all - another one in x5. You'll also have to enable the option to dump the raw buffer in raw_diag.


No, not with the 3x3 mode. I can retake the others with silent zoom bracketing tomorrow if that makes a diffenrence!


Somehow the silent zoom bracketing doesnt quite do what it's supposed to. When I don't turn on MLV_REC it takes the 1080p but not the 5x zoom picture and when I DO turn on MLV_REC it takes the 5xzoom but not the regular one. It never takes both  :-\?


Sorry, forgot how to use this one - it was supposed to work together with the silent picture module, not the raw dumping option from raw_diag. You should enable simple silent pictures manually. Make sure AF is disabled.


Yes, I figured that much, but still - somehow the module doesnt take 2 different pictures. If it makes any difference here are the 1080p, 720p and 720 3x3 again. In 1080p it only took 1 picture, but at leastbecause of the timer I didnt touch the cam when Photo was taken. In the 720p modes the module took 2 pictures each but not with a zoom^^. in this case it is always the second picture I am providing because I thought it couldn't hurt^^. are the 5x required for the kind of work you want to do?


Yes, comparing 1x with 5x without any sort of camera movement is important for identifying the binning pattern.

The silent zoom bracket does 2 half-shutter presses, one in 1x and one in 5x. That's all it does. The silent picture module is triggered by half-shutter. I've tested it on 500D, it actually took 2 pictures. Modules loaded: and Silent pictures enabled manually, default settings. Movie mode 1080p.

Silent picture module requires long half-shutter press if AF is enabled, that's why I've asked you to disable it.


Here's a short video of the process. As you can see, triggering silent zoom bracket takes 1 picture in 1080p mode for me and 2 in 720p mode, none of them in zoom mode. As always I happily invite everyone to point out my stupidity if I'm simply not getting it!


Hm, it's not going into x5 zoom mode. Maybe it just needs larger delays.

In raw_diag.c (iso-research branch), silent_zoom_bracket, try msleep(5000) instead of 2000. Recompile just the module.


Yes! Programming the delay differently did the trick :)!

Now everything worked as expected! Aaand once again, here are the DNGs haha.

With the crop_rec experiment, I am once again not able to find the right reigsters to mess with vertical resolution. Should I in theory be able to expand the vertical resolution in the "normal" 720 mode or is this only possible in 5xZoom and with raising timer B? Is it possible that 636x 1824 is the maximum I can achieve, like on the 6d?


Nice! If the camera did not move during the experiment, that's exactly what I was looking for. Now to sit down and interpret the results, but I might delay this a bit.

Increasing resolution should work without much fuss, until the image breaks. Just take care of the powersave registers, as they operate on the vertical direction (if in doubt, set them to 0 - that worked here, but the sensor might run a bit hotter). The crop_rec module already has these registers generic, so you shouldn't need to take care of them.

For FPS, the optimal configuration is with timer A minimized and B maximized. This minimizes the rolling shutter and pushes the resolution as far as it can get. I wonder why Canon did not always use it...

When reducing timer A, check with raw_diag OB zones for bad columns on the right side. Once that happens, go back (increase it). The trick is to find the lowest value that still gives clean image (including in the last few columns). Sometimes this is identical to Canon value, sometimes a few units lower, sometimes noticeably lower (5D3 25p: 480 -> 398).


After half a year since switching to 70D: I like it a lot, also ML works absolutely fabulous. I find the stability of ML even better than on 700D which was crashing for me randomly from time to time. This was anyway only few times a year but 70D seems to not crash at all. By crash I mean null pointer exceptions or similar stuff -- the console pops and restart is needed; not that big deal.

Bug report:

The only thing which bothers me is a function to adjust ISO and white balance in Live View using the up/down/left/right button. Sometimes it gets suddenly activated (ISO+, ISO-, WB+, WB- labels appear on screen) without any reason I would be aware of. I don't even know how to reproduce it. It just sometimes pops up unexpected.

- How is it supposed to be activated?
- Is there a way to disable this function completely? It drives me crazy as I am using these keys very often to move the focus box around the screen and then suddenly I'm changing the ISO and WB, which forces me to stop photographing and fix the settings.
M50.110 [main cam] | G7X III [pocket cam] | 70D.112 [gathers dust] | M.202 [gathers dust] | waiting for M5II


That's FEATURE_ARROW_SHORTCUTS (undefine it in features.h). The trigger key is model-specific; here it's defined as "METERING btn" / BGMT_PRESS_METERING_OR_AFAREA. Maybe this definition covers some other button presses.

Maybe you can suggest another shortcut key, that would be easier to detect?

If no suitable key is found, I'll just disable the feature and other related 70D exceptions, as I'm unable to verify them anyway.


Great, thanks a lot! I'll disable it for my use.

Just checked again: I entered LV and tried pressing each button, including shutter release half-press. This feature did not get activated by any of them. It always happens when I'm in hurry and click a lot... And that moments are not the right ones for a closer analysis... :/

Regarding an alternative button: I have found only one button not having any function assigned in LV and this is the AF sensor group selection button, next to the shutter release (marked red on the photo below).

Not sure if it could be caught by ML at all. From the other buttons, they all have functions in LV and I use them all, so personally I would not prefer to have them overriden (but as a RAW-shooter I don't use WB at all and ISO is anyway well accessible anyway; for shooting JPEGs the WB is a good idea).
M50.110 [main cam] | G7X III [pocket cam] | 70D.112 [gathers dust] | M.202 [gathers dust] | waiting for M5II


Quote from: ArcziPL on September 21, 2018, 10:17:08 PM

Bug report:

- How is it supposed to be activated?
- Is there a way to disable this function completely? It drives me crazy as I am using these keys very often to move the focus box around the screen and then suddenly I'm changing the ISO and WB, which forces me to stop photographing and fix the settings.

I activate this with WB so often and like you I am unsure how I do it. I haven't sent a bug report as I couldn't replicate it, but it regularly happens. I will play around and see if I can find how I am triggering it. If I find it, I will let you know.


About this so called bug, it's not a bug, it's a setting.
Had it happen very often, while moving around the focus box etc, suddenly whitebhlance and iso settings pop up.
These are probably the settings you're looking for: Prefs tab in ML menu ->Arrow/SET shortcuts, ISO/Kelvin and use SET button are on by default.


Quote from: Levas on September 26, 2018, 08:49:27 AM
Had it happen very often, while moving around the focus box etc, suddenly whitebhlance and iso settings pop up.

That does sound like a bug; it should be triggered only by a well-defined shortcut key (the one displayed in the Help tab, not by random button presses).

6D is also affected?