5d died when uninstalling

Started by Bemul, January 08, 2015, 10:45:31 AM

Previous topic - Next topic

0 Members and 1 Guest are viewing this topic.


Hi. Hopefully some one can help me. I tried to uninstall Magic Lantern.
I did everything "by the book", but after uninstallation by firmware update and formatting the card
camera went black. It just won't start. I have tried different batteries and cards. I have removed the small
"settings" battery and it won't help. Now I'm clueless...


Remove card(s), remove battery (big one).
Insert battery. Don't insert card.
Startup cam

Which 5D? There are 3 flavours ...
And which ML version/date? And which Canon firmware?


Francis Frenkel

Just re-install properly ML.
and it will come back to life.

Then unnistall properly.
it is so simple...

Dont be afraid.
No DSLR Died after unnistalling ML in the all world.

Only cartoonist in France

Je suis Charlie.
Francis Frenkel


5d mk II.
Firmware 2.1.2? (i cant check it now)

And I can not install, bacause the camera won't swich on. It's just black.

Current ML was 2.3 (july 23 2012)


Format card using your cardreader.
Insert card into cam and close doors. Try to startup cam.

Any LED activity?

Try M and all C modes.


I formatted the card properly with disc utility.

No LED activity at all.

Tried the M and all C modes.



Remove lens, remove card, remove battery, insert battery, close compartment doors and try again.
I suppose you triple checked your batteries. Remove battery grip (if any), check for obstacles in battery compartment. Try again
Do you have an opportunity to check your batteries within another cam?


Did that and tried with three different batteries that worked yesterday just fine.
Won't start.


Can you describe how the uninstall process went? As many details as you remember, if possible (what you did, what appeared on the screen, in what mode you did the uninstallation, whether the installer went to LiveView or not...).

I don't know if you still have the boot flag enabled (this depends on how far the uninstallation process went). If it's still enabled, you should be able to run the LED blinking test from here: http://magiclantern.fm/forum/index.php?topic=2296.0

If it blinks, I can look into it.


Card must be bootable. Use EOScard (Windows) or MacBoot (OS X).
Card should have 32 GByte or less.


Ok. I used this tutorial:

I followed those steps.
But, when I formatted the card on camera, I accidentally used: "format card but keep ML".
(this option doesn't show on this tutorial)

I noticed this when cameras firmware ID still had ML on it. And I was still able to start ML.

I did the procedure again. Now when formatting I used: "format card and remove ML".

After that the camera went black and never woke up again.

ML was installed on a 32Gb 60 MB/s card.


"Format card and remove ML" won't affect cam's bootflag but will make the card non bootable and remove ML files located on the card. Thus starting the cam should bring up plain Canon.


I removed the cameras ML bootflag before formatting the card.
Just like in the tutorial.


If you removed the bootflag you won't be able to use ML options.
So: If you saw the option "Format card but keep ML" bootflag must be set.


Detailed description of what you did, please.

After formatting, you probably turned the camera off. Did you do this from the main switch? Or by opening the card door? Or by opening the battery door? Did you remove the card before attempting to turn it on, or not? Was there any LED activity when you turned the camera off? How it looked like?

All these details are important, don't skip them.


After formatting I turned the camera off from the main switch.
I did not remove the battery or the card.

Then I restarted the camera.

In the menu firmware still indicated that I had ML installed.

I re-uninstalled ML (boot).
Then I formatted the card: erase data and remove ML.
If I remember correctly, I turned the camera off from the main switch.
I did not remove the battery or the card.

Then camera didn't start anymore.

...and have to add that I removed the small battery of the camera and put it back.
Idea was to make a "Factory reset". I did this after nothing else had any effect.


Ok. I took the camera to a Canon "repair shop".
They found a chip that needed to be replaced.
Cost estimate 500€.

Let this be a reminder to everyone that you really
do install Magic Lantern at your OWN RISK.


Quote from: Bemul on January 08, 2015, 01:26:39 PM
I re-uninstalled ML (boot).
Then I formatted the card: erase data and remove ML.

As I wrote before: It is impossible to access ML menu after uninstalling ML.
Conclusion: ML was not uninstalled. Or your memory is mixing things up.

Removal of the small battery will not do a "factory reset".

Installing ML is in fact own risk and ML team is in no way liabable for any damage.
But it is highly unlikely such error was caused by ML.