Author Topic: Canon 550D / T2i  (Read 290203 times)

Murkka

  • New to the forum
  • *
  • Posts: 7
Re: Canon 550D / T2i
« Reply #300 on: July 08, 2018, 09:27:14 AM »
Thanks about the response! I had read those already but could not find or comprehend anything to download or install. Now, let us take a look at them again.

Murkka

  • New to the forum
  • *
  • Posts: 7
RAW Video Bug Fixed With Lua Fix
« Reply #301 on: July 08, 2018, 03:38:06 PM »
I can happily declare that with the Lua Fix there is no error in raw recording with 550D. I used 928x522 reso which resulted (according to ML display) up to 20.1 mb/s bitrate. I recorded about 46 sec test video without any errors. All the time recording there was "Wait a while" quotation text on the upper side of the screen but like said, there was not any meaningful errors. Is it fully normal that that text is diplayed during raw rec?

a1ex

  • Administrator
  • Hero Member
  • *****
  • Posts: 12280
  • Emergencies only
Re: Canon 550D / T2i
« Reply #302 on: July 08, 2018, 04:27:03 PM »
"Wait a while" - there's no such string in ML source. Also couldn't find any string that begins with "Wait" and might appear during raw recording.

What are you talking about?

Murkka

  • New to the forum
  • *
  • Posts: 7
Re: Canon 550D / T2i
« Reply #303 on: July 08, 2018, 08:32:26 PM »
It is in my native language which I just translated directly. So I think it is from Canon own text? 

initium

  • New to the forum
  • *
  • Posts: 2
Re: Canon 550D / T2i
« Reply #304 on: August 03, 2018, 05:56:38 AM »
Hi!
Having an issue with my 550D...
ERR 70 appears on every boot. Tried to find a solution but failed :( Need your help!


Link to autoexec.bin: https://www.dropbox.com/s/i0vel4ubr1dxdsa/autoexec.bin?dl=0

Link to log002.log: https://www.dropbox.com/s/jzg7mu7toba3bls/log002.log?dl=0

CRASH.02.LOG:

ASSERT: 0
at Stub.c:29, task RscMgr
lv:0 mode:2

Magic Lantern version : Nightly.2017Feb12.550D109
Mercurial changeset   : eb960b67af34 (unified) tip
Built on 2017-02-12 16:39:46 UTC by jenkins@nightly.
Free Memory  : 227K + 2046K

ItsMeLenny

  • Hero Member
  • *****
  • Posts: 923
  • 550D
Re: Canon 550D / T2i
« Reply #305 on: August 05, 2018, 07:10:11 AM »
Magic Lantern version : Nightly.2017Feb12.550D109
Mercurial changeset   : eb960b67af34 (unified) tip
Built on 2017-02-12 16:39:46 UTC by jenkins@nightly.
Free Memory  : 227K + 2046K

Thats a very old nightly build you got there, can you download the latest and try it please?
https://builds.magiclantern.fm/ <-- select 550d
or go straight here https://builds.magiclantern.fm/550D-109.html
2018 3rd of August rather than 2017 12th of Feb

initium

  • New to the forum
  • *
  • Posts: 2
Re: Canon 550D / T2i
« Reply #306 on: August 06, 2018, 10:35:46 AM »
Hi! Thanks for your reply....
I'd be glad to upgrade... But I don't have access to the menu. All I see is ERR 70 message after reboot.
How can I access to the menu?

a1ex

  • Administrator
  • Hero Member
  • *****
  • Posts: 12280
  • Emergencies only
Re: Canon 550D / T2i
« Reply #307 on: August 06, 2018, 12:42:55 PM »
This should help.

If that doesn't work, use this build to get a diagnostic log.

baiadelleiridi

  • New to the forum
  • *
  • Posts: 3
Re: Canon 550D / T2i
« Reply #308 on: August 09, 2018, 11:20:44 PM »
Hi, I don't know if this is the correct place to ask but is there a way to override the 30 mins LCD liveview shutdown using magic lantern on a 550d? I need the screen to stay on for more than half an hour
Thanks

Audionut

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 3565
  • Blunt and to the point
Re: Canon 550D / T2i
« Reply #309 on: August 16, 2018, 02:31:35 AM »
There's lots of information regarding this subject on this forum.  Various ways around the issue depending on your particular circumstances.

baiadelleiridi

  • New to the forum
  • *
  • Posts: 3
Re: Canon 550D / T2i
« Reply #310 on: August 18, 2018, 06:26:32 PM »
can you point me to some of those ansewers? I really can't find anything

Walter Schulz

  • Contributor
  • Hero Member
  • *****
  • Posts: 6839
Re: Canon 550D / T2i
« Reply #311 on: August 18, 2018, 07:08:31 PM »
https://www.magiclantern.fm/forum/index.php?topic=20908.msg193014#msg193014
A1ex is refering to ML's experimental builds -> Top of page -> Downloads -> Downloads (drop down menu) -> Experiments
Photogs and videographers: Assist in proof reading upcoming in-camera help!. Your input is wanted and needed!

baiadelleiridi

  • New to the forum
  • *
  • Posts: 3
Re: Canon 550D / T2i
« Reply #312 on: August 19, 2018, 07:44:02 PM »
Thanks to both of you now I have it installed and working as intended!

madhivanan

  • Just arrived
  • *
  • Posts: 1
Re: Canon 550D / T2i
« Reply #313 on: September 17, 2018, 01:53:41 PM »
hi,
with regard to the issue in Reply #273, i too am facing this problem. i am using the latest 1.1.0 build. before installing magic lantern, when switching on the camera in photo mode, the normal display appears and the sensor cleaning will occur, which will be indicated in the right lower corner of the display. when shutting down, the sensor cleaning animation alone will be displayed. after installing magic lantern, when i switch on the camera in photo mode, there is no normal display but only the prominent sensor cleaning animation (as in shut down) and then no display, until the display button is pressed.
Also, after the LCD auto off, it can be brought back by pressing the shutter half way. but after installing magic lantern, after the LCD auto off, half pressing the shutter doesn't bring the display back. i have to press the display button to bring it back. This is a bit annoying.
After clicking some shots, i found that an empty white rectangular box appeared in the left top corner over the main display which didn't go away even after restarting the camera.
Hope this helps with troubleshooting the above said problem.
This is my first experience with magic lantern. Thanks.

aritzilla

  • Just arrived
  • *
  • Posts: 1
Re: Canon 550D / T2i
« Reply #314 on: October 06, 2018, 05:07:06 PM »
Hello,
I have installed magiclantern-Nightly.2018Jul04.550D110.zip for firmware 1.1.0 of Canon EOS 550D.
I do not know what tests I can do (or how) to help improve the version (I'm a newbie user).
Can i help somehow?
Thank you.

Audionut

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 3565
  • Blunt and to the point
Re: Canon 550D / T2i
« Reply #315 on: October 14, 2018, 12:33:03 PM »
I do not know what tests I can do (or how) to help improve the version (I'm a newbie user).
Can i help somehow?

If you have no coding knowledge, there are plenty of other ways to contribute to the project.

Test, as in really test. As if you were QC working for a software company. Don't just use ML in normal situations and submit problems when things go wrong (and don't just do another ML RAW vs. H264 test, there are more than plenty of those out there). Try to break a feature. Think of as many possible scenarios as you can. Throw everything you can think of at a feature to break it. Try every value of every setting. Try it in extremely unusual scenes or lighting. Write down your results like a scientist doing an expirement. Then share your results, even if nothing went wrong. It's also helpful for devs to know when something actually works. Test for the sake of testing, with specific intention, not for the sake of making your 'budget short film'.

If you notice a problem, figure out how to repeat it and try to isolate it to a specific build (or if you can compile, isolate it to a specific changeset). Looking at the change log on bitbucket is very helpful in doing this (look for commits related to the feature and check those builds first). This requires no coding ability at all, and can save devs a lot of time, b/c they will know exactly where in the code the problem lies. Even I can figure out bugs that would normally be way above my skill level if you tell me exactly the changeset that is causing it, in fact most of the very few patches I've submitted, I've found like this.

This has been reiterated by a1ex time after time, I'm sure he's tired of saying it. It's clear that very few people actually end up reading the 'how to report bugs' links he posts.

https://www.chiark.greenend.org.uk/~sgtatham/bugs.html

https://www.magiclantern.fm/forum/index.php?topic=12657.0  < Needs updating.

dfort

  • Developer
  • Hero Member
  • *****
  • Posts: 3733
Re: Canon 550D / T2i
« Reply #316 on: March 07, 2019, 04:28:27 PM »
Another way to help is to keep checking out the various topics to see if there are any new developments that include Digic 4 and/or LV State cameras like the 550D. For example I recently discovered that 10/12-bit might be working on this camera. I posted a test build on my Bitbucket downloads page. Could someone please give it a test drive and  report back?
5D3.* 7D.206 700D.115 EOSM.203 EOSM2.103 M50.102

jpegmasterjesse

  • Freshman
  • **
  • Posts: 97
Re: Canon 550D / T2i
« Reply #317 on: March 07, 2019, 08:34:16 PM »
Tried MLV_Lite and MLV_REC at all bit depths - nothing worked. Just rapidly alternating black and white frames with some purple and pink corrupted lines. Here are some examples:

https://drive.google.com/open?id=1gAZwQKmszwaZkfVx14PGm3PnNSy_H06p



jpegmasterjesse

  • Freshman
  • **
  • Posts: 97
Re: Canon 550D / T2i
« Reply #318 on: March 07, 2019, 09:06:48 PM »
Aha! I hadn't tried it in 5x mode - everything works! Either module and at any bit depth. Here's an example of a 10bit file in 5x mode:

https://drive.google.com/open?id=1ggLwdDOWrOB34uSHULqdk-YUSLGATKEH

dfort

  • Developer
  • Hero Member
  • *****
  • Posts: 3733
Re: Canon 550D / T2i
« Reply #319 on: March 08, 2019, 02:40:45 AM »
Thanks for running the test. Looks like the patch didn't work--at least not yet, still working on it. At least we know that zoom mode is still functional, that mode doesn't seem to require the patch.
5D3.* 7D.206 700D.115 EOSM.203 EOSM2.103 M50.102

scrax

  • Contributor
  • Hero Member
  • *****
  • Posts: 1543
  • Code monkey
Re: Canon 550D / T2i
« Reply #320 on: March 13, 2019, 02:25:37 PM »
I'm tring to add support to my module for other cameras than 600D, can somebody help in finding missing GUIMODE for 550D?
more info and discussion here

I'm using ML2.3 for photography with:
EOS 600DML | EOS 400Dplus | EOS 5D MLbeta5- EF 100mm f/2.8 USM Macro  - EF-S 17-85mm f4-5.6 IS USM - EF 70-200mm f/4 L USM - 580EXII - OsX, PS, LR, RawTherapee, LightZone -no video experience-

mariofutire

  • New to the forum
  • *
  • Posts: 2
Re: Canon 550D / T2i
« Reply #321 on: August 12, 2019, 09:11:41 PM »
I'm tring to add support to my module for other cameras than 600D, can somebody help in finding missing GUIMODE for 550D?
more info and discussion here

Is this still needed?