Canon 550D / T2i

Started by ItsMeLenny, August 27, 2014, 10:34:21 AM

Previous topic - Next topic

0 Members and 1 Guest are viewing this topic.


You must be formatting with keep ML. To be sure format in computer then again in canon. But I don't know why you would not want to keep such a useful thing as ML.
T3i and Kiss X4 (550d (T2i)) Tamron 18-200mm, Sigma 28-70mm f2.8 (need firmware upgrade) Olympus 50mm f1.8  Olympus 28mm f2.8 and Olympus 24mm f2.8
Fancier 370 tripod and LCD hinged loupe. DIY Slider and crane.

Walter Schulz

This procedure won't reset cam's bootflag!


Hi, I'm trying to disable the automatic gain control on my T2i so I can get cleaner audio recording with an external microphone. I understand Magic Lantern provides this feature.

I attempted to install Magic Lantern for the first time. I reset camera settings, updated my Canon firmware (1.0.9) and formatted my memory card. I downloaded the latest nightly build and pasted the unzipped files to the root of my SDHC 16GB memory card using a USB card reader on a Mac.

The contents of the SD card look like this:

When I attempt to update firmware in the camera, I receive an error: "Memory card containing firmware is required to update."

Any idea what I'm doing wrong? Thanks!


So I formated my SDHC card and downloaded the Stable (outdated) version of Magic Lantern. I was able to get it installed successfully.

I'm a bit confused about the "boot flag". What does it do? How do I determine if the boot flag is enabled or not? Can I format my SDHC card now or do I need to keep the Magic Lantern files on there? Thanks.

Walter Schulz

The cam's bootflag has to be set or ML won't run.
If you format your card you will loose ML. Because ML is run from the card. See User Guide section above.


If ML is working the bootflag is working. What it does is first time you run ML Firmware upgrade is add a line to Canons firmware telling it to read the autoexec file on the card. So the program runs from the card not the camera.

Edit  I just downloaded the latest and I can't see the fir file.

Found it.
T3i and Kiss X4 (550d (T2i)) Tamron 18-200mm, Sigma 28-70mm f2.8 (need firmware upgrade) Olympus 50mm f1.8  Olympus 28mm f2.8 and Olympus 24mm f2.8
Fancier 370 tripod and LCD hinged loupe. DIY Slider and crane.


Hi everyone,

I download the last Magic Lantern version but the file *.firm is not  exist in the folder.

Where I may download the the file *.firm ?

thanks in advance.


I'm experiencing the same issue not finding the 550D.fir file and with the only one I managed to find in an old link, I get the message that "the file cannot be found" on the card. Another thing though is that I'm not able to update the Canon firmware even though it's already 1.0.9. I've tried everything and no luck. I'm not sure wether there's a problem with the camera or there's something I'm missing.
Anyone has any idea?



Still the same message "Update file cannot be found. Please check the memory card and relaid the battery again".
I've tried a couple of SDHC 32Gb cards (Verbatim) and a 1Gb SD card with the same result. I cleared all settings on the camera and formatted (even tried with "low") and I end up with the same result.

As I mentioned in my previous post, I get the same error message when I try to update the firmware with the Canon 109.

Any idea?

Walter Schulz

Is your cam running Canon's firmware 1.0.9?
(If not: Format the card using a cardreader. Insert into cam. Format it there. Back into cardreader. Copy Canon's firmware file to card. Insert card into cam and run firmware update.)

Format the card using a cardreader. Insert into cam. Format it there. Back into cardreader. Copy extracted *nightly* build contents to card (Autoexec.bin + ML directory). Extract the files linked by ItsMeLenny. Copy 550D-109.fir to card's root.

Insert card into cam and run firmware update.


Thank you for your fast reply.

Tried it again and again with same result :-( I've even tried to remove the partition on the card and creating a new one etc.

Is there a possibility there's something wrong with the camera?

Walter Schulz

Is the cam running on 1.0.9 or not?
If in doubt: Visit and use the file found there.


Yes it is.

The thing is that even if I try to update the firmware from Canon, I get the same message???

Walter Schulz

Which files and directories are located on card's root directory?



Walter Schulz

This isn't by any chance a SD-card with 128 GByte?


It's a 32Gb Verbatim SDHC card

Walter Schulz

If this happens after formatting the card and copying files over: I'm pretty much out of options.


Do an in camera low level format. If it still doesn't work try a 16GB card or smaller card.


Hello everyone! I'm new here, i've just bought a 550D, i usually take photos, a few videos on occasion only.
I have to film something for longer than 12minutes, and i was told Magic Lantern is the way to do it. I installed it without a problem (the stable release, then updated to the latest nightly firmware, but my recordings still stop at the 12-13 minute mark.
On the stable firmware it just stopped by itself, on the latest nightly it stopped with saying "recording stopped automatically" or something like that, and that notice was on the screen until i pressed menu or shutter button. Is it not possible to record more than 12 minutes? Isn't there an "automatically start record again" function?

P.S. I'm using a 32 GB Kingston Class 10 UHS-1 (SDA10/32)


Yes there is:

Movie Restart

While this setting is on, movie recording will restart automatically, unless you stop it. There will be a few seconds skipped during restarting.
EOS 550D // Sigma 18-200 // Sigma 18-70 // Canon 10-18 STM



Hi All! 
I use very often my 550D always with magic lantern.  8)

I have a bug on the last build (10/07)
it incorrectly display the Time indicator [ In movie tweaks ] it is set on remain 4GB

When ON the Time Indicator is just over the GB remain ( top right of the screen )
and it show very strange numbers that changes incoherently
after time it stabilize but show 44min on a 4GB count down..
after it show red reverse also strange numbers

First I thought about VBR mode but I am in CBR 1.0x so I dont know why it dont show a consistent TIME REMAIN

I've tried with full hd and 720p it dont change anything.

Best and Long life to ML !    :)

EDIT : Sorry it appear that even in CBR filming a black scene (with lens cover) change dramatically the movie size so the countdonwn is false.
With real life filming time seems correct