Author Topic: UHS-I / SD cards investigation  (Read 192576 times)

lightspeed

  • Freshman
  • **
  • Posts: 58
Re: UHS-I / SD cards investigation
« Reply #750 on: October 13, 2021, 08:15:11 AM »
I just want to confirm. Is 240 working on the eos m?

I tried the module and it seemed to work at first but was very buggy.

Teamsleepkid

  • Member
  • ***
  • Posts: 247
Re: UHS-I / SD cards investigation
« Reply #751 on: October 14, 2021, 05:32:19 AM »
Sorry so vague. So I used this link

https://drive.google.com/file/d/1KQHxJfKnSHP5jy83dIutPW3ZIXeQUEJS/view?usp=sharing

and put the module in my magic lantern folder. Replacing the existing one. Like I said somehow bricked my camera somehow fixed it. I really forget what I did or what it said it was like a week ago. I got some screen to come up. Loaded something Alex made to save cameras. It worked.

The card was the Sandisk extreme 120MB card
EOS M

Teamsleepkid

  • Member
  • ***
  • Posts: 247
Re: UHS-I / SD cards investigation
« Reply #752 on: October 14, 2021, 05:34:28 AM »
This card appears to accept 240 MHz overclock (tested on 700D by a user interacted with me on FB)


I ran a few benchmarks I’m getting like 56MB write speeds which is ok to get yellow running 5kfrtp so pretty happy way less drop outs than my 95mb extreme pro. Thank you. Sorry I’m so bad at using the forum. And I always use 10 bit I don’t use 12 or 14 because I don’t want to choke the card.
EOS M

70MM13

  • Hero Member
  • *****
  • Posts: 544
Re: UHS-I / SD cards investigation
« Reply #753 on: December 22, 2021, 05:22:17 PM »
Hi all,
I'm feeling the itch to buy an SD card for my good old 5d3 if there's anything that might be worth testing for overclocking...
The sandisk 170MB/s extreme pro I am using now is excellent and always reliable, so I don't "need" a new card, but if there's something new with the right udma characteristics that may be faster, I'd order one to try it out!
Has anyone been keeping abreast of anything new and interesting?

Frayfray

  • New to the forum
  • *
  • Posts: 43
  • T1i,T5i,T6i,77D,EOS M,50D,M50,RP
Re: UHS-I / SD cards investigation
« Reply #754 on: December 24, 2021, 11:35:18 PM »
there are  three cards that i want to try Lexar professional silver series 1066x uhs1 120 MB/s write speed 160 MB/s read ,new Samsung PRO PLUS same specs . and Kingston canvas go plus but has lower specs 90MB/s write but claims 170 MB/S read speed ...note that these are claims that they are making . not me although i did order new card readers by kingston sandisk to test on computer ..i think i read some were that they are using  DDR208 controller on the UHS 1 pins to get higher read speeds

lightspeed

  • Freshman
  • **
  • Posts: 58
Re: UHS-I / SD cards investigation
« Reply #755 on: April 23, 2022, 12:55:54 AM »
240mhz with the new build and the old sd hack is working for me on eos M.

Anyone else have it working?

ZEEK

  • Senior
  • ****
  • Posts: 329
Re: UHS-I / SD cards investigation
« Reply #756 on: April 23, 2022, 03:00:42 PM »
240mhz with the new build and the old sd hack is working for me on eos M.
Anyone else have it working?
Stops immediately after a second on my Sandisk Extreme PRO 170 MB/s with 240 MHz
EOS M

Walter Schulz

  • Contributor
  • Hero Member
  • *****
  • Posts: 8303
Re: UHS-I / SD cards investigation
« Reply #757 on: April 23, 2022, 03:36:31 PM »
240mhz with the new build and the old sd hack is working for me on eos M.

Anyone else have it working?

Little more details, please!
Which old "SD hack"? Link, please!
And card in use.

lightspeed

  • Freshman
  • **
  • Posts: 58
Re: UHS-I / SD cards investigation
« Reply #758 on: April 23, 2022, 06:06:39 PM »
I used the one with the patch that prevents it from going into safe mode. And I disabled lua script and it works for me.

lightspeed

  • Freshman
  • **
  • Posts: 58
Re: UHS-I / SD cards investigation
« Reply #759 on: April 23, 2022, 06:08:37 PM »
Tlapse.lua script

theBilalFakhouri

  • Developer
  • Hero Member
  • *****
  • Posts: 863
Re: UHS-I / SD cards investigation
« Reply #760 on: April 23, 2022, 06:52:16 PM »
Which old "SD hack"? Link, please!

I used the one with the patch that prevents it from going into safe mode. And I disabled lua script and it works for me.

@lightspeed means this:
https://www.magiclantern.fm/forum/index.php?topic=12862.msg236735#msg236735

-Edit: I wrote my notes on it, it wasn't really stable, see masc's replies, one of his clips got corrupted with this sd_uhs version.
New custom build for 100D/SL1 is up:
https://www.magiclantern.fm/forum/index.php?topic=26511.msg239125#msg239125
Porting still work in progress!

lightspeed

  • Freshman
  • **
  • Posts: 58
Re: UHS-I / SD cards investigation
« Reply #761 on: April 23, 2022, 07:07:23 PM »
Mine was buggy to.  It the. I disabled that tlapse script and it seems to work good now.

rinski

  • New to the forum
  • *
  • Posts: 46
Re: UHS-I / SD cards investigation
« Reply #762 on: April 25, 2022, 06:41:51 PM »
Hello, could you explain to us how the lua script is disabled, it gives me an error and the version of the sd patch is that of September 17, 2021?
Thank you.

rinski

  • New to the forum
  • *
  • Posts: 46
Re: UHS-I / SD cards investigation
« Reply #763 on: April 28, 2022, 08:11:21 PM »
card full
load error 0:ML/CROPMKS/16_9.bmp

lightspeed

  • Freshman
  • **
  • Posts: 58
Re: UHS-I / SD cards investigation
« Reply #764 on: May 01, 2022, 01:31:40 AM »
it seems to work if you disable the aspect ratio as well.

theBilalFakhouri

  • Developer
  • Hero Member
  • *****
  • Posts: 863
Re: UHS-I / SD cards investigation
« Reply #765 on: June 12, 2022, 07:48:19 PM »
I did some tests on 100D, it doesn't accept 240 MHz overclock at all (*both 5D3 and EOSM does for some time @ 240 MHz but not practical), tried with only write benchmark and with *forcing patch*, no sign of working 240 MHz overclock on 100D.

*on 5D3 240 MHz does work but only for write operations, read operations won't be possible. on EOS M it does work with *forcing patch* but not stable until the card become inaccessible.
BTW, 240 MHz does work on 650D/700D/6D/70D without a problem (with compatible card).

Personally I won't touch UHS stuff again until I get the following:
Xilinx QEMU includes UHS emulation (along with some other nice stuff) and is based on QEMU 2.6.x (at the time of writing). Currently we have patches for QEMU 2.5.0 and 2.9.0, and for the Xilinx version, it will be something in-between. If there is interest, I can commit the patches.

It might be easier to spot the differencees among e.g. 100D and 700D regarding SD configurations using QEMU.
New custom build for 100D/SL1 is up:
https://www.magiclantern.fm/forum/index.php?topic=26511.msg239125#msg239125
Porting still work in progress!

names_are_hard

  • Developer
  • Senior
  • *****
  • Posts: 478
  • 200D idiot
Re: UHS-I / SD cards investigation
« Reply #766 on: June 12, 2022, 08:01:37 PM »
Qemu 4 also looks to have UHS-I support.

theBilalFakhouri

  • Developer
  • Hero Member
  • *****
  • Posts: 863
Re: UHS-I / SD cards investigation
« Reply #767 on: June 12, 2022, 08:16:00 PM »
QEMU 4 doesn't have DebugMsg I think?
I am asking for something ready to work with :P QEMU 4 might need some patches too :-\

If you managed to run card benchmarks using QEMU 4 with e.g. DIGIC 5 or 7/8 model ROMs and if benchmarks matched reality benchmarks numbers, please let me know :D
New custom build for 100D/SL1 is up:
https://www.magiclantern.fm/forum/index.php?topic=26511.msg239125#msg239125
Porting still work in progress!

names_are_hard

  • Developer
  • Senior
  • *****
  • Posts: 478
  • 200D idiot
Re: UHS-I / SD cards investigation
« Reply #768 on: June 12, 2022, 08:24:56 PM »
What would demonstrate support for (or lack of) DebugMsg in Qemu 4?

I'd never expect emulated hardware to match benchmark numbers on a physical cam.  What are you trying to check for?

lightspeed

  • Freshman
  • **
  • Posts: 58
Re: UHS-I / SD cards investigation
« Reply #769 on: June 12, 2022, 11:53:10 PM »
Hello, could you explain to us how the lua script is disabled, it gives me an error and the version of the sd patch is that of September 17, 2021?
Thank you.


I just disabled it so it didn't run at startup. once I did that it seemed to work pretty good. but only on a 64 gb card. not sure why it doesn't work on others all the time.

lightspeed

  • Freshman
  • **
  • Posts: 58
Re: UHS-I / SD cards investigation
« Reply #770 on: June 19, 2022, 10:38:52 PM »
it also gets a little hot. 50 c.

can the camera run at 50? will that harm it?

Skinny

  • Member
  • ***
  • Posts: 166
Re: UHS-I / SD cards investigation
« Reply #771 on: June 20, 2022, 09:53:52 AM »
I used to run 550D at 60 degrees or even more for hours.. for timelapses in video mode with slow fps. Red thermometer sign was there, but camera didn't turn off. Although it should at some point of overheat. I still use this camera sometimes without any problems, didn't even noticed any increased sensor noise (it was noisy before, it is noisy now, lol)

lightspeed

  • Freshman
  • **
  • Posts: 58
Re: UHS-I / SD cards investigation
« Reply #772 on: July 02, 2022, 03:57:53 AM »
if you format your card on Mac with the following it seems to make it work.

sudo news_exfat -c 4 disk2s1


replace disk2s1 with whatever disk you have.

Walter Schulz

  • Contributor
  • Hero Member
  • *****
  • Posts: 8303
Re: UHS-I / SD cards investigation
« Reply #773 on: July 02, 2022, 09:35:22 AM »
Are we talking about emulation here?
We have an open issue with illegal directory/folder attributes with ExFAT and Big Sur (or up). https://www.magiclantern.fm/forum/index.php?topic=25656