Author Topic: Full-resolution silent pictures (silent.mo)  (Read 648503 times)

josepvm

  • Member
  • ***
  • Posts: 212
Re: Full-resolution silent pictures
« Reply #725 on: April 21, 2015, 06:15:24 PM »
During my test yesterday on 500D (nightly 2015 March 29th) expo override worked fine for my STM lenses, as I already posted.

But now I've tested it also on my recently purchased EOS M. And there is really a problem with STM lenses.

Lenses I have tested (EOS-M nightly 2015 April 14th)

- EF-M 18-55mm STM   Expo override does not work, exposure in FRSP does not change at all when changing aperture.
- EF-M 11-22mm STM   Same behaviour, expo override does not work
- EF-M 22mm STM  Exposure in FRSP does not change when going from F2.0 to F11, but there is some degree of exposure reduction at F16 and F22

Using the EF to EF-M adapter on EOS M I get:

 - EF 50mm f1.8 and several EF-S USM lenses: expo override works Ok.
 - EF-S 24mm STM:  same behaviour as EF-M 22mm STM prime, exposure only changes for F16 and F22
 - EF-S 18-55mm STM and EF-S 55-250mm STM: same behaviour as EF-M zooms, expo override not working, exposure does not change at all.

Tonight I will repeat tests on 500D with a more recent nightly.



 


Licaon_Kter

  • Hero Member
  • *****
  • Posts: 519
  • M
Re: Full-resolution silent pictures
« Reply #726 on: April 21, 2015, 07:02:04 PM »

- EF-M 18-55mm STM   Expo override does not work, exposure in FRSP does not change at all when changing aperture.
- EF-M 11-22mm STM   Same behaviour, expo override does not work
Yep, confirmed the same behaviour with my own EF-M 18-55mm STM

josepvm

  • Member
  • ***
  • Posts: 212
Re: Full-resolution silent pictures
« Reply #727 on: April 21, 2015, 10:30:57 PM »
Tested again on 500D, with nightly 2015 April 19th. Expo override works well with my EF-S STM lenses (18-55mm, 55-250mm and 24mm).

It seems that on the old 500D the STM, USM and micromotor lenses work all in the same way (it makes sense, STM lenses did not exist when 500D was launched). But in newer cameras (optimized for STM lenses, with phase detection AF on the sensor), probably the STM lenses are corntrolled in a different way...

 

Slasheal

  • New to the forum
  • *
  • Posts: 26
Re: Full-resolution silent pictures
« Reply #728 on: April 21, 2015, 11:54:50 PM »


Video related to the aperture problem with STM lens as promised.
Same problems as stated before.

It's funny to see that I'm kind of the first to point out that problem.
I'm glad to see that it wasn't only a mistake from me :)

Lens tried:

10-18 STM
55-250 STM


pontop

  • New to the forum
  • *
  • Posts: 3
Re: Full-resolution silent pictures
« Reply #729 on: April 22, 2015, 11:14:34 PM »
I do high magnification stacked macro pictures and am really thrilled by the full res silent function. For high magnification vibration is a big problem and one way to solve it is by using flash. I am planning for a circuit that will let me trigger the silent shooting, wait a defined time and then fire the flash.
I noticed that after taking a picture I need to half press the shutter again. Is there a way around that? To let the camera automatically return to live view after taking the silent picture?

I was told that there is considerable variation in the delay between pressing the shutter and taking the picture from standard live view - at least on the EOS Ti1. Do you know if that is also the case for silent pictures? Has anyone measured the time from the half-press shutter to the clearing of the sensor is done?

/Bo

Matheus

  • New to the forum
  • *
  • Posts: 19
Re: Full-resolution silent pictures
« Reply #730 on: April 27, 2015, 04:10:37 PM »
During my test yesterday on 500D (nightly 2015 March 29th) expo override worked fine for my STM lenses, as I already posted.

But now I've tested it also on my recently purchased EOS M. And there is really a problem with STM lenses.

Lenses I have tested (EOS-M nightly 2015 April 14th)

- EF-M 18-55mm STM   Expo override does not work, exposure in FRSP does not change at all when changing aperture.
- EF-M 11-22mm STM   Same behaviour, expo override does not work
- EF-M 22mm STM  Exposure in FRSP does not change when going from F2.0 to F11, but there is some degree of exposure reduction at F16 and F22

Using the EF to EF-M adapter on EOS M I get:

 - EF 50mm f1.8 and several EF-S USM lenses: expo override works Ok.
 - EF-S 24mm STM:  same behaviour as EF-M 22mm STM prime, exposure only changes for F16 and F22
 - EF-S 18-55mm STM and EF-S 55-250mm STM: same behaviour as EF-M zooms, expo override not working, exposure does not change at all.

Tonight I will repeat tests on 500D with a more recent nightly.



 



Add the 18-135mm STM to this list, I've tested it yesterday on my 70D (firmware 1.1.1B) and it wouldn't work even with Expo Override...
Cams: Canon 70D (70D.111B)
Lens: EF-S18-135mm f3.5-5.6STM, Sigma UC 70-210mm f4-5.6, Helios 44M4-MC 58mm f2
Audio: Zoom H4n + Rode Videomic Pro

Licaon_Kter

  • Hero Member
  • *****
  • Posts: 519
  • M
Re: Full-resolution silent pictures
« Reply #731 on: April 27, 2015, 05:19:07 PM »

It's funny to see that I'm kind of the first to point out that problem.
The slow speed ( max 1/4 ) kinda duped me, a lower aperture was not wanted/needed anyway, hence this got away.

Greg

  • Contributor
  • Hero Member
  • *****
  • Posts: 607
Re: Full-resolution silent pictures
« Reply #732 on: April 27, 2015, 09:13:29 PM »
500D VSizeSetting :

Code: [Select]
Tv Time Acc loop
1/4000 10 114 1
1/3200 10 114 1
1/2500 10 114 1
1/2000 10 114 1
1/1600 10 114 1
1/1250 10 114 1
1/1000 10 114 1
1/800 10 114 1
1/640 10 114 1
1/500 10 114 1
1/400 11 125 1
1/320 12 137 1
1/250 13 148 1
1/200 14 160 1
1/160 15 171 1
1/125 17 194 1
1/100 19 217 1
1/80 21 240 1
1/60 25 285 1
1/50 30 342 1
1/40 33 377 1
1/30 41 468 1
1/25 51 582 1
1/20 59 674 1
1/15 73 834 1
1/13 93 1062 1
1/10 109 1245 1
1/8 138 1577 1
1/6 177 2022 1
1/5 209 2388 1
1/4 268 91 2
0.3" 345 971 2
0.4" 409 1702 2
0.5" 528 3071 2
0.6" 682 1805 3
0.8" 809 240 4
1" 1047 2960 4


runtheearth

  • New to the forum
  • *
  • Posts: 2
Re: Full-resolution silent pictures
« Reply #733 on: April 29, 2015, 10:14:23 PM »
Hi, I have just download Magic lantern (•magiclantern-Nightly.2015Apr28.5D2212.zip
•Built on: 2015-04-28 00:10:02 +0200) to test full resolution on silent mode and after successfull installation, I have followed this steps I found in this fórum on my camera 5d mark II

1.) Prefs tab -> Config files -> Restore ML default
2.) Restart cam
3.) Activate Silent.mo
4.) Restart cam
5.) Put cam to M mode
6.) Activate FRSP (Shoot tab -> Silent Picture -> Silent Mode -> Full-res)
7.) Activate Liveview
8.) Press shutter half

But I do not get anything. There is a message in orange letters:
"full-res pictures only work in manual (M) photo mode"

but I am already in M photo mode and manual focus.
so I am wondering, Am I missing something in this basic tutorial?

I have got success on Silent mode -> simple: dng and mlv format works great.
Resolution I got is: 1880*1250px.
Also, I cannot see dng and mlv pictures on camera. Only in computer.
Of course, I have load modules: pic_view, file_man and mlv_play and restart cam.
If I take mlv raw video I can see it on my camera but I can not see simple pictures.

Any suggestion? Something I am doing wrong with 5d mark II?
 
thanks,
5d mark II, with ML nightly builds; lens 35mm 1.4 L

a1ex

  • Administrator
  • Hero Member
  • *****
  • Posts: 12564
Re: Full-resolution silent pictures
« Reply #734 on: April 29, 2015, 10:37:28 PM »
Since you can record MLV videos, you are probably in movie mode. Switch to photo mode.

runtheearth

  • New to the forum
  • *
  • Posts: 2
Re: Full-resolution silent pictures
« Reply #735 on: April 29, 2015, 11:50:24 PM »
thank you so much. You are right.
I was in "stills+movie". I have changed Live view to "stills only".

So basic tutorial for beginners like me would be like this:


camera: 5d mark II
0.1) Set camera to photo mode: Live view settings: stills only
0.2) Set quality RAW+L

1.) Prefs tab -> Config files -> Restore ML default
2.) Restart cam
3.) Activate Silent.mo
4.) Restart cam
5.) Put cam to M mode
6.) Activate FRSP (Shoot tab -> Silent Picture -> Silent Mode -> Full-res)
7.) Activate Liveview
8.) Press shutter half

:)
5d mark II, with ML nightly builds; lens 35mm 1.4 L

Licaon_Kter

  • Hero Member
  • *****
  • Posts: 519
  • M
Re: Full-resolution silent pictures
« Reply #736 on: April 30, 2015, 12:32:17 AM »

3.) Activate Silent.mo
you need mlv_rec.mo loaded too for saving in .MLV
also press * for AF ( if you set up back-button focus that is )

Slasheal

  • New to the forum
  • *
  • Posts: 26
Re: Full-resolution silent pictures
« Reply #737 on: May 01, 2015, 10:15:53 PM »
I really want exposure overide to work with my stm lenses... So if there's any test I can to help you determine what's the problem, just tell me :)

Matheus

  • New to the forum
  • *
  • Posts: 19
Re: Full-resolution silent pictures
« Reply #738 on: May 02, 2015, 03:18:42 AM »
Press the DOF preview button then turn the lens like 45 degrees. It should disconnect the electronics and lock the aperture to what you set (just make sure the lens is still on camera)

Old trick, but works for STM
Cams: Canon 70D (70D.111B)
Lens: EF-S18-135mm f3.5-5.6STM, Sigma UC 70-210mm f4-5.6, Helios 44M4-MC 58mm f2
Audio: Zoom H4n + Rode Videomic Pro

Slasheal

  • New to the forum
  • *
  • Posts: 26
Re: Full-resolution silent pictures
« Reply #739 on: May 02, 2015, 03:38:37 PM »
Thanks for the tip, already knew it. It's a good technique since if you use ETTR with a tiny aperture, it will force the shutter speed to go above 1/10th, and then no much troubles.
Still, i d prefer to have aperture control over stm lenses, of course :) .

Also, ETTR should have a feature that set max and min shutter time (you can only set the slowest shutter) and also max and min aperture. Shouldn't be too hard to implement I hope.

It would then make ETTR usable for Timelapsers. :p
I have read that I'm not the only one wanting to use it for timelases... The only problem is when shutter goes way above 1/10th...
So meta data for LRTimelapse are unusable.

Also, when using "take pics like crazy" it a bit of struggling to change the parameters manually without introducing shake in the picture, because it needs a lot of try because taking effect.


I bought a cheap ND filter: will do the job to help me with exposure. And I just have made a 2k picture timelapse... Overexposed when I felt asleep. Ahahaha. I thought that the weather would have been more shady :( I will try to get used to doing timelapses.. And then my project as a low-budget-student, is to do a timelapse of the city where I'm studying :) I'm also composing a music, I will gladly share it with you.
Thanks :)

DeafEyeJedi

  • Hero Member
  • *****
  • Posts: 3401
  • 5D3 | M1 | 7D | 70D | SL1 | M2 | 50D
Re: Full-resolution silent pictures
« Reply #740 on: May 02, 2015, 06:06:48 PM »
Looking forward to your work @Slasheal!
5D3.113 | 5D3.123 | EOSM.203 | 7D.203 | 70D.112 | 100D.101 | EOSM2.* | 50D.109

Licaon_Kter

  • Hero Member
  • *****
  • Posts: 519
  • M
Re: Full-resolution silent pictures
« Reply #741 on: May 10, 2015, 03:25:25 PM »
Add the 18-135mm STM to this list, I've tested it yesterday on my 70D (firmware 1.1.1B) and it wouldn't work even with Expo Override...
On my M I had a whole afternoon of fun with the EF/S to EF-M converter and a Canon EF 100mm f/2.8 L IS USM, nice lens, BUT it behaves the same, neither normally nor with ExpOverride, trying to make a FRPS goes to max apperture ( 2.8 ) and snaps an overexposed pic even if I set it up for the lowest apperture ( 32 )  :(

Slasheal

  • New to the forum
  • *
  • Posts: 26
Re: Full-resolution silent pictures
« Reply #742 on: May 11, 2015, 09:22:51 PM »
With the new 50mm 1.8 STM coming... We will need a fix  :o

garry23

  • Contributor
  • Hero Member
  • *****
  • Posts: 2210
Re: Full-resolution silent pictures
« Reply #743 on: May 12, 2015, 12:50:39 AM »
I'll most probably get 'told off' for this post, but here goes.

I think many understand the limitations of full silent DNGs (FSDs), but some still think FSDs will simply replace normal shutter actions.

Maybe FSDs will get better, as gurus find tweaks, but from what I understand we will always see a shutter shortfall in the FSDs.

I was thus wondering whether it would be possible to 'hardwire' in the shutter limitations. In other words when shooting FSDs, only ML can control!set the shutter, ie lock out Canon control.

Doing this will bring in some realism and things can be adjusted as alternative ways are found to extend the FSD range.

As I say, just a thought.

DeafEyeJedi

  • Hero Member
  • *****
  • Posts: 3401
  • 5D3 | M1 | 7D | 70D | SL1 | M2 | 50D
Re: Full-resolution silent pictures
« Reply #744 on: May 12, 2015, 06:05:19 PM »
Definitely an interesting thought, @garry32!
5D3.113 | 5D3.123 | EOSM.203 | 7D.203 | 70D.112 | 100D.101 | EOSM2.* | 50D.109

Slasheal

  • New to the forum
  • *
  • Posts: 26
Re: Full-resolution silent pictures
« Reply #745 on: May 13, 2015, 07:29:18 PM »
I just realised that aperture work with my stm lenses.. on video mode.

tidelander

  • New to the forum
  • *
  • Posts: 8
Re: Full-resolution silent pictures
« Reply #746 on: May 26, 2015, 11:52:13 PM »
I just spent several days testing full-res silent pictures functionality.
I used ML nightly build for 5d3 from April 28, 2015.
I tested silent pictures with 2 lenses: EF 24mm f/2.8 IS USM and EF 100mm f/2.0 USM.
Setting aperture does not work on 24mm lens. The photo is always taken on the widest aperture which is f/2.8 for this lens.
Here are 2 images.


Left one is a master CR2 image taken with all ML settings off. I had to put markers indicating distance from tripod in my backyard :)
The camera was focused on the nearest marker '.8'. Aperture set to f/22. You see that all the markers are in focus.
Right image is MLV image taken with 'silent.mo' and 'mlv_rec.mo' modules. Silent picture settings were set to 'full-res'. Exposure simulation and exposure override were enabled in ML menu.
Camera was focused on the same point.
However, the picture was taken at f/2.8.
At the same time setting aperture works with EF 100mm f/2.0 USM on the same camera with same ML build.
Summary:
1. Liveview says that picture will be taken at f/22.
2. Exif says that picture was taken at f/22.
3. Actual picture was taken at widest open aperture.
4. Setting aperture does not work on EF 24mm f/2.8 IS USM and works on EF 100mm f/2.0 USM.

Quote
Sounds like expo override may not work with STM lenses. Any other STM lens users can confirm?

EF 24mm f/2.8 IS USM is not STM lens, but aperture does not work on it too.

domasa

  • Member
  • ***
  • Posts: 108
Re: Full-resolution silent pictures
« Reply #747 on: June 01, 2015, 12:06:57 AM »
for ML-developer:
I have 5DII. Is the problem "Exposure too long (max 16)." in settings in Canon menu?
( Live View/Movie func. set. > Metering timer > 16 sec. )
Can higher value could help?

dmilligan

  • Developer
  • Hero Member
  • *****
  • Posts: 3218
  • 60Da / 1100D / EOSM
Re: Full-resolution silent pictures
« Reply #748 on: June 01, 2015, 01:29:36 AM »
Please read the OP (the "Limitations" section). A detailed technical explanation of the limitation can also be found in this thread.

mothaibaphoto

  • Senior
  • ****
  • Posts: 392
  • pesky kid
Re: Full-resolution silent pictures
« Reply #749 on: June 13, 2015, 03:31:37 PM »
I confirm that
... Setting aperture does not work on EF 24mm f/2.8 IS USM ...
with FRSP. When I try to close diaphragm with rear wheel - it closes a bit, than opens again. I found the only way to make it works - move photo/video switch to video mode. Yes, I got 1/30 exposure time. Maybe it's possible to solve this "video" exposure time limitation with FPS override, for example - i didn't try.