[WONTFIX - DISABLED] Movie mode remap (problems)

Started by a1ex, June 28, 2012, 03:14:24 PM

Previous topic - Next topic

0 Members and 1 Guest are viewing this topic.


I'm having some issues with movie mode remap (and ISO+LV). There were also a few bug reports on it (500D: black screen, 60D: not remembering settings).

Today I've got ERR70 on 60D by doing this:
1) started camera in M mode;
2) enabled LiveView;
3) pressed ISO+LV to go to movie mode;
4) pressed REC => instant ERR70.

I've tried with a minimal code base (the only extra code was switching to movie mode after 10 seconds). Still ERR70. After clearing Canon settings the problem disappeared, but it clearly shows that there's something fishy with this feature.

I'm seriously thinking to disable movie mode remap completely. Suggestions?


Personally I use less ISO+LV than movie mode remap, but for stability I think that will do the change (maybe is even better but i'm used with a-dep now)
I'm using ML2.3 for photography with:
EOS 600DML | EOS 400Dplus | EOS 5D MLbeta5- EF 100mm f/2.8 USM Macro  - EF-S 17-85mm f4-5.6 IS USM - EF 70-200mm f/4 L USM - 580EXII - OsX, PS, LR, RawTherapee, LightZone -no video experience-


Technically, both are movie mode remaps (they work in the same way internally - by changing PROP_SHOOTING_MODE). But the remapped movie mode certainly borrows some things from the mode you were before (and this is camera-specific).


I just tried to duplicate your error and cannot. I've tried from P, M, TV. I've had no problems with either the remap or increased/moved memory. In fact this seems like the fastest and most stable build yet.

The zoom on AF point has been driving me nuts tho. It zooms on that point even when I turn it off and the point doesn't flash.

Without remap on 600D movie mode is waaaaaaaaaaaay too far from any normal shooting modes. I have to turn through 8 useless modes before getting to movie.


I also can no longer duplicate the error after cleaning the settings, but I can notice differences between movie remapped to C and normal movie.

The problem with the recent memory tricks is ERR70 when you change ISO NR (at least on 60D). This is a clear sign that it's interferring with normal shooting. I've narrowed it down to the shoot_malloc call.

1%: how does ML feel with 5908947bf583 stability-wise? and how much free memory do you have with it?


I have to compile it and try it. I kinda wanted to keep the memory so I was waiting to see what happened. Also the movie mode+LV remap, I've had no problems with these functions on 600D.

As for noise reductions when I go to change them from the custom function no error 70. When I turn on strong reduction it shows BUSY on the screen and VF and I can't take a photo. Everything else is fine. Behavior repeats in JPEG mode. Also, I've NEVER reset my settings and run the 1.0.2 on 1.0.1 :)

**** Ok I get 334K/1053K... only 991K in movie mode.... after a few switches around 950K
See the new LV to Movie is a bit slower. That's about it so far. Was this how it was done on 550D?


Running the stability test... right now too... I'll see what happens. I wanna say i liked the other memory setup more but it screws the in camera NR people.

*The tests drained my battery but didn't see any errors. Lowest the memory got was 922k.


Sounds good. After you use the camera for a while (take a few pics, record a few clips), can you take a screenshot for Debug menu? (on 60D I can't).

The BUSY thing from changing ISO NR was also on 60D (before ERR70). But it's gone with latest changeset.


I can take a pic of the debug menu with phone/400d, etc. Maybe run a little bit more of quick test... that got memory down to the lowest.

After all this memory stuff (both exmem and new) movie mode seems more stable... I don't get as many stopped recording errors even on 1250+ with 1.4-1.9x rates. Used to crash often on the first start... I think someone had an issue open on this but it was inconclusive.


Debug shot while test was running.


I mean the screenshot function in ML.

After playing a while with movie mode remap (going back and forth to C) I've managed to break movie mode completely on 60D (black screen). So this feature will go away right now. Sorry.

Movie mode works again after clearing settings.


I've yet to do that. The worst I've done is to crank the bit rate and lose all camera control. Can't turn it off, no more ML menu, no buttons work, but screen keeps updating.  No difference between instant movie mode and delayed movie mode on 600D. 60D must be different.


I've done all my test so far with movie mode enabled with a-dep since using ML probably, so I can't say if there is something different from real movie mode, I'll try it soon but in those days i'm a bit busy.
I think that a stable release now is more important than having a lot of functions that, in the end, are a bet to use.
So even if movie remap is one of the first thing I set up when starting with a default configuration, I'm agree with removing it from the next release but I'll suggest to keep it a feat to add/fix in future (maybe other changes will make it works ok like what happened to trap focus).
Hope to see in future a fully re-configurable mode dial ;)
I'm using ML2.3 for photography with:
EOS 600DML | EOS 400Dplus | EOS 5D MLbeta5- EF 100mm f/2.8 USM Macro  - EF-S 17-85mm f4-5.6 IS USM - EF 70-200mm f/4 L USM - 580EXII - OsX, PS, LR, RawTherapee, LightZone -no video experience-


The problem here is that only changing PROP_SHOOTING_MODE (with no other ML code running on the camera) still causes problems (same behavior as will full ML loaded). So, at least for now, I have no idea what I can do to fix it. Probably there is a higher-level wrapper function that I should call for changing the mode, but this should be found by reverse engineering.

Anyway, decision was taken. You can suggest even more useless things to remove.


Ran 15 minute test last night and had no problems. Too bad it breaks 60D + other cameras. I've done everything in a-dep movie mode and never noticed a difference.

Useless features... I dunno. Flash light: my screen just turns white and gives off less light than my phone :)

AV Mercenary

I'll really miss the movie mode remap. It's the only way I've been shooting any of my films and tests projects with my 60D since ML has been ported to it. Just tried rolling the dial back from M to Movie takes so long with that darn locking wheel, you can miss your shot if it's something spur of the moment.

Though I do have a few occasional crashes, the camera gets hung up and won't respond unless I remove the battery when I am shooting video.

I hope to see it back in a future release.
Anthony Verderosa
Visual Effects Artist/Cinematographer


The only way to get it back is to show me a way to call it safely. For this you need reverse engineering skills.

Testing does not help at this stage. The probability of things going wrong because of this feature is small, but nonzero.


I had my first lockup by doing ISO+LV in M and then flipping to A-Dep. Makes sense that this action crashes the camera though.


a1ex I have to put my 2 cents in too on the removing the remap to A-Dep feature.  I have 2 550D and I have friends that have them as well. 

There are many features that I like with ML but I really find the remap useful.  It is MUCH more convenient, everyone in my group uses it and does not have issues unless you are trying to do something really quickly/unnaturally.  Is there any way to leave the feature in a USE at your OWN RISK option?

It would be a real bummer to have to step backward in capability?

Thanks again for all your hard work, we in the dslr filming community certainly appreciate all this group has done!!


You can still use it at your own risk - nobody is stopping you from compiling a custom version with it enabled.

But please don't ask me to release something that has the potential of causing permanent camera damage. I'm 100% sure it can - it happened on my own 60D, but I was lucky that I still had access to Canon menus to clear the settings and bring the movie mode back.

Have a nice reading: http://groups.google.com/group/ml-devel/browse_thread/thread/802d76120a9f5472


I left it on in my repository but I've only made 600D binaries. I've made some unified but only on the stock branch.


That sucks.
I really liked Movie Mode at A-Dep on my 550d....
A lot.......
At the very least, it certainly was not a "useless feature"....
Alas, a true risk of permanent damage is not a reasonable gamble.
I guess I'll live.


i never really had issues with the CA movie mode remap on my 60D
I understand that it is better to remove it from the menu at this point. I hope to see it back in action one day though!

Matthew Kieren

Shoot, that sucks since I use this feature constantly. I wouldn't call it a useless feature since turning that dial all the way is such a pain with that *!@#&$% locking mechanism on my 60D, but I completely understand the reasoning behind disabling it. Better safe than sorry. Anyway, I too would love to see this feature return at some point if it can be deemed safe.

Canon 60D, 18-55mm IS, 55-250mm IS, Tascam DR-40
SMC Pentax-M 50mm f/1.4, Yongnuo YN560-II


There is a situation where i can go in movie mode with the dial on another mode (I was in M when found), it's rack focus rec start, is this dangerous too?
I'm using ML2.3 for photography with:
EOS 600DML | EOS 400Dplus | EOS 5D MLbeta5- EF 100mm f/2.8 USM Macro  - EF-S 17-85mm f4-5.6 IS USM - EF 70-200mm f/4 L USM - 580EXII - OsX, PS, LR, RawTherapee, LightZone -no video experience-


Technically, that one is movie mode remap too, so potential side effects are the same.

One more side effect on 60D: going from movie to photo via remapping result in impossibility to take pictures.