Author Topic: Canon 5D Mark II / 5D2  (Read 602336 times)

SoyLeo

  • New to the forum
  • *
  • Posts: 6
Re: Canon 5D Mark II / 5D2
« Reply #650 on: February 07, 2018, 08:25:11 PM »
Hello Dfort, I have problems with the 5d2 version raw_video_10bit_12bit.2018Jan27.5D2212 and raw_video_10bit_12bit_LVState-wip.2018Feb04.5D2212, error loading the modules after activating them, the magiclantern-Nightly.2018Feb04.5D2212 vesrion works without problems





I also have a 7D and the raw_video_10bit_12bit.2017Dec12.7D203 version works without problems

SoyLeo

  • New to the forum
  • *
  • Posts: 6
Re: Canon 5D Mark II / 5D2
« Reply #651 on: February 07, 2018, 08:32:30 PM »
Pleaaaassseeeeee  ;D :D :D :D

reddeercity

  • Contributor
  • Hero Member
  • *****
  • Posts: 2054
Re: Canon 5D Mark II / 5D2
« Reply #652 on: February 08, 2018, 04:36:31 AM »
That's because 5D2 is not supported , It doesn't work because of raw_slurp is not implemented and my never as there problems in Vsync in liveview .
If you want to help make it work , start here read the next 10 page , then you will be up to date .
Setup a development environment , very easy to do there many tutorial on the forum from starting from scratch to a per-loaded VM OS ready to compile magic lantern nighty builds

dfort

  • Developer
  • Hero Member
  • *****
  • Posts: 3718
Re: Canon 5D Mark II / 5D2
« Reply #653 on: February 08, 2018, 05:04:24 AM »
Another problem is that you are loading way too many modules. Activate only mlv_lite--nothing else, at least for now. If you look at the source code of my experimental raw_video_10bit_12bit_LVState-wip branch you'll notice this:

platform/5D2.212/internals.h
Code: [Select]
/** this method bypasses Canon's lv_save_raw and slurps the raw data directly from connection #0 */
#define CONFIG_EDMAC_RAW_SLURP
#define CONFIG_ALLOCATE_RAW_LV_BUFFER

So is raw_slurp really working? You tell me.
5D3.* 7D.206 700D.115 EOSM.203 EOSM2.103 M50.102

reddeercity

  • Contributor
  • Hero Member
  • *****
  • Posts: 2054
Re: Canon 5D Mark II / 5D2
« Reply #654 on: February 08, 2018, 05:12:22 AM »
I think there must be something , as you do have some very good success with it on 7d (digic4) so you would think 5d2 (digic4) should be similar in success .
 

reddeercity

  • Contributor
  • Hero Member
  • *****
  • Posts: 2054
Re: Canon 5D Mark II / 5D2
« Reply #655 on: March 16, 2018, 07:07:42 AM »
Playing around with the new experimental 1:1 Liveveiw in 12bit @ 1856x1044 23.976fps +audio (full mlv_rec+audio)
every one can get up to speed on this in this post on the 10-12bit thread .
I really like this 12bit better then 14bit , I more pleasing cinematic image and real pleasure to grade .
I did the classic Quick Mount in Win7 then import to CS6 A.E. in ACR exported as
tiff --> Mac compressor -->prores4444xq --> FCPX film convert pro , red mx camera source --> export frame
link to frames
M11-0006_002688.dng  no-grade.png  full grade_black backgound   full grade_white backgound

By the way it's just my ugly old face -- so you being warned  :P

original dng exported CS6A.E. full grade

Edit: shot at 70mm (24-70f2.8L canon) F4 200 ISO @ 1/53th second (closest I can get to 1/48) and no preprocessing with mlv_dump option
 

benoit

  • New to the forum
  • *
  • Posts: 26
Re: Canon 5D Mark II / 5D2
« Reply #656 on: March 16, 2018, 09:57:25 AM »
Well done Reddeercity  :) !
Thanks to keep up the good work on 5D2 !
I'm a little bit scary about the channel 02 and aex1's warning ...
so when the right channel will be found, I will test it for sure !
Which picture size did you try with success in 12bit crop 1:1 23,96hz ? 1920x1076 ?
Thanks

reddeercity

  • Contributor
  • Hero Member
  • *****
  • Posts: 2054
Re: Canon 5D Mark II / 5D2
« Reply #657 on: March 19, 2018, 05:30:59 AM »
Well done Reddeercity  :) !
Thanks to keep up the good work on 5D2 !

@benoit thanks but,
I'm just one very small part of the whole picture on the forum  -- It's never just one person , even though it may seem like it .
It's dozen if not hundreds of users making contribution , even if it's just researching info about chips sets of reading disassembly rom strings or
reading  (dm-log) for memory address performing image_dumps , running logs to capture different camera process e.g. (Lossless compression)  etc. ...
I could go on & on , It's much more then just coding (of would I know very little about , but enough to follow along & make changes will maybe a little more then that)
So don't be afraid to participate , all is welcome .

I'm a little bit scary about the channel 02 and aex1's warning ...
so when the right channel will be found, I will test it for sure !
take this with a grain of salt  :D
see my statement on the beginning of this post , that the point . I would like people to get involved to help solve problems like this .
The right channel can be found if more people help.

Which picture size did you try with success in 12bit crop 1:1 23,96hz ? 1920x1076 ?
This only works in 1:1 liveview not 3x Crop_mode hence the name of the build "magiclantern-10_12bit_broken_3xcrop_mode_2017Dec10.5D2212.zip"
So to recap 12bit 1:1 liveview works up to 1856x1044 (max res)@ 23.976 (with frame override enabled to exact) + audio on the mlv_rec module plus
HDMI works with Evf or hard drive recorder e.g. atomos ninja etc. ....

3x crop mode is totally corrupted when recording in all bit depths , if you are looking for stable 3x crop_mode 10 & 12bit then use the old dec 2016 build with bit reduction
look in my bitbucket downloads ,  https://bitbucket.org/reddeercity/magic-lantern_10-12bit/downloads/
10bit @ 2144x1076 @ 23.976 is continuous (mlv_rec) 12bit would still be limited to resolution & writing band width (75MB/s) in 3xcrop mode
I never really check but I would think 1920x960 @ 23.976 should be ok , you may get more vertical resolution up to 1076 .




clanlee

  • New to the forum
  • *
  • Posts: 11
Re: Canon 5D Mark II / 5D2
« Reply #658 on: March 24, 2018, 06:16:00 AM »
Hello.  Long time lurker, first time poster.

First, thank you to everyone for the amazing work that's been done on Magic Lantern.  It's breathing new life into older hardware.

I'm using Magic Lantern (latest nightly build) on my EOS M for non RAW video and it's amazing.  I'm not looking to use RAW anytime soon due to various reasons and am happy with H.264.  The only issue I have with the EOS M is poor ISO performance so I was looking to use my 5D2.  I installed the latest nightly build and everything seems to be working correctly.  The only issue I am running into is the Aliasing on the 5D2.  Compared to the EOS M, it's terrible.  Here's a comparison video shot at f/2.8:

https://youtu.be/uLv__DycyhM

I also shot video at f/8.0 and it's a similar result.

When I shoot RAW on the 5D2, it's amazing but I can't use it due to the crop and file size.  Do I have any hope with my 5D2?

Thank you.

dfort

  • Developer
  • Hero Member
  • *****
  • Posts: 3718
Re: Canon 5D Mark II / 5D2
« Reply #659 on: March 24, 2018, 02:20:24 PM »
@clanlee - wow, that is quite a dramatic comparison.

5D2 H.264


EOSM H.264


Never knew that the EOSM improved on the aliasing issue.

You should be able to pretty much eliminate aliasing by shooting in 5x zoom mode but of course that completely changes the characteristic of the camera because it is using just a small part of the sensor. Another option would be to use a (rather costly) VAF filter.

Just out of curiosity, what are your settings? You might have sharpening turned up. My settings when shooting H.264 are:



A.K.A. Prolost Flat

Start with the Neutral Picture Style
Set Sharpness to zero—all the way to the left
Set Contrast all the way to the left
Set Saturation two notches to the left

@reddeercity is the 5D2 expert so maybe he can share some tips for getting the most out of this camera when using H.264.
5D3.* 7D.206 700D.115 EOSM.203 EOSM2.103 M50.102

clanlee

  • New to the forum
  • *
  • Posts: 11
Re: Canon 5D Mark II / 5D2
« Reply #660 on: March 24, 2018, 06:07:26 PM »
@dfort

I'm using the Cinestyle profile with Sharpness set at 0, Contrast at -4 and Saturation and Color Tone set to 0.  I also tried the Flaat and Neutral and got similar results in regards to aliasing.

Here's the footage with the Prolost Flat profile shot at 35mm @ f/2.8:

https://youtu.be/zDOXZ4Sr0X4

I tried shooting crop mode in H.264 and it looked worse than the non cropped mode.  Just to be sure I did it correct, I pressed the zoom button once (5x) and started recording.  Sound wasn't recorded and when I pulled the video, aliasing was worse than non cropped mode.  The VAF filter is an option if I could find one used.  I would love to continue using my 5D2 but based on my test, I don't think I want to.  A software solution would be ideal.

If I can't get this working, I might try to get a used 5D3.


reddeercity

  • Contributor
  • Hero Member
  • *****
  • Posts: 2054
Re: Canon 5D Mark II / 5D2
« Reply #661 on: March 26, 2018, 08:12:02 AM »
12bit Experimental Raw Video on my 5D2 , It ended up as a development update video for digic iv .  :D
I'm very happy with the image results 12bit hits the Sweet Spot !! No Aliasing and Moiré patterns (at least I can't see any), the skin tones are wonderful
I couldn't get this cinematic  look with 14bit with so little work , MLVFS(pc quick mount) normalize them in A.E. to Tif's  , made a prores4444xq  in compressor graded in FCPX  :D
Keyed the greenscreen , then applied film convert pro "RED MX" for camera source with KD P400 Ptra film emulation .
Can't wait to shoot some projects now in 12bit , I also briefly talk about Lossless & UHD/3.5k
I hope everyone enjoys it


TrEK

  • New to the forum
  • *
  • Posts: 19
  • Canon 5d mk2 , CF Sandisk Extreme PRO 64gb 160MB/s
Re: Canon 5D Mark II / 5D2
« Reply #662 on: March 26, 2018, 09:57:32 PM »
tell me please...
it i will shotinh 14 bit on my Canon 5d mk3 .... and shooting in 1- bit
it will be big difference ?
coz it on 30% less in value

Deadcode

  • Freshman
  • **
  • Posts: 55
Re: Canon 5D Mark II / 5D2
« Reply #663 on: March 27, 2018, 10:31:26 AM »
What is the difference between 1:1 mode and the "normal mode"? It sounds strange to me there are no moire/aliasing in full frame mode. Nice development anyway.

Ilia3101

  • Contributor
  • Hero Member
  • *****
  • Posts: 582
Re: Canon 5D Mark II / 5D2
« Reply #664 on: March 27, 2018, 10:51:20 AM »
So y ou're saying 12 bit fixes moire patterns on the 5D2? very excited to watch the video and test it out...

This means you have somehow changed the binning as a side effect?

 :D
5D2, MLV App

dfort

  • Developer
  • Hero Member
  • *****
  • Posts: 3718
Re: Canon 5D Mark II / 5D2
« Reply #665 on: March 27, 2018, 04:09:24 PM »
I tried shooting crop mode in H.264 and it looked worse than the non cropped mode.  Just to be sure I did it correct, I pressed the zoom button once (5x) and started recording.  Sound wasn't recorded and when I pulled the video, aliasing was worse than non cropped mode.
...
I might try to get a used 5D3.

That's odd--you shouldn't be getting this much aliasing and you should have audio. Your EOSM is working fine in Movie crop and zoom modes, right?





The 5D3 is by far the best camera to use with Magic Lantern and it should perform almost as good as your EOSM.  :P

Just kidding of course but I was thinking why would the EOSM outperform the 5D2 in H.264? The only thing I could think of is that even though the 5D2 has a 21.1 megapixel sensor vs. the EOSM's 18 megapixel, it is spread over a larger area. That means in 3x3 sampling mode the "pixel pitch" of the EOSM is tighter and thus less aliasing. However, that doesn't explain the 1:1 sampling H.264 aliasing issue that you pointed out.
5D3.* 7D.206 700D.115 EOSM.203 EOSM2.103 M50.102

clanlee

  • New to the forum
  • *
  • Posts: 11
Re: Canon 5D Mark II / 5D2
« Reply #666 on: March 27, 2018, 09:13:10 PM »
I think I just have a bad 5D2 copy, at least for video.  Photo is great but the very few times I've tried video in the past, aliasing was very bad.  This was when I tried shooting video on the Canon firmware, without Magic Lantern. 

reddeercity

  • Contributor
  • Hero Member
  • *****
  • Posts: 2054
Re: Canon 5D Mark II / 5D2
« Reply #667 on: March 28, 2018, 07:04:10 AM »
So y ou're saying 12 bit fixes moiré patterns on the 5D2? very excited to watch the video and test it out...
This means you have somehow changed the binning as a side effect?
:D
No I don't think so , all I change was the write channel ,  normally I have very little to no problems with moiré patterns even with h264 .
I'll try to explain my logic : I believe the main issue (be on line skipping) is  motion blur , sharpness & contrast .
For is reason I only use technicolor cinestyle picture style profile for Liveview preview (flat) , I correct my w/b & expose
to that profile . I try to be within f4 to f8 , one thing I do is to expose for shadows instead of exposing for hi-lights .
I usually find most moiré patterns are a issue in the hi-lights (sometime not always)
I know I can always recover hi-lights (with 12+ stops) 99% of the times , drag the shutter a bit (1/43th-ish) , I make sure I have at least a
3 point light setup with more light power (like the sun :)) ) that I need (in the case of the green screen , third light was over top of me instead of behind me)
so I can run lower ISO's (100 , 200 but never over)  . I like to run a little soft on the focus (instead of turn down sharpness in "cinestyle profile)



I use canon "L" lens so not sure if that help too , but what I thing is really helping is the 12bit black level range



So I have to wonder , does 12bit still come from the 14bit silent image 1880x1250 ? or is there another pipe off
the A/D convertor to 12bit & 10bit or a recalculation of the 14bit ? but is really 14bit ?
I know in some of my very early tests with the bit reduction code , I implemented it in the old ml core .
I was abled to get 16bit to save test files , but couldn't decode it .
If you compare 14 to 12 for black levels  1792 to 448 , It seem to be the color sweet spot , can't explain it why just is !
I least to my eye's , You tell me for yourself @Ilia3101 , I'm I wrong ?

I need to do a long 10bit test to see if it's as clean & clear of issue like moiré patterns

sbaklund

  • New to the forum
  • *
  • Posts: 3
Re: Canon 5D Mark II / 5D2
« Reply #668 on: April 10, 2018, 05:19:57 AM »
Just picked up a 5d mk ii and am having issues installing ML.. I'm running latest 2.1.2 with a 1067x sandisk extreme Pro cf.  I've formatted and re-installed ML multiple times but when I go to live view > trash bin the ML menu doesn't show up, nothing has changed. Not sure if its me or the camera / software.

any troubleshooting tips would be much appreciated.

reddeercity

  • Contributor
  • Hero Member
  • *****
  • Posts: 2054
Re: Canon 5D Mark II / 5D2
« Reply #669 on: April 10, 2018, 08:08:54 AM »
Take a short video with a cell phone/iphone  to show what happens when you boot the cam and post here also try :
after bootup press the Liveview button --top left of the small view finder (the red letter B )
 


That should bring up LiveView , you may have to cycle though the Info button to get ML menu (the red letter E)
Did you set the boot flag ? you should have seen a screen like this or very close to it



If you don't set the boot flag magic lantern will not load .
hope this helps


sbaklund

  • New to the forum
  • *
  • Posts: 3
Re: Canon 5D Mark II / 5D2
« Reply #670 on: April 10, 2018, 09:48:20 PM »
I do not see the boot flag. The camera boots and operates as if there is no ML installed.

Here is a video of me booting camera and such:

https://www.dropbox.com/s/pvwprn0986f10oe/Video%204-10-18%2C%2012%2038%2012%20PM.mov?dl=0

Here are the ML files on my card, I assume they are installed properly? Just a simple copy onto the card?





Walter Schulz

  • Contributor
  • Hero Member
  • *****
  • Posts: 6790
Re: Canon 5D Mark II / 5D2
« Reply #671 on: April 11, 2018, 01:08:54 AM »
Top of page -> User Guide -> FAQ/Install Guide
Photogs and videographers: Assist in proof reading upcoming in-camera help!. Your input is wanted and needed!

dfort

  • Developer
  • Hero Member
  • *****
  • Posts: 3718
Re: Canon 5D Mark II / 5D2
« Reply #672 on: April 11, 2018, 02:32:49 AM »
Hint--

"run Firmware Upgrade and follow the instructions."
5D3.* 7D.206 700D.115 EOSM.203 EOSM2.103 M50.102

reddeercity

  • Contributor
  • Hero Member
  • *****
  • Posts: 2054
Re: Canon 5D Mark II / 5D2
« Reply #673 on: April 16, 2018, 06:40:13 AM »
Just did I test with the latest nightly build -- doing a install video tutorial for Fresh CF Card (New , never had ML on it) with the new ml update ML-SETUP.FIR
Code: [Select]
# Magic Lantern Nightly.2018Feb04.5D2212 (36acb0f9c3e2 (unified) tip)
# Built on 2018-02-03 23:10:44 UTC by jenkins@nightly
# Configuration saved on 2018/04/15 21:46:25
beta.warn = 15
When I tested raw (1856x928 @23.976p exact + audio 44.1 kHz) I'm getting a lot of torn frames when I pan .
Sometimes high in the frame and sometimes low in the frame
Starts at frame 39 , 41,42,43,44,45,46,47,49,51,52,54, then starts to do it every 2 frames then a good frame etc.. with the 2 frames the first has tearing high then the next has it low on the frame then the next is good then it repet it's self
this is the first time I had ever had problem with the nightly , not sure what was added or merged but this build is not right , sure be marked as "Failed"
The only other thing I did was I had the HDMI connected while recording raw , which I never had a problem ever before.
Now if it is related to HDMI , Why would this cause corruption ??  never has before  so I have to think some code in liveview has been updated related to JpCore(jpeg chip)
and like always I run with Frame Over ride to exact @ 23.976 from 24 .
Even in my 10-12bit experimental 1:1FHD  build I don't have this issue .
Here the file , it's 750MB 10 second of video , if any one wants to check it out
https://drive.google.com/file/d/18XdoRuctcUCPUkhPddJf7_ziUQlnTjK-/view?usp=sharing
I used two method to view the problem , first with MLVFS QuickMount (Win7) and MLVProducer

reddeercity

  • Contributor
  • Hero Member
  • *****
  • Posts: 2054
Re: Canon 5D Mark II / 5D2
« Reply #674 on: April 16, 2018, 07:18:20 AM »
After looking at the change log , I see a "Merged in garry23"36acb0f some focus.c: stuff the rest is all "MakeFile" can't see that being the problem . https://bitbucket.org/hudson/magic-lantern/commits/0752dd8e7182747ec2ae5caf46ef3c3b06d3b4a6 , this look like it may be a problem , Preview while recording raw back in Aug/18/2017 0752dd8: there seems to a lot of changes to raw.c main 5d3 but it shouldn't cause a problem with 5d2 you would think but there a problem and I don't know how far back the issue go's as I don't ever check new builds I just compile my own with changes I like or need and I still use the old core(1872) for daily stuff.