Author Topic: Help needed with mini_iso calibration for 6D  (Read 2203 times)

Marsu42

  • Contributor
  • Hero Member
  • *****
  • Posts: 1557
  • 66d + flashes
Help needed with mini_iso calibration for 6D
« on: February 02, 2014, 09:41:52 PM »
Yo 6d users (and esp. 1%), your help is needed to get the new mini_iso module working on the 6d:

Alex has now support for it and raw_diag also works on the 6d, problem is that for well known reasons he's currently not too enthusiastic about the whole 6d thing unless some TL back-merging is done. But if someone wants to give it a try and calibrate for the 6d, I'm sure he'll pm you the link to the dev binary.

This needs to be done (again), I did only part of it and haven't got time to continue: https://docs.google.com/document/d/1neb3q36YeQm6HuPTy6-cMmcnVTswsRXSQ-sNSCCLM_Q/edit#

This is what I found:

* the module works, mini_iso @ neutral with 0ev gain settings is identical to Canon & I calibrated it. It does show the desired effect to gain dynamic range - so far, so good.

* problem is: the module refuses to force the values into to the desired white level range set in the options (acr, dcraw, ...). The question is if I did something wrong, or there's something different on 6d than 5d3/60d where it works just fine.

* todo for you: repeat the series so that we can see if my measurements were wrong or the module really isn't working on the 6d as expected.

# --

Here's my 6d calibration:
# Config file for module mini_iso (MINI_ISO.MO)
black.opt = 0
calibrated.gain.100 = -29
calibrated.gain.200 = -32
calibrated.gain.400 = -37
calibrated.gain.800 = -39
calibrated.gain.1600 = -42
calibrated.gain.3200 = -51
calibrated.gain.6400 = -53
calibrated.gain.12800 = -153

Here's the sheet (I didn't do the last row of f0.0), black was always 2047 or 2048, white sometimes changed by a minor amount on multiple tests:

;white/0.0;dr/0.0;white/2.8;dr/2.8;ml/gain;ml/eq.iso
100 Canon;15331;11,458;15498;11,470;-0,29;82
100 ML@0;15331;11,455;15498;11,470;;
100 ML@-1;;;10485;11,802;;
200 Canon;15331;11,450;15498;11,459;-0,32;160
200 ML@0;15331;11,446;15498;11,460;;
200 ML@-1;;;10312;11,768;;
400 Canon;15331;11,304;15498;11,316;-0,37;310
400 ML@0;15331;11,282;15498;11,302;;
400 ML@-1;;;10727;11,649;;
800 Canon;15331;11,072;15498;11,087;-0,39;610
800 ML@0;15331;11,030;15498;11,083;;
800 ML@-1;;;10846;11,403;;
1600 Canon;15331;10,644;15498;10,668;-0,42;1195
1600 ML@0;15331;10,544;15498;10,560;;
1600 ML@-1;;;11025;10,965;;
3200 Canon;15331;10,022;15498;9,858;-0,51;2247
3200 ML@0;15331;9,868;15498;9,867;;
3200 ML@-1;;;11635;10,366;;
6400 Canon;15331;9,280;15500;9,032;-0,53;4432
6400 ML@0;15333;9,040;15500;9,030;;
6400 ML@-1;;;11836;9,555;;
12800 Canon;15331;8,283;15502;8,030;-1,53;4432
12800 ML@0;15334;8,037;15502;8,017;;
12800 ML@-1;;;15500;9,003;;

1%

  • Developer
  • Hero Member
  • *****
  • Posts: 5936
  • 600D/6D/50D/EOSM/7D
Re: Help needed with mini_iso calibration for 6D
« Reply #1 on: February 02, 2014, 09:52:45 PM »
On the one I got I was getting the same calibrations repeatedly.

Marsu42

  • Contributor
  • Hero Member
  • *****
  • Posts: 1557
  • 66d + flashes
Re: Help needed with mini_iso calibration for 6D
« Reply #2 on: February 02, 2014, 10:16:47 PM »
On the one I got I was getting the same calibrations repeatedly.

Same for me, that doesn't seem to be the issue (though the newer module needs other calibration values than you did with the old one).

The problem is that the white level option refuses to work correctly, it does *something* but it certainly doesn't fore the values to the desired range which is essential for proper raw conversion. So if you've got some time on your hands it'd be great if you did the steps alex suggests in the google doc, looking if I did something wrong, and/or of the white level works on your 6d (you never know, you're using a different compiler than me and seem to have less raw issues).

1%

  • Developer
  • Hero Member
  • *****
  • Posts: 5936
  • 600D/6D/50D/EOSM/7D
Re: Help needed with mini_iso calibration for 6D
« Reply #3 on: February 03, 2014, 12:57:59 AM »
Ok, I'll give it a test and see what I come up with. Kung fu my drama continues and I have to merge up 7D stuff with nanomad some time soon so the nightly gets display filters and audio controls.

Also if some of the registers are wrong it may be the problem as the module is closed/private source ATM.

Black level seems to be changing, the white level is not changing in the exif when I do raw digger. I'll try a few with mini ISO vs no Mini ISO.. yep, black level is 100%, white level is no different than canon in exif even when I force it to 10k, etc.

Marsu42

  • Contributor
  • Hero Member
  • *****
  • Posts: 1557
  • 66d + flashes
Re: Help needed with mini_iso calibration for 6D
« Reply #4 on: February 03, 2014, 03:30:25 AM »
Black level seems to be changing, the white level is not changing in the exif when I do raw digger.

Hmmm, with raw_diag the black level is constant = 2048 (or 2047)

I'll try a few with mini ISO vs no Mini ISO.. yep, black level is 100%, white level is no different than canon in exif even when I force it to 10k, etc.

Ok, seems we have to wait for alex to release the source code then.

1%

  • Developer
  • Hero Member
  • *****
  • Posts: 5936
  • 600D/6D/50D/EOSM/7D
Re: Help needed with mini_iso calibration for 6D
« Reply #5 on: February 03, 2014, 04:13:16 AM »
Download raw digger. I see 63 in the CR2 with mini ISO and 2048 without.

With the older raw_diag I have the black level + white level changes too.

http://minus.com/mbk8hajBITcVWa

a1ex

  • Administrator
  • Hero Member
  • *****
  • Posts: 12564
Re: Help needed with mini_iso calibration for 6D
« Reply #6 on: February 03, 2014, 06:53:41 AM »
This checklist is meant for testing after everything seems to work at first sight. It won't reveal much about what registers are wrong and what needs patched; it will only tell whether it works as designed and it will show how much improvement you are going to get.

So, at this stage, I don't need anyone to run this checklist any more than Marsu already did. It won't give any more clues than I already have, and if you compile tables and such, they will be useless (I will ask you to run the tests again after fixing the registers, and I bet you don't want to run through all that stuff more than once).

What I need from 6D is a detailed table with ISO registers and every values at every single ISO (including intermediates), similar to what ayshih did on 50D and dmilligan on 1100D. This can be done with ADTG GUI (you don't need mini_iso for it).

I'm working on a tool to automate this step, because I will need this data on all cameras (even those where it already works).


Marsu42

  • Contributor
  • Hero Member
  • *****
  • Posts: 1557
  • 66d + flashes
Re: Help needed with mini_iso calibration for 6D
« Reply #7 on: February 03, 2014, 08:31:15 AM »
So, at this stage, I don't need anyone to run this checklist any more than Marsu already did. It won't give any more clues than I already have, and if you compile tables and such, they will be useless (I will ask you to run the tests again after fixing the registers, and I bet you don't want to run through all that stuff more than once).

Thanks for explaining, I posted the procedure here to to make sure I didn't screw up anything when running these tests so you're continuing to work with wrong assumptions concerning the 6d.

I'm working on a tool to automate this step, because I will need this data on all cameras (even those where it already works).

Ok, looking forward to that!

Levas

  • Contributor
  • Hero Member
  • *****
  • Posts: 1741
  • 6d - Nightly build user
Re: Help needed with mini_iso calibration for 6D
« Reply #8 on: February 03, 2014, 09:29:37 AM »
6d tragic lantern user following this thread  :D


a1ex

  • Administrator
  • Hero Member
  • *****
  • Posts: 12564
Re: Help needed with mini_iso calibration for 6D
« Reply #9 on: February 03, 2014, 11:01:19 PM »