Author Topic: [UNMAINTAINED] Canon 5D Classic Firmware ** Beta 4 **  (Read 548160 times)

DCB

  • New to the forum
  • *
  • Posts: 2
Re: Canon 5D Classic Firmware ** Beta 4 **
« Reply #475 on: July 01, 2013, 01:01:56 AM »
Well Auto ISO would be nice, I think!

NEW 5D? Where did you buy it?

New to me. Looks like new though.

Peace

SoulState

  • New to the forum
  • *
  • Posts: 13
Re: Canon 5D Classic Firmware ** Beta 4 **
« Reply #476 on: July 17, 2013, 12:56:11 AM »
No auto ISO?

white_chapel

  • New to the forum
  • *
  • Posts: 6
Re: Canon 5D Classic Firmware ** Beta 4 **
« Reply #477 on: July 18, 2013, 12:24:35 PM »
New to me. Looks like new though.

Peace

So, comparable to mine with 8940 shots only!  ;)

vscd

  • New to the forum
  • *
  • Posts: 20
Re: Canon 5D Classic Firmware ** Beta 4 **
« Reply #478 on: August 01, 2013, 09:42:01 AM »
Is someone still developing on the 5DC?    We can't wait for the beta5 ;)

walta

  • Freshman
  • **
  • Posts: 77
Re: Canon 5D Classic Firmware ** Beta 4 **
« Reply #479 on: August 02, 2013, 04:48:43 PM »
Is anyone noticing how many people view this thread every day - looking for activity or progress?

I don't think anyone's working on it any more. Probably because its an older model - everyone's trying to crack they new sexy models with video etc.

Walt
Canon 5Dc and 400D

dfallsfilm

  • New to the forum
  • *
  • Posts: 11
Re: Canon 5D Classic Firmware ** Beta 4 **
« Reply #480 on: August 03, 2013, 11:13:52 PM »
Im still waiting on beta 5... come on now, dont let the 5Dc die.

chombor

  • Just arrived
  • *
  • Posts: 1
Re: Canon 5D Classic Firmware ** Beta 4 **
« Reply #481 on: August 06, 2013, 04:35:46 PM »
Cant install  :-[  8gb trancend

Update file cannot be found, please check the memory card and reloade the battery and try again

oh with 4gb cf i have not blinking blue light


now all great, thx for this tool

vscd

  • New to the forum
  • *
  • Posts: 20
Re: Canon 5D Classic Firmware ** Beta 4 **
« Reply #482 on: August 08, 2013, 10:24:57 AM »
@White_Chapel
>So, comparable to mine with 8940 shots only!

How do you know? Did you send the camera to CPS? The Imagenumber is no real proof ;)

white_chapel

  • New to the forum
  • *
  • Posts: 6
Re: Canon 5D Classic Firmware ** Beta 4 **
« Reply #483 on: August 13, 2013, 09:07:36 PM »
@White_Chapel
>So, comparable to mine with 8940 shots only!

How do you know? Did you send the camera to CPS? The Imagenumber is no real proof ;)

Yes, I sent it to CPS for a bit of correction on the AF. Now it's perfect. ;)

organicphoto

  • New to the forum
  • *
  • Posts: 4
Re: Canon 5D Classic Firmware ** Beta 4 **
« Reply #484 on: August 16, 2013, 08:26:42 PM »
I followed the directions but I only get the blinking blue light (bootflag disabled) and no response when I click the Trash button. Any suggestions? I went through the process several more (5) times but I only get a blinking blue light. Any help is appreciated.

p.s. If it helps, I'm using a Komputerbay 266x 32GB card.

walta

  • Freshman
  • **
  • Posts: 77
Re: Canon 5D Classic Firmware ** Beta 4 **
« Reply #485 on: August 19, 2013, 04:45:50 PM »
I followed the directions but I only get the blinking blue light (bootflag disabled) and no response when I click the Trash button. Any suggestions? I went through the process several more (5) times but I only get a blinking blue light. Any help is appreciated.

p.s. If it helps, I'm using a Komputerbay 266x 32GB card.


Look back a few posts. I helped some others that had the same problem.

You have to do the firmware update twice with 2 different .fir files


=====================================

The instructions aren't too clear.

On your first install you need to do the firmware update with the file named "5dc.111.card bootable.fir" in the root of the card
This makes your card bootable
next you have to do the firmware update with the "5dc.111.ML install.fir" file (as well as all the other ones needed for ML)
This installs the ML bootflag.

There is no message that it was successful. The blue light should come on steady - like the instructions say. Then you have to remove the battery to re-boot the camera.

Blinking light means something wasn't installed properly.

I'm not sure what the camera does if you do the upgrade firmware process with 2 fir files in the root of the card.
after copying all the files over there, I made sure there was only 1 fir file each time when I did the firmware upgrade process and it worked for me.

Canon 5Dc and 400D

Pharinen

  • New to the forum
  • *
  • Posts: 29
Re: Canon 5D Classic Firmware ** Beta 4 **
« Reply #486 on: August 19, 2013, 05:53:41 PM »
Is there any possibility to get "shutter delay(MLU)" feature on 5Dc? That would be super helpful, with my 550D I can get almost 1-2 stop longer shutter speed with it.  :)

Sindaizo

  • Just arrived
  • *
  • Posts: 1
Re: Canon 5D Classic Firmware ** Beta 4 **
« Reply #487 on: August 20, 2013, 12:18:02 PM »
Quote
Cant install  :-[  8gb trancend

Update file cannot be found, please check the memory card and reloade the battery and try again

oh with 4gb cf i have not blinking blue light

Got same problem but can't find the response to fix it. Work on a 1 gb sandisk.

Can someone teach me how to get the right tool?

I got a 8gb Lexar professional 400x

walta

  • Freshman
  • **
  • Posts: 77
Re: Canon 5D Classic Firmware ** Beta 4 **
« Reply #488 on: August 20, 2013, 04:53:09 PM »
Got same problem but can't find the response to fix it. Work on a 1 gb sandisk.

Can someone teach me how to get the right tool?

I got a 8gb Lexar professional 400x

Did you see my post?
Canon 5Dc and 400D

dfallsfilm

  • New to the forum
  • *
  • Posts: 11
Re: Canon 5D Classic Firmware ** Beta 4 **
« Reply #489 on: August 24, 2013, 03:11:09 AM »
This is what should be added to Beta 5:

AUTO ISO enable for Manual Mode. No excuses.


Maik mit A.I.

  • New to the forum
  • *
  • Posts: 3
Re: Canon 5D Classic Firmware ** Beta 4 **
« Reply #490 on: September 06, 2013, 03:26:46 AM »
Hiho
I´v installed the ML fw every thing is ok but how can i uninstall the fw i want the 1.1.1. Canon fw!

(a friend want the cam for his Vacation) Now i have some ugly display settings :(


could you help me?

Thx Thomas

walta

  • Freshman
  • **
  • Posts: 77
Re: Canon 5D Classic Firmware ** Beta 4 **
« Reply #491 on: September 07, 2013, 09:31:36 PM »
Hiho
I´v installed the ML fw every thing is ok but how can i uninstall the fw i want the 1.1.1. Canon fw!

(a friend want the cam for his Vacation) Now i have some ugly display settings :(


could you help me?

Thx Thomas


Do the firmware update again with the file named "5dc.111.card bootable.fir" in the root of the card.
This makes your card not bootable
If you do it again it makes it bootable.
This is a flag that turns the boot portion on and off so every time you run it it turns it either on or off
Next format your CF

ML is gone.








Canon 5Dc and 400D

Maik mit A.I.

  • New to the forum
  • *
  • Posts: 3
Re: Canon 5D Classic Firmware ** Beta 4 **
« Reply #492 on: September 12, 2013, 07:55:52 AM »
Hi

i made it like you told me but it doesn´t work.
I tryed it blinking blue led > format the CF card but still no auto Focus wired colors ...

any idea what i can do to reset all settings?

greetings from Germany

niwi

  • New to the forum
  • *
  • Posts: 3
Re: Canon 5D Classic Firmware ** Beta 4 **
« Reply #493 on: September 13, 2013, 07:32:17 AM »
Hi,

I also have the missing firmware message on a 16GB CF card, but ML works on a 2GB card. Several pages ago there was a Windows tool linked which I also tried and this said I have no boot flag on the 16GB card. Changing the boot flag with this tool also allows me to use the 16GB card.

And it is (in my case) regardless if the boot switch firmware file 5dc.111.card_bootable.fir stays on the CF or not.

I'm still testing this boot problem and if there is a workaround with Windows or Mac OS system tools to make a CF bootable. Maybe it is a problem of the file system (FAT32 on the 16GB card) or the CF card is not a typed as a big floppy or removable, maybe it is a USB HDD type. I'm not sure if I had used this card as a bootable USB hdd for Windows setups earlier...

Is the ML software insied the auto exec.bin file? If so I think it is not possible to use different ML files (in my case for the 5DC and the 7D) at the same time on one CF.
Is there a way for hot swapping the CF card without rebooting the DSLR?

Regards
Nils

PS: nice tool, I'm looking closer to the several functions.

Pharinen

  • New to the forum
  • *
  • Posts: 29
Re: Canon 5D Classic Firmware ** Beta 4 **
« Reply #494 on: September 14, 2013, 06:02:46 PM »
For some reason I'm not able to get ML running on my 5Dc again.

I had it couple of months with any issues but I accidently formatted the card in camera yesterday.

I have tried dozens of times to get it running, but I always just get blinking blue light.

And yes, I have tried this already: http://www.magiclantern.fm/forum/index.php?topic=1010.msg16120#msg16120

walta

  • Freshman
  • **
  • Posts: 77
Re: Canon 5D Classic Firmware ** Beta 4 **
« Reply #495 on: September 15, 2013, 06:05:16 PM »
For some reason I'm not able to get ML running on my 5Dc again.

I had it couple of months with any issues but I accidently formatted the card in camera yesterday.

I have tried dozens of times to get it running, but I always just get blinking blue light.

And yes, I have tried this already: http://www.magiclantern.fm/forum/index.php?topic=1010.msg16120#msg16120

I am having the same problem. I tried to re-install the version on the first page of this thread and got the blinking blue light. I used both methods (having both .fir files and then having only one). Neither way worked. In the end my camera ended up being locked up - no LCD screen and can't actuate the shutter.

I formatted the card, tried to run the bootflag file a number of times nothing. I was starting to sweat. Finally took all batteries out for 5+ minutes and camera works fine.

In the past I've been able to install Beta 4 that I downloaded earlier (last year) and they worked fine. Maybe theres something different in the one on this thread now. Anyway I'm not attempting an install again until it gets out of BETA.


Walt

 
Canon 5Dc and 400D

polarrys

  • New to the forum
  • *
  • Posts: 5
Re: Canon 5D Classic Firmware ** Beta 4 **
« Reply #496 on: September 15, 2013, 10:35:36 PM »
Dear All,

My name is polarrys and I am a 5D classic user.  I have installed Magic Lantern on my 5D but I have a big issue now. I tell you :

1. I put the all the files from the zip on my camera and I boot it. I do an upgrade firmwre. I have the blue light so no problem.
2. But, I can't boot on magic lantern or on canon soft with my CF card
3. When i have NO CF card installed, i can boot on canon soft (but with no CF card)

Please, can you give me an advice to solve my problem .
There is a possibility to delete all ML to have only the canon soft.

Thanks a lot for your help.

walta

  • Freshman
  • **
  • Posts: 77
Re: Canon 5D Classic Firmware ** Beta 4 **
« Reply #497 on: September 16, 2013, 04:13:48 PM »
read the last 3 posts and you'll see others are having the same problem.

Canon 5Dc and 400D

polarrys

  • New to the forum
  • *
  • Posts: 5
Re: Canon 5D Classic Firmware ** Beta 4 **
« Reply #498 on: September 16, 2013, 04:34:12 PM »
Thanks Walta but I read the 3 posts but i don't find a solution to start normally my 5DC.

Please, can you tell the proceedings to have now only the canon soft?

I think all is ok on my camera because I can start the 5DC without CF Card.
I try to erase all files on my CF card, but nothing appears ???

Thanks for your help.

walta

  • Freshman
  • **
  • Posts: 77
Re: Canon 5D Classic Firmware ** Beta 4 **
« Reply #499 on: September 16, 2013, 04:40:36 PM »
From my post above




Do the firmware update again with the file named "5dc.111.card bootable.fir" in the root of the card.
This makes your card not bootable
If you do it again it makes it bootable.
This is a flag that turns the boot portion on and off so every time you run it it turns it either on or off
Next format your CF

ML is gone.









 
Canon 5Dc and 400D