Author Topic: [UNMAINTAINED] Canon 5D Classic Firmware ** Beta 4 **  (Read 558151 times)

Devulder

  • New to the forum
  • *
  • Posts: 7
Re: Canon 5D Classic Firmware ** Beta 4 **
« Reply #325 on: January 03, 2013, 04:30:08 PM »
Okay good news !
I'me happy to knows that the ml port dont stop because counts have brick is 5dc !
Thanks 0xAF
5đc  ml beta 4

vscd

  • New to the forum
  • *
  • Posts: 20
Re: Canon 5D Classic Firmware ** Beta 4 **
« Reply #326 on: January 04, 2013, 04:38:11 PM »
Yeah 0xaf, nice to hear that! ;)

sandisk

  • New to the forum
  • *
  • Posts: 11
Re: Canon 5D Classic Firmware ** Beta 4 **
« Reply #327 on: January 05, 2013, 07:38:23 PM »
Good to hear 0xAF. Thanks for your time.
Sold my Canon 5Dc. Now enjoying my 5D2 with liveview and Magic Lantern. INCREDIBLE !

rstone

  • Just arrived
  • *
  • Posts: 1
Re: Canon 5D Classic Firmware ** Beta 4 **
« Reply #328 on: January 05, 2013, 10:52:20 PM »
b0ooo, thanks for the clarity about using only one .fir at a time. This tip worked for me but it works only about 50% of the time for some reason. There is no "Keep Magic Lantern" in the Format menu so I did lose ML twice before the light bulb went off. Well it's a beta so maybe  beta 5 will have that feature? This is a good thing for the 5Dc and I appreciate all that have put time into it. Will donate when it's out of beta for sure.  :)

walta

  • Freshman
  • **
  • Posts: 77
Re: Canon 5D Classic Firmware ** Beta 4 **
« Reply #329 on: January 07, 2013, 12:11:13 AM »
b0ooo, thanks for the clarity about using only one .fir at a time. This tip worked for me but it works only about 50% of the time for some reason. There is no "Keep Magic Lantern" in the Format menu so I did lose ML twice before the light bulb went off. Well it's a beta so maybe  beta 5 will have that feature? This is a good thing for the 5Dc and I appreciate all that have put time into it. Will donate when it's out of beta for sure.  :)

Which .fir are you running? Bootflag?

Remember this from the Instructions

You only need to run the firmware update to enable the bootflag ONCE. Each time after that will only disable, re-enable, disable, re-enable, etc. the bootflag.

So it turns the bootflag on 50% of the time. Turns it off the other 50%


Canon 5Dc and 400D

scrax

  • Contributor
  • Hero Member
  • *****
  • Posts: 1543
  • Code monkey
Re: Canon 5D Classic Firmware ** Beta 4 **
« Reply #330 on: January 07, 2013, 11:08:09 PM »
5D arrived finally, installed ML without issue so far.
Instead can't compile from source. make 5DC gives me:
Code: [Select]
init.o: In function `copy_and_restart':
init.c:(.text+0xc8): undefined reference to `init_code_run'
lens.o: In function `draw_ml_bottombar':
lens.c:(.text+0x2a58): undefined reference to `hdr_video_enabled'

I've patched lens.c to not load that part if 5DC, but on the init.C I can't just remove it. :)
Code: [Select]
// this is just restart.. without copying
// (kept for compatibility with existing reboot.c)
void copy_and_restart() {
   
    // don't know whether it's needed or not... but probably it's a good idea
    zero_bss();
   
    // lock down caches
    //~ cache_lock();
   
    // jump to modified Canon startup code from entry.S
    // (which will call Create5dplusInit - where we create our tasks)
    init_code_run(2); <<<WITH THIS COMMENTED CAN COMPILE BUT DON'T LOAD.
   
    // unreachable
    while(1) LEDBLUE = LEDON;
}
I'm using ML2.3 for photography with:
EOS 600DML | EOS 400Dplus | EOS 5D MLbeta5- EF 100mm f/2.8 USM Macro  - EF-S 17-85mm f4-5.6 IS USM - EF 70-200mm f/4 L USM - 580EXII - OsX, PS, LR, RawTherapee, LightZone -no video experience-

0xAF

  • Contributor
  • Freshman
  • *****
  • Posts: 85
  • The devil in me...
Re: Canon 5D Classic Firmware ** Beta 4 **
« Reply #331 on: January 07, 2013, 11:41:28 PM »
5D arrived finally, installed ML without issue so far.
Instead can't compile from source.

Hi scrax, perhaps you would want to try my repo, but ATM it wont run ML, since i still have to fix 2-3 spots in cache hacks.
I can make it run with the old method of booting if you want and commit to the repo.
https://bitbucket.org/0xAF/magic-lantern-5dc-port-wip
// AF

scrax

  • Contributor
  • Hero Member
  • *****
  • Posts: 1543
  • Code monkey
Re: Canon 5D Classic Firmware ** Beta 4 **
« Reply #332 on: January 07, 2013, 11:50:26 PM »
Hi scrax, perhaps you would want to try my repo, but ATM it wont run ML, since i still have to fix 2-3 spots in cache hacks.
I can make it run with the old method of booting if you want and commit to the repo.
https://bitbucket.org/0xAF/magic-lantern-5dc-port-wip
If it's not a problem, I will try it, for now cloning your repo to this revisionthen will try to update with ML.
I'm using ML2.3 for photography with:
EOS 600DML | EOS 400Dplus | EOS 5D MLbeta5- EF 100mm f/2.8 USM Macro  - EF-S 17-85mm f4-5.6 IS USM - EF 70-200mm f/4 L USM - 580EXII - OsX, PS, LR, RawTherapee, LightZone -no video experience-

a1ex

  • Administrator
  • Hero Member
  • *****
  • Posts: 12422
Re: Canon 5D Classic Firmware ** Beta 4 **
« Reply #333 on: January 07, 2013, 11:52:47 PM »
Rename entry.S to entry-5dc.S (also in Makefile) and will work.

Probably it's from latest Makefile changes.

scrax

  • Contributor
  • Hero Member
  • *****
  • Posts: 1543
  • Code monkey
Re: Canon 5D Classic Firmware ** Beta 4 **
« Reply #334 on: January 08, 2013, 12:02:04 AM »
Rename entry.S to entry-5dc.S (also in Makefile) and will work.

Probably it's from latest Makefile changes.
ok thank's
I'm using ML2.3 for photography with:
EOS 600DML | EOS 400Dplus | EOS 5D MLbeta5- EF 100mm f/2.8 USM Macro  - EF-S 17-85mm f4-5.6 IS USM - EF 70-200mm f/4 L USM - 580EXII - OsX, PS, LR, RawTherapee, LightZone -no video experience-

scrax

  • Contributor
  • Hero Member
  • *****
  • Posts: 1543
  • Code monkey
Re: Canon 5D Classic Firmware ** Beta 4 **
« Reply #335 on: January 08, 2013, 12:06:29 AM »
The problem is solved but now on my summon-arm, it gives me same problem had with 7D:
Code: [Select]
entry-5dc.o: In function `my_romStart':
(.text+0xec): relocation truncated to fit: R_ARM_PC24 against symbol `sub_FF810318' defined in *ABS* section in magiclantern
entry-5dc.o: In function `my_usrInit':
(.text+0x128): relocation truncated to fit: R_ARM_PC24 against symbol `sub_FF810E84' defined in *ABS* section in magiclantern
entry-5dc.o: In function `my_usrInit':
(.text+0x134): relocation truncated to fit: R_ARM_PC24 against symbol `sub_FFB45FCC' defined in *ABS* section in magiclantern
entry-5dc.o: In function `my_usrInit':
(.text+0x138): relocation truncated to fit: R_ARM_PC24 against symbol `sub_FFB35004' defined in *ABS* section in magiclantern
and so on with other till output is truncated.
I'm using ML2.3 for photography with:
EOS 600DML | EOS 400Dplus | EOS 5D MLbeta5- EF 100mm f/2.8 USM Macro  - EF-S 17-85mm f4-5.6 IS USM - EF 70-200mm f/4 L USM - 580EXII - OsX, PS, LR, RawTherapee, LightZone -no video experience-

a1ex

  • Administrator
  • Hero Member
  • *****
  • Posts: 12422
Re: Canon 5D Classic Firmware ** Beta 4 **
« Reply #336 on: January 08, 2013, 12:14:28 AM »
Quote
Rename entry.S to entry-5dc.S (also in Makefile) and will work.

Fixed the makefile, don't commit this workaround.

Quote
relocation truncated to fit: R_ARM_PC24

Documented on the wiki: -mlong-calls.

0xAF

  • Contributor
  • Freshman
  • *****
  • Posts: 85
  • The devil in me...
Re: Canon 5D Classic Firmware ** Beta 4 **
« Reply #337 on: January 08, 2013, 12:17:45 AM »
If it's not a problem, I will try it, for now cloning your repo to this revisionthen will try to update with ML.

just merged the master into my repo and fixed the compilation problems...
check it out.



EDIT: though nothing more than beta4 is to be expected (at least for the porting, the new stuff, if any, in the master will be available).
// AF

scrax

  • Contributor
  • Hero Member
  • *****
  • Posts: 1543
  • Code monkey
Re: Canon 5D Classic Firmware ** Beta 4 **
« Reply #338 on: January 08, 2013, 12:26:37 AM »
just merged the master into my repo and fixed the compilation problems...
check it out.



EDIT: though nothing more than beta4 is to be expected (at least for the porting, the new stuff, if any, in the master will be available).

That's enough for now. I want to start playing with it, and also need to take confidence with the camera, I'm not used at all with two wheels.

EDIT: Same problem as with alex suggstion, could be something in my makefile.user? OK there is no makefile.user in 0xAF clone seems I'm tired, restarted to work regularly yesterday   :D

foun another error now:
Code: [Select]
/Users/scrax/arm-toolchain462/lib/gcc/arm-elf/4.6.2/../../../../arm-elf/bin/ld: error: init.o uses VFP instructions, whereas magiclantern does not
I'm using ML2.3 for photography with:
EOS 600DML | EOS 400Dplus | EOS 5D MLbeta5- EF 100mm f/2.8 USM Macro  - EF-S 17-85mm f4-5.6 IS USM - EF 70-200mm f/4 L USM - 580EXII - OsX, PS, LR, RawTherapee, LightZone -no video experience-

0xAF

  • Contributor
  • Freshman
  • *****
  • Posts: 85
  • The devil in me...
Re: Canon 5D Classic Firmware ** Beta 4 **
« Reply #339 on: January 08, 2013, 12:29:45 AM »
EDIT: Same problem as with alex suggstion, could be something in my makefile.user?

see if you got the local_entry.S file, since i forgot to add it ... if its missing checkout(update) again.
(this file will be removed later)

EDIT: if it's about the long-calls and you cannot work it out, i'm using a toolchain compiled in 32bit and copyed into my 64bit host, this way you can work-around the -mlong-calls demand in the 64bit toolchains.
Though i had to export LD_LIBRARY_PATH in Makefile.user, because for some unknown reason my toolchain did not see it's own libs ;)
something like this:

  # Supported camera models
  SUPPORTED_MODELS:=5DC
 
  # Path-related stuff
  # for yagarto or the official ARM toolchain use ARM_ABI=none-eabi otherwise use ARM_ABI=elf
  CCACHE=ccache
  ARM_ABI=elf
  # this export needs a full path for some reason, ~ wont work
  export LD_LIBRARY_PATH=/home/af/arm/arm-toolchain462/lib
  ARM_PATH=~/arm/arm-toolchain462
  ARM_BINPATH=$(ARM_PATH)/bin
  GCC_VERSION=4.6.2



the rest i think is untouched in my Makefile.user
// AF

scrax

  • Contributor
  • Hero Member
  • *****
  • Posts: 1543
  • Code monkey
Re: Canon 5D Classic Firmware ** Beta 4 **
« Reply #340 on: January 08, 2013, 12:50:06 AM »
Yes it was here, 2 commit.
I've -mlong-calls now, something strange also 600D din't compile (probabli make clean missed), copied makefile.user from a working clone  (no -mlong-calls problems) and still same error for 5DC, 600D instead compiles. From default I have only:
Code: [Select]
ARM_ABI=elf
PYTHON=python

# You can customize CFLAG here
CFLAG_USER = -mlong-calls -DCONFIG_RELEASE_BUILD \

error:
Code: [Select]
local_entry.o: In function `my_romStart':
(.text+0x100): relocation truncated to fit: R_ARM_PC24 against symbol `sub_FF810318' defined in *ABS* section in magiclantern

So if this is due to 64bit toolchain I need to compile to 32bit like you but I've tried some times ago and never be able to understand how to do it, are you on a mac?
I'm using ML2.3 for photography with:
EOS 600DML | EOS 400Dplus | EOS 5D MLbeta5- EF 100mm f/2.8 USM Macro  - EF-S 17-85mm f4-5.6 IS USM - EF 70-200mm f/4 L USM - 580EXII - OsX, PS, LR, RawTherapee, LightZone -no video experience-

sandisk

  • New to the forum
  • *
  • Posts: 11
Re: Canon 5D Classic Firmware ** Beta 4 **
« Reply #341 on: January 08, 2013, 12:55:34 AM »
You guys are the best for working so late on this. Thankyou.
Sold my Canon 5Dc. Now enjoying my 5D2 with liveview and Magic Lantern. INCREDIBLE !

0xAF

  • Contributor
  • Freshman
  • *****
  • Posts: 85
  • The devil in me...
Re: Canon 5D Classic Firmware ** Beta 4 **
« Reply #342 on: January 08, 2013, 12:57:30 AM »
are you on a mac?

nope, just plain linux user :)

forget the 32bit toolchain for now, if 600d compiles, then it's something else ?!?
though i've never changed anything related to the compilation.

coutts, could you please try to compile it with your toolchain ?
// AF

scrax

  • Contributor
  • Hero Member
  • *****
  • Posts: 1543
  • Code monkey
Re: Canon 5D Classic Firmware ** Beta 4 **
« Reply #343 on: January 08, 2013, 01:02:10 AM »
You guys are the best for working so late on this. Thankyou.
For me it's not too late, for others could be morning :D

nope, just plain linux user :)

forget the 32bit toolchain for now, if 600d compiles, then it's something else ?!?
though i've never changed anything related to the compilation.

coutts, could you please try to compile it with your toolchain ?

I'm trying to compile a make all just to check other camera and it worked. 7D fails (on your repo not tested main) but with another error (not my problem, something missing in the code):
Code: [Select]
menu.o: In function `handle_ml_menu_keys':
menu.c:(.text+0x3e70): undefined reference to `beta_set_warned'
6D, 650D, EOSM also compiling ok

Same error also after updating main repo, is it only happening to me?
I'm using ML2.3 for photography with:
EOS 600DML | EOS 400Dplus | EOS 5D MLbeta5- EF 100mm f/2.8 USM Macro  - EF-S 17-85mm f4-5.6 IS USM - EF 70-200mm f/4 L USM - 580EXII - OsX, PS, LR, RawTherapee, LightZone -no video experience-

dfallsfilm

  • New to the forum
  • *
  • Posts: 11
Re: Canon 5D Classic Firmware ** Beta 4 **
« Reply #344 on: January 11, 2013, 04:19:38 AM »
I forgot to mention.

As soon I got the 5D Classic, I put the ML Beta 4 on it and it is running perfect! 

I wonder would there will be more features added in the future like Auto ISO, Bypass Long Exposure?

Buzzz57

  • New to the forum
  • *
  • Posts: 42
  • ML addict
Re: Canon 5D Classic Firmware ** Beta 4 **
« Reply #345 on: January 11, 2013, 08:19:44 PM »
Hi all,

I'm new here, but I follow this project with much interest.
I had installed ML 2.3.0 on my 50D and enjoyed it.
Now, I have sold the 50D and I'm waiting for a 5Dc, that should arrive tomorrow.

I'm looking forward for testing ML on the 5Dc.

I'd like to participate, but I guess my programming skills (mainly under VB) wouldn't be sufficient.

Guys, keep the good work on!

sandisk

  • New to the forum
  • *
  • Posts: 11
Canon 5D service manual pdf - I have it!
« Reply #346 on: January 14, 2013, 01:10:04 AM »
As the title reads I have the Canon 5D classic service manual in pdf.



Does anyone need it, there is a public website that you can download it from.

Check out http://elektrotanya.com
Sold my Canon 5Dc. Now enjoying my 5D2 with liveview and Magic Lantern. INCREDIBLE !

0xAF

  • Contributor
  • Freshman
  • *****
  • Posts: 85
  • The devil in me...
Re: Canon 5D service manual pdf - I have it!
« Reply #347 on: January 14, 2013, 01:15:53 AM »
As the title reads I have the Canon 5D classic service manual in pdf.



Does anyone need it, I do not mind sharing.

I would like to check it out (I haven't searched the web for the manual).
// AF

vscd

  • New to the forum
  • *
  • Posts: 20
Re: Canon 5D Classic Firmware ** Beta 4 **
« Reply #348 on: January 14, 2013, 02:12:40 AM »
I guess you will ruin this thread with thanks, but from all of us (i think) here is our thumb:     :D

Buzzz57

  • New to the forum
  • *
  • Posts: 42
  • ML addict
Re: Canon 5D classic
« Reply #349 on: January 14, 2013, 04:21:47 PM »
The only thing I wish would be an AutoISO function in P/Av/Tv mode (even if it is only between ISO 100 and 400), but of course, anything would be great.
Same here.

The 5Dc already has an Auto ISO when you're in Auto exposure mode. Isn't it possible to "simply" port this feature in the creative modes?