Author Topic: [UNMAINTAINED] Canon 5D Classic Firmware ** Beta 4 **  (Read 652473 times)

aprofiti

  • Contributor
  • Member
  • *****
  • Posts: 194
Re: [UNMAINTAINED] Canon 5D Classic Firmware ** Beta 4 **
« Reply #650 on: September 02, 2020, 02:36:22 PM »
Which build were you using?

It may be an HW problem.
I bought a spare 5Dc (ML has never been loaded on it) with the same issues you have, it has a damaged D-PCB (main board) that overheat near processor/ram and also fried the fuse of the DC power board. Top lcd and MCU are working as normal and blue/red leds stay on

Brakeless

  • New to the forum
  • *
  • Posts: 5
Re: [UNMAINTAINED] Canon 5D Classic Firmware ** Beta 4 **
« Reply #651 on: September 03, 2020, 12:17:58 AM »
 :o Please! Somebody check a link for downloading ML for 5D1 because Bitbucket no longer supports!  :-[



aprofiti

  • Contributor
  • Member
  • *****
  • Posts: 194

Hellhawk00

  • Just arrived
  • *
  • Posts: 1
Re: [UNMAINTAINED] Canon 5D Classic Firmware ** Beta 4 **
« Reply #655 on: March 26, 2022, 05:25:46 AM »
You sir are a life saver lol.   I bought a 5 classic a few years ago and love it but had absolutely NO idea you could put ML on it till this afternoon.  I also have a 7D that I dropped it on and my EOS M which had ML on it when I got it.  I took ML off right after I got the M  because it was more than I wanted to try and figure out just getting a new camera so it left for an extended while.  Well with my daughter being in a school play I decided to put it back on there and see what kinda fun I can have and now that I have it on the 7 and gonna try it on the 5 classic I should be having loads of fun.  Once again, THANK YOU!!