Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Messages - TechnoPilot

Pages: 1 [2] 3 4
26
Dev & TechnoP

Clean outs are possible.  Check my post, it really needs to be a sticky.
http://www.magiclantern.fm/forum/index.php?topic=14309.msg157764#msg157764

The part I am not sure is Atmos as I dont use it. But I thought its interface (record, stop)
is integrated with canon interface, not sure if those commands work with ML in place. 
Check it out and let us know if it works with ML clean outs.
Hi ShootMeAlready, thanks for the info, but honestly to my intruptation and consideration, clean output does not involve crop, especially on 720p for a camera that shoots 1080p internal.  This would simply not be worth it for any external recording as the image quality regardless of codec would be less then the camera's internal 1080p image.

I personally considered Black Magic Video Assist until I discovered this drawback and then scrubbed it completely as an option for any 70D rig.

Dev, I'm sorry I should have referenced ShootMeAlready's thread, but when you talk about recording to an Atomos, I struck that completely as a reasonable option as what you'd consider "clean out"

Sorry for any confusion, I wish there was a true clean out option from Canon on our camera like that of the 7D mkII.  It seems so stupid for Canon to not provide something they clearly, easily can for those of us that want touchscreen dual-pixel AF (I didn't buy the 70D due to the price difference over the 7D mkII).

27
Hi guys.. Sry for the nooby question. Does 70D with ML got clean video output in a case if i use external recorder (Atomos for example)?
Nope, sorry not possible with current knowledge for the Digic 5 as I've already been told.  i.e. not currently and probably never will be possible without really in-depth hacking of the processor which has not happened yet for any camera, let alone the 70D.

28
Interestingly though this sounds like the same issue I was having on my 70D.111B install, I just didn't have that much in my crash log...

29
Camera-specific discussion / Re: Canon 70D (Beta-2b / 26th Nov)
« on: November 28, 2015, 10:02:23 PM »
Okay I re-downloaded the build and yes I can see a later build time, but sadly I see this in the crash log.  Same exact crash as previous:

Code: [Select]
ASSERT: 0
at ./Memory/Memory.c:575, task AeWb
lv:1 mode:3


Magic Lantern version : Nightly.2015Nov28.70D111B
Mercurial changeset   : aae92eae46f1 (70D-merge-dryos-hooks) tip
Built on 2015-11-28 20:50:58 UTC by ml@ml-pc.
Free Memory  : 231K + 2435K

30
Camera-specific discussion / Re: Canon 70D (Beta-2b / 26th Nov)
« on: November 28, 2015, 09:46:56 PM »
To update what I posted above, sadly, as soon as I turned on the camera in movie and C mode (what I use for movie settings), the camera drew the ML overlays and as soon as it finished, it crashed again on a vanilla copy of Beta 2c.  Same crash log essentially, but in case included below:

Code: [Select]
ASSERT: 0
at ./Memory/Memory.c:575, task AeWb
lv:1 mode:3


Magic Lantern version : Nightly.2015Nov28.70D111B
Mercurial changeset   : 15be51f3ac34+ (70D-merge-dryos-hooks) tip
Built on 2015-11-28 19:44:03 UTC by ml@ml-pc.
Free Memory  : 231K + 2434K

Rolling back to Beta 2b for now...

31
Camera-specific discussion / Re: Canon 70D (Beta-2b / 26th Nov)
« on: November 28, 2015, 09:28:10 PM »
Okay bad news...instant crash as soon as I engaged liveview in movie mode when I turned on the camera after it warned me that my bag had slightly disengaged the lens.  I locked the lens back on, hit the liveview button, heard the mirror flip up and was instantly presented with the crash notice on screen.

Code: [Select]
ASSERT: 0
at ./Memory/Memory.c:575, task AeWb
lv:1 mode:3


Magic Lantern version : Nightly.2015Nov28.70D111B
Mercurial changeset   : 15be51f3ac34+ (70D-merge-dryos-hooks) tip
Built on 2015-11-28 19:44:03 UTC by ml@ml-pc.
Free Memory  : 146K + 2176K

Please note that I had copied my settings over from the Beta 2b, so I will retry with a vanilla build and update this post with my results.

32
Camera-specific discussion / Re: Canon 70D (Beta-2b / 26th Nov)
« on: November 28, 2015, 09:20:48 PM »
Rolling up to most recent Beta 2c, will let you know if I run into anything and I will see what I can do to provide the dual ISO test.

33
Camera-specific discussion / Re: Canon 70D (Beta-2b / 26th Nov)
« on: November 26, 2015, 10:31:08 PM »
rec indicators are included in bitrate source. I grabbed 5D3 implementation and replicated it for 70D.This would let me disable bitrate features again but have rec indicator enabled as requested. You better updated to the build from 1st post as it differs from the test-zip posted some days ago  8). You might want to always check the bitbucket source to see when the last commits were done.
That's why I wanted to check!  Will update tonight!

34
Camera-specific discussion / Re: Canon 70D (Beta-2b / 26th Nov)
« on: November 26, 2015, 10:21:05 PM »
updated first post. Read changelog.
Seems you still have it listed though as having bitrate modifications disabled, is this a new revision from the 2b beta you posted on the 15th?  While I know that people seem to found the modified bitrates not to work, they were enabled...

35
Camera-specific discussion / Re: Canon 70D (Beta-2 / 15th Nov)
« on: November 26, 2015, 04:31:43 AM »
Perhaps could there be an option in the settings for picking?  I feel like having the those kinds of customizations would be ideal...since I think a few of us would want different things...

36
Camera-specific discussion / Re: Canon 70D (Beta-2 / 15th Nov)
« on: November 24, 2015, 09:27:06 PM »
Alright, I definitely agree that what I experienced was not a bug, however it would seem that QuickZoom was defaulted to on.  Should this really be the case?  I do also want to note that the camera did not lockup as I think was taken that I described, just the touch functionality until I exited Playback mode.

I have noted one instance where I can reliably get the camera to completely lockup and require switch off and battery removal to reset, but I think this is a Canon issue and not a ML one.  That is removing a micro SD from the camera while leaving an adapter in it and closing the SD card door.  This creates an instant lockup, but I need to test with a non-ML card to see if it is ML related or at the Canon level.

I have to second/third the request to add back the arrow button control of white balance and ISO, this worked brilliantly for me, and while it popped up a little Canon overlay while the activation button was pressed, it really was only a slight annoyance and not a hindrance to use.

I just wanted to confirm, please correct me if I'm wrong, but as far as we are aware at moment, there is no way to implement Clean HDMI out?  Right?  I ask because with the release of the new Blackmagic Video Assist, I was eyeing it at the store yesterday and simply loved it, except when I plugged it into my 70D [emoji14]

Thanks again Nikfreak for all the work, I love ML on my camera to say the least!

37
Camera-specific discussion / Re: Canon 70D (Beta-2 / 15th Nov)
« on: November 20, 2015, 07:17:26 PM »
BTW guys, I've been doing some professional shoots with this Beta 2 build on my B firmware 70D and have run into an issue that I could swear we fixed back a number of Alphas ago.

My shooting has been photography all this week and while going to review photos and punch in to check sharpness using the +/- buttons, everytime one press is taking me to full zoom and not stepping in.  I thought it might be because I had Magic Zoom enabled for my video work, but disabling this had no effect, same of course but tried, global draw.  I'm a little stumped because along with this, when using the punch in button instead of pinching with the touch screen, it also locked up touch functionality again at random (only when using the +/- key for photo review) which is something I also thought we solved a little while back.

Any recommendations Nikfreak or what you need from me to debug, let me know!

38
Camera-specific discussion / Re: Canon 70D (Beta-2 / 15th Nov)
« on: November 20, 2015, 07:10:59 PM »
i'd start over. low level format the sd card in the camera(erase ml).  extract the ml zip onto it. use the update firmware steps.
Agreed, I suggest you just start from scratch with the ML install, see if that fixes the issue!

39
Camera-specific discussion / Re: Canon 70D (Beta-2 / 15th Nov)
« on: November 19, 2015, 01:27:09 AM »
Hey all I've noticed something interesting with this build, and my installation of it.

For reference, I have been regularly using the method mentioned above to retain settings from build to build, specifically though the settings file, not whole folder.

For a while now I have been using the shutter timing delay functionality to give myself an accurate 180° shutter for 24p video recording, but I noticed now that the delay seems to be pre-added and when set to zero on the delay, shutter speeds are still modified and at 1/48 or similar and putting in any delay does not work, shutter speeds do not change.  I tried resetting all settings to default in my install and this still did not change the shutter speed back.  Is this accurate behaviour, or is it a bug?  It seems to only effect video recordings, photo shutter speeds remain normal.

40
Camera-specific discussion / Re: Canon 70D (Beta-1 / 22th Aug)
« on: November 14, 2015, 12:52:43 AM »
With massive reverse engineering efforts it may be possible one day. But actually there's no Digic5 powered cam supporting audio features except the audio metersand mlv_snd-module.
Oh this is very interesting, I was not aware of that point!

41
Camera-specific discussion / Re: Canon 70D (Beta-1 / 22th Aug)
« on: November 11, 2015, 08:10:51 AM »
Sorry, misinformation by me. Remembered having it seen marked "as fixed" but I was wrong:

https://bitbucket.org/hudson/magic-lantern/issues/2379/canon-6d-116-rec-picstyle-magiclantern
No worries, that's a really honest mistake! Just do a test shot after turning on the camera before you start shooting, not a bad practice anyways! [emoji14]

42
Camera-specific discussion / Re: Canon 70D (Beta-1 / 22th Aug)
« on: November 11, 2015, 07:45:40 AM »
I still ran into the issue that the Cinestyle picture style, even though selected as the record picture style, didn't get used on first recording after the camera was switched on.

43
Camera-specific discussion / Re: Canon 70D (Beta-1 / 22th Aug)
« on: November 10, 2015, 10:56:03 PM »
Not really. This is bleeding edge with the latest fixes from me and thse from bitbucket applied by a1ex. This should fix:

  • picstyle on first record not being applied
  • movie restart feature fixed for 70D.111B
  • less and faster gui redraws when using halfshutter / wheel
  • ....

if you can confirm this then 70D just misses movie mode dualiso and fps overrides to become perfect [emoji14]
So awesome Nikfreak! Thanks for all the continued hard work!  I'll try it out on my B firmware 70D tonight.

I noticed you've yet to make note about any additional audio features, are we still waiting on the new audio package to be merged?  Or is there something else needed to make this happen?

44
Camera-specific discussion / Re: Canon 70D (Beta-1 / 22th Aug)
« on: October 18, 2015, 09:13:26 AM »
I will recheck fps on 70D once 100D has been released
No worries, just wanted to give you a heads up and cool to know actually, since I sold off my 100D to my mother to eventually upgrade to my 70D.

BTW, like we've talked about before Nikfreak, if there is anything we can do to help with the new audio module, please let me know as I'd love to help make this amazing improvement happen! :)

45
Camera-specific discussion / Re: Canon 70D (Beta-1 / 22th Aug)
« on: October 18, 2015, 01:57:21 AM »
Btw all, I just rolled back to the last Alpha release to have some fun with the undercranking feature and honestly the banding really disappears when using a contrasty grade in camera.  It was almost unnoticeable at 2.5fps, 1/5th sec, ISO800, however as soon as I switched to Cinestyle the banding became super visible.  It definitely seems to come through with flat profiles, but is very usable with the proper colour settings up to some very decent ISOs.

Just wanted to provide my two cents from further testing if it helps at all, I know though that it is an old release.

46
Camera-specific discussion / Re: Canon 70D (Beta-1 / 22th Aug)
« on: October 14, 2015, 08:02:22 AM »


Thanks, TechnoPilot!

I found a good video on youtube showing how to install.
Now my doubt is regard to these options that he showed here:

1. Does it needs to turn on all these options?


2. In case of not activating all them, ML will not work?

3. For exemple, I want initially to use ZEBRA, FOCUS PEAKING, LV DIGIC PEAKING, VECTOR SCOPE, VIDEO HACK BITRATE, TIMELAPSE. Which one must I active to use these features?

4. Another thing I noticed is that is not possible to copy the ML files into SD Card through USB cable. At least I cant here. Is needed to use a SD Card reader in PC instead direct with usb cable?

Turn all of them on, then reboot the camera (switch off, then back on again).  There is no harm having them all turned on in this case.  After the reboot, you will be able to select those options in their associated menu to display on the ML overlay screen.

No, you cannot use the camera with a USB cable to transfer the ML files, the camera mounts to the computer as a digital camera USB device, the card instead needs to be mounted as a mass storage device to transfer the files.  Remove the card from the camera and use a card reader instead, it is the safer option anyways.

Note that with ML, you should always wait to ensure that the card activity light is off before ejecting the card from the camera after opening the SD card door.  It is a good practice to help prevent corrupting your SD card anyways, but is especially important with ML installed.

47
Camera-specific discussion / Re: Canon 70D (Beta-1 / 22th Aug)
« on: October 13, 2015, 11:57:30 PM »
I keep not understand anything. Congratulations for developing ML which is very interesting. However, in terms of communication/organization i didnt like. I think ML need to launch a simple and objective/clean website for "non nerds" like me, with simple and objective texts and download button.
I came here to find help to install/avoid mistakes and in order to do my first job with ML that will happens in this saturday. but the forum/communication here is very advanced for me. Infomartion through the threads are not clean for me. I will try to find help with blogs around the web.
Miramez, please use translation software if you are having trouble as it is clearly explained in English.

Both versions, A & B are the newest.  There are two because there are two versions of the Canon 70D.  This cannot be found in the Canon menu; try installing version A first and if it fails stating you have the wrong version, just download and install B.

ML being a hack of the Canon firmware it really cannot be made easier without negating the fact that this IS A HACK.  This is not something that you should be doing to your Canon camera if you are not comfortable with at least understanding some of the technical nature, as it still does pose a slight risk and always will.

48
Camera-specific discussion / Re: Canon 70D (Beta-1 / 22th Aug)
« on: September 30, 2015, 05:01:44 AM »
When shooting with a REC-picture style on,  I noticed my camera doesn't switch to the REC-picture style the first time recording after the camera has been turned off. From the second clip on it will switch to it just fine. Has anyone else noticed this?
Sorry if it has been mentioned before.
Hi @Wiggierip, yep I have had the exact same results throughout the alphas and beta which I noted earlier but may have been missed.

49
Camera-specific discussion / Re: Canon 70D (Beta-1 / 22th Aug)
« on: August 22, 2015, 10:47:20 PM »
HDR video is way older than RAW/MLV video. If there was information given about 70D HDR video function limited to RAW/MLV I missed to find this post.
Well my miss understanding then, but was always under the impression that the HDR processing had to be done in post and not in realtime in the camera, this certainly cannot be done in post on an h264 compressed image.

50
@nikfreak - tried hdr video.  all frames the same.  for some reason the hdr ml settings say iso 0/0,4ev instead of iso 100/1600,4.0ev like on my 60d.  tried at both 1920x1080 all-i and 1280x720 all-i.

the hdr option in the menu turns green when it is selected but it's a dull green not like other items that are on.
That sounds like you are trying to take it in h264 codec and not raw, remember it only works in raw.

Pages: 1 [2] 3 4