Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Messages - hindra

Pages: [1] 2
1
Use 'dokanctl.exe' to unmount the drive correctly: dokanctl.exe /u Z (or whatever drive you use)

Here it's location (x64 ver) and usage:
Code: [Select]
C:\Program Files\Dokan\Dokan Library-1.0.0>dokanctl.exe
Driver path: 'C:\WINDOWS\system32\drivers\dokan1.sys'
dokanctl /u MountPoint (/f)
dokanctl /m
dokanctl /i [d||n]
dokanctl /r [d||n]
dokanctl /v

Example:
  /u M                : Unmount M: drive
  /u C:\mount\dokan : Unmount mount point C:\mount\dokan
  /u 1                : Unmount mount point 1
  /u M /f             : Force unmount M: drive
  /i d                : Install driver
  /i n                : Install network provider
  /r d                : Remove driver
  /r n                : Remove network provider
  /d [0-9]            : Enable Kernel Debug output
  /v                  : Print Dokan version
Let me guess - you used auto or aperture/shutter priority exposure mode.

Thank you for the instruction on unmounting the drive. I did not use any auto exposure mode, it was manual at f4, iso 200 1/60th but I believe I was on auto WB.

2
Hmm, I've been using mlv-dump (and the dumper batch) a bunch lately and haven't had any issues. Do you have the latest version of mlv_dump.exe? And are you sure you have enough hard disk space?

Yeah I am using the latest dump, and I have plenty of HD space. All the files get extracted, I can stop mlv-dump and my files are there for 1 clip. Ive been using it fine for the past week or so this just occurred the past few days. I havent changed anything so I'm not sure whats going on.

3
Tutorial:
https://youtu.be/6v4EWj0zXDs
I didn't get this new version working on win 10 though...
I get instant "this program stopped working" when executing mlvfs.exe.

Let me know if you have any luck on win 8

I have it working on Windows 10, just got it up tonight. I had to install the x64 installer and it was good to go. Thank you everyone!!!

EDIT: The only bug I'm noticing is I cant close MLVFS unless I go into the task manager and end task. My raw files come out really cool/blue. Other than that everything looks great.

4
Hey guys, just curious. I shot some footage, about 4 takes of a local artist and its about 114gb. 3k 12bit lossless 3.5k centered mode and it all went very well. It flashed between orange and green but I also had the global draw on. Camera temp hit orange a few times but it all worked great and it is super sharp!!

My question has to do with MLV_dump.exe, I left it overnight to process the DNGs but I think it got stuck because it never got past the first set of mlv files. I had selected all the time, 32 in total. I am re-attempting to do them one clip at a time now, but I'm curious if there is limit on GB size or amount of files I can run at once.

Is this normal? Does it need to process the images more than once? Thanks for all your help guys!

Quote
MLV Dumper v1.0
-----------------

Mode of operation:
   - Input MLV file: 'M02-2034.MLV'
   - Enforcing 14bpp for DNG output
   - Convert to DNG frames
   - Output into 'M02-2034\M02-2034_'
File M02-2034.MLV opened
File M02-2034.M00 opened
File M02-2034.M01 opened
File M02-2034.M02 opened
File M02-2034.M03 opened
File M02-2034.M04 opened
File M02-2034.M05 opened
File M02-2034.M06 not existing.
Processing...


Vertical stripes correction:
  1.00000  1.00781  1.00792  1.00864  1.00664  1.00841  1.00572  1.00777
Cold pixels : 36
Reached end of chunk 1/7 after 1235 blocks
Reached end of chunk 2/7 after 1232 blocks
Reached end of chunk 3/7 after 1230 blocks
Reached end of chunk 4/7 after 1232 blocks
Reached end of chunk 5/7 after 1237 blocks
Reached end of chunk 6/7 after 1238 blocks
Reached end of chunk 7/7 after 436 blocks
Processed 7776 video frames
Done


 MLV Dumper v1.0
-----------------

Mode of operation:
   - Input MLV file: 'M02-2034.MLV'
   - Enforcing 14bpp for DNG output
   - Convert to DNG frames
   - Output into 'M02-2034\M02-2034_'
File M02-2034.MLV opened
File M02-2034.M00 opened
File M02-2034.M01 opened
File M02-2034.M02 opened
File M02-2034.M03 opened
File M02-2034.M04 opened
File M02-2034.M05 opened
File M02-2034.M06 not existing.
Processing...


Vertical stripes correction:
  1.00000  1.00781  1.00792  1.00864  1.00664  1.00841  1.00572  1.00777
Cold pixels : 36

EDIT: It seems to be on an endless cycle just repeating and wont move on to the next clip. Even if I only select the mlv files for one clip its just in an endless loop.

5
you now can choose between
a) output uncompressed DNGs
b) compress DNG content (bit slower bit same as uncompressed, just many tools have trouble with lossless compressed DNG)
c) pass through the original lossless data (which will be fast but skip all processing like stripe and hot pixel detection)

this can be done by adding "-c" multiple times to the commandline.

e.g.
Code: [Select]
./mlv_dump in.mlv --dng   # outputs uncompressed DNGs
./mlv_dump in.mlv --dng -c  # outputs compressed DNGs using mlv_dump's LJ92 algorithm
./mlv_dump in.mlv --dng -c -c  # outputs uncompressed DNGs by passing through unmodified lossless data

Thank you for that. It is nice having options.

6
If you used compressed raw, the MLV files are always smaller. The dng files that are made by MLV_dump are not compressed, so bigger.
And as far as I know, the output in dng from MLV_dump is always in 14 bit.
So you could have a compressed 12 bit MLV file, but the dng's that come out mlv_dump are uncompressed 14 bit.

That makes perfect sense! Thank you for clearing that up for me.

7
Sorry guys, with the new MLV_Dump the DNG file sizes are coming out much larger, for 3k 12 bit they are 7mb each. I am using this script to run MLV_Dump, please help me make corrections. Also, it seems to be taking much longer as well.

Quote
@echo off
for %%a in ( %* ) do ( md "%%~na" 2>nul )&( C:\MLVFS\mlv_dump.exe -o %%~na\%%~na_ --dng %%~na.MLV )

EDIT: MLV files are 16.6gb, dng output are closer to 30gb.

8
This is incredible! Soooo impressed!

Also I just replaced my test with a much better one

This means Either Canons 5Div 4K is actually 3K
or
That we get to call 5D3 ML 3K  ... 4K
4 Clips
2 are 5div 1/100 f11 ISO 400 Sigma Art 35mm 4k
2 are 5Diii 1/50 f11 ISO 400 Sigma Art 35mm 3k  ML
14bit lossless using 4-21-2017 4K Crop Rec build
(I underexposed the 5Div because I was clipping highlights at 1/50 shutter)
Both rendered to Cineform UHD and both were precisely focussed on the crosshatch on the color chart.
Can you tell which is which.
Download and zoom in. It's a UHD Cineform AVI
 5Diii was quickly graded to match Canon's neutral picture style of the 5div




1 and 3 are much sharper when viewed at 200%

9
I was able to replicate  the 19 FPS bug in the menu I reported a while baclk. If I forget to turn FPS Override off, turn on Crop Mode module for UHD recording, enter canon menu then go back into ML menu, when I turn off FPS Override it defaults back to 19 FPS. If FPS Override is off when I turn on Crop Mode, everything is fine.


10
Whats the best Card to use?

I'm not sure on the best card, but I have had great success with Lexar 32gb and 128gb 1066x CF cards.

11
I'd actually like to try and raise the vertical resolution and shorten the width to try and get the closest to 16:9 at highest resolution possible.

12
Camera-specific discussion / Re: Canon 7D Mark II
« on: April 16, 2017, 10:20:14 PM »
Can any digic 6 camera work? Can I go buy a cheaper PowerShot? I wouldn't mind if that bricked. I've got a 7d2 too.

13
Unfortunately I erased the videos.
But ... how do we attach an image on the post ?
Sorry for my ignorance ?


I upload to imgur.com and copy/paste the BBCcode link in the forum post.

14
1080p48 at 12 and 11 bit lossless at 100 iso I get results with a split exposure. Global draw off


15
Camera-specific discussion / Re: Canon 7D Mark II
« on: April 15, 2017, 09:43:53 AM »
7D2 is probably the last Digic 6 cam you want to start deployment with because it's dual processor architecture is known to cause major headache.
Some people are working on the first Digic 6 port for other cams.
You probably have to wait long, long time to see ML for 7D2. In the meantime: Don't hold your breath!

Yes, I am aware. I'm seeking someone local that I can work with and she/he can show me and work with me in person on the 7d2. If working on other Digic 6 first would make the 7d2 easier we can start there.

16
Have you noticed the ISO suggestions when selecting a lower bit depth from menu? (at the bottom of screen)

Please refer to this commit for more details, and to this article for some theory regarding bit depth, noise and posterization.

Impossible (please check the metadata with mlv_dump -v).

Yes, I did notice the ISO suggestions. I have no idea why I thought I was shooting at 60fps. I re-rendered at 30 fps, I also cant hit 60fps when attempting to re-create. but, 8 bit lossless works! :) I was trying to use the lowest bitrate to obtain the highest fps and I thought it was 60, I was mistaken. Thank you for those links.

17
Hey guys, here's a quick 23 second shot of the 8 bit lossless 3520x1322 at 60 fps with the latest April 14th 1.2.3 build. My hands are really shaky, I'm not a pro and I had my shutter at 1/80th.
ISO 200, F8, 1/80th - SHAKY HANDS - straight out of camera no corrections/lut - 60mbit vbr
Its working :)



EDIT: 30 fps

18
Camera-specific discussion / Re: Canon 7D Mark II
« on: April 15, 2017, 04:18:16 AM »
Is there anyone in or around the Seattle, WA area that would like to collaborate on this? I really am ignorant when it comes to much of this stuff but I would like to help and get ML on the 7D2.

19
Anyone else just try 1080p raw with the 1080p all-i proxie with the new april 13th build? Is it broken? Here is what happened to me today.

1080p raw w/ proxie broken, raw to CF and all-i to SD - Stops recording after a few seconds, camera locks up, preview still works, global draw on or off. After messing with proxie, 14bit lossless no longer working? recording at 90+mb/sec for 1080p as stated on my liveview monitor.

ML ASSERT:
0
at mlv_lite.c:2113 (compress_task), task compress_task
lv:1 mode:3


Magic Lantern version : crop_rec_4k.2017Apr13.5D3123
Mercurial changeset   : cf07f797b9c3 (crop_rec_4k)
Built on 2017-04-13 10:35:29 UTC by jenkins@nightly.
Free Memory  : 166K + 3785K


ML ASSERT:
RAW_IS_IDLE
at mlv_lite.c:592 (measure_compression_ratio), task shoot_task
lv:1 mode:3


Magic Lantern version : crop_rec_4k.2017Apr13.5D3123
Mercurial changeset   : cf07f797b9c3 (crop_rec_4k)
Built on 2017-04-13 10:35:29 UTC by jenkins@nightly.
Free Memory  : 167K + 3119K


I uninstall ML, format card in pc, then format in camera, then load ML software and reload firmware to set bootflag.

Still recording at 90mb/sec and in canon menu at format menu it shows no use of CF card. I am also now having issues recording with any of the crop_rec options. Recording stops very quickly. What did I break?  :(

EDIT:
Lossless is still working, looking at footage the 1080p raw stills are only 1.90MB

20
Just tested newest build from Latest Build (2017-04-12 20:31).

I got the red dot in the memory patches again, no big deal right? It seemed like most of my shots using crop_rec had a bad first frame regardless of resolution.  Shooting at 3504x1536 at 24fps I only got 157 frames with a Lexar 128gb 1066x card.

Also, something odd kept happening and it kept reverting back to 19fps with FPS override off.

21
Having never done it before: how long should a ML ROM dump take?

Near instant? I believe when you "update" firmware with ML it will backup the ROM then. I just formatted my SD card in PC, format in camera, load ML from PC onto card, update firmware to setup ML, grab the ROM1.BIN and follow instructions.

22
This is what I just did to test it (for Windows):
1. Install python for your computer: https://www.python.org/downloads/
2. Make sure to check add python x.x to PATH
3. Make a backup of your current camera's ROM (using magic lantern)
3. When done make a new folder and copy your ROM1.bin to that folder (i made E:/tmp)
4. In the same folder make a new .txt file and rename it to testrom.py --> make sure you have file extensions visible
5. Open the file in your favorite text editor (i like notepad++) and copy the code in a1ex's post
6. Open a command window in the folder you just created (press right click on the folder while holding shift key, select Open command window here and type this:

    py testrom.py ROM1.bin

7. Read and follow the output on your screen.

Worked great, thank you. My camera appears to be ok :)

23
To use 1080 with 50fps you need to be using the latest experimental firmware. Activate mlv_lite and crop_rec module. Set crop rec to 1080 50 then set the resolution in mlv lite.

24
Shooting with the Canon 5d3, 1.2.3 firmware and using the latest experimental build(April 3rd 2017) with Lexar 128gb 1066x cf card.

1080p 48FPS seems to be working (It seemed to have recorded fine, but I must have deleted the file.)
3520x1320 24FPS(ISO 100-200 iso seems to be continuous and at a 5x crop mode) ISO 400 recording stops after a few seconds. In no crop mode preview was colorful noise. in 5x crop preview worked great. I recorded 1510 frames and I ended it.
3584x1320 24FPS I recorded 1443 frames and I ended it.
1080p 60FPS(buggy, stops recording quickly) gray preview was glitchy and lagged.

3k (3072x1920@24fps) I got 66 frames.
UHD (3840x1536@24fps, couldnt get 3840x1600) I got 66 frames as well. It states its 120mb/sec, this might require the lossless compression with 10bit?
Both 3k and UHD frames are good, used MLV_DUMP from the page I downloaded the firmware to extract these.

I am also very tired, I will try and play around with them some more.

25
Raw Video / Re: Newest build for 5d3 1.2.3, extra frames with (1)
« on: March 28, 2017, 02:02:01 AM »
Thank you for the reply. I wasn't able to replicate the issue again even with the same .mlv file.

Pages: [1] 2