Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Messages - bischofftep

Pages: [1]
1
Camera-specific Development / Re: Magic Lantern for 7D 2.0.3
« on: June 03, 2014, 08:53:01 PM »

Have these issues been resolved?

No: in RAW still exists.

2
Camera-specific Development / Re: Magic Lantern for 7D 2.0.3
« on: May 30, 2014, 09:36:58 PM »
I would like to make sure that when recording raw video the hdmi output is functional with the 7D?

My experimentation with that setup has been NO, it will NOT work RAW + HDMI output. There will be significant tearing of the recorded image. That said, I've been pretty aggressive with the frame sizes I'm working with, so it may be that it works at lower resolutions than what I'm trying to do. But at anything approaching 1080 it does NOT work with HDMI output. Unplug the monitor and you're fine. (Which for me, as I suspect it is for you, is a deal-breaker, sadly.)

I'm still trying to understand how to "bang on the code" to try and fix this, but alas it seems out of my skill range for now.

3
General Development / Re: Benchmark Stub Test failures?
« on: April 22, 2014, 04:32:03 PM »
Probably the threshold is a bit too tight (it's just an approximation to check if malloc/free seems to reserve the requested memory and give it back). If some other code is using the memory allocators in parallel with the tests, they may fail.

Interesting... I went ahead and dropped back to the 2013_q4 toolchain just to be sure it wasn't something else going on, same problems.

Nightly builds do NOT have this problem, just my own builds. Frustrating, and makes me worry that my development environment isn't working after all.

5
General Development / Re: Benchmark Stub Test failures?
« on: April 22, 2014, 03:10:09 PM »
gcc-arm-none-eabi-4_8-2014q1

6
General Development / Benchmark Stub Test failures?
« on: April 18, 2014, 05:56:35 PM »
Hello, all:

Got a development environment up and running under VirtualBox and everything compiles fine. Several things aren't working as they do under nightly builds, though, the most noticeable being that the Benchmark->Stub Test reveals a LOT of [FAIL] markers. For example:
Code: [Select]
[Pass] UNCACHEABLE(p) => 0x42000068
       _shoot_free(p)
       m11 = MALLOC_FREE_MEMORY => 0x411b8
       m12 = GetFreeMemForAllocateMemory() => 0x2c865c
[Pass] ABS(m01-m11) => 0x0
[Pass] ABS(m02-m12) => 0x0
[FAIL] ABS(m0-m2) => 0x1518
[FAIL] ABS((m0-m1) - 256*1024) => 0x14f0
[FAIL] ABS(m0-m2) => 0x14fc
[FAIL] ABS((m0-m1) - 256*1024) => 0x14f0
[FAIL] ABS(m0-m2) => 0x14fc

followed by a whole string of [FAIL] just like the ones shown.

My build pattern is:
/magic-lantern/make
/magic-lantern/platform/7D.203/make install

That's it... any ideas what might be causing this?

7
So... if one were to want to work on the 7D_MASTER code, which appears to require a signed firmware, one is out of luck?

8
Ran into this and others may as well:

If your "make docs" or "make zip" build fails with an error after the words "This is pdfTeX" it may be that your LaTeX install did not include several fonts used by ML's document system.

To fix this on Linux systems, try:
Code: [Select]
apt-get install texlive-fonts-extra
That should install the missing fonts.

The next error I hit was a missing "pylab" module. This comes from:
Code: [Select]
apt-get install python-matplotlib

9
Camera-specific Development / Re: Magic Lantern for 7D 2.0.3
« on: April 02, 2014, 10:35:59 PM »
Hi all:

Is there a "lead" developer working on 7D issues, or who did the 7D port? I'd like to PM them with some questions and thoughts about the 7D problems that seem to be related to having an HDMI monitor plugged in.

Thanks in advance,

10
Camera-specific Development / Re: 7D ML backporting from TL
« on: March 31, 2014, 08:55:15 PM »
If you want a stable ML on your 7D you can help testing different functions and compare these functions in TL and ML.
What the developers need mostly is feedback.

I am more than willing to help out here. I've been making bug reports on the bitbucket repository's "Issues" track: is this the best way? If so, can someone add a "7D" option in the "Version" pop-up?

I'm also willing to try some coding if that will help.

11
Camera-specific Development / Re: Magic Lantern for 7D 2.0.3
« on: March 26, 2014, 11:50:10 AM »
Confirming tearing still exists.
* 2014 May 25 Nightly Build ML7D.203
* Raw 2.0 (mlv)
* 1532 x 1148 resolution

Using HDMI out.

12
Tragic Lantern / Re: 7D Raw Thread
« on: March 26, 2014, 11:47:49 AM »
Thank you, Ted! Hadn't realized this was a TL thread...

13
Hey everyone. Here are some examples of coloring capabilities with Canon 7D magic lantern raw using Davinci Resolve. All shot in gorgeous Maine, United States in 2013 and 2014.

Beautiful!

Mind sharing your settings, lensing, and post production workflow?

14
Tragic Lantern / Re: 7D Raw Thread
« on: March 26, 2014, 01:37:51 AM »
This happens under certain conditions (when you overload the camera, is my hypothesis). It has only happened to me when I was using the ml grayscale preview in crop mode. When I use the canon preview there is no issue.

Thanks for the reply! I don't use crop mode, and am not sure what you mean by "canon preview." The output came from MLRawViewer... wonder if the problem is there? I can't actually play back on the camera itself: it plays at perhaps 8 fps. (And to answer the next likely question, using a Lexar 1000 32mb card.) I did read something about a "memory hack" which I am NOT using.

Would you mind sharing a "working" magic.cfg config file either here or by PM?


15
Tragic Lantern / Re: 7D Raw Thread
« on: March 25, 2014, 10:35:00 PM »
I'm having trouble with Raw 7D. Here's the skinny:
* 2014 May 25 Nightly Build ML7D.203
* Raw 2.0 (mlv)
* 1532 x 1148 resolution

Most of the frames come out fine. Periodically, though, the following error will creep in (as exported from MLRawViewer 1.1.3 on Mac OS X):


It's a "tearing" of the image (circle added to show where the problem is) during motion. Is this a new issue, or am I missing something which will help avoid these?

16
Raw Video / Re: Can the 7D shoot 2.5k RAW continuously?
« on: March 24, 2014, 03:41:34 PM »
Get an anamorphic lens and start shooting 2.5k today!
[SNIP....]
2816x1156!

Planning to do exactly that this week. Would you mind posting or PM'ing with any caveats or things you've learned shooting raw/anamorphic on the 7D for those of us about to dive into it? Many thanks in advance... and yes... that's a pretty sweet looking video you got there!

17
Camera-specific Development / Installing Magic Lantern for 7D 2.0.3
« on: March 21, 2014, 07:13:52 PM »
If i understand good you can download this in here http://builds.magiclantern.fm/#/

and just follow this instructions?

Installation:
1) Format the card from the camera.
2) Make sure you are running Canon firmware 2.0.3.
3) Copy ML files on the card and run Firmware Update.

Uninstallation:
1) Run Firmware Update from your ML card.
2) Follow the instructions.

Confirmed today. Works like a charm.

Pages: [1]