Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Messages - dragonsfire1981

Pages: [1]
1
General Development / Re: Dealing with Focus Pixels in raw video
« on: September 28, 2021, 04:20:56 PM »
Thank you yes- I thought that was the workaround, I just shot three h264 clips with h264 preset applied and can confirm there are no focus pixels! Something else I was slightly confused by was that there are two levels of presets, level 1 when you press the set button (presets), and level 2 (startoff presets) when you press the play button. H264 isn't listed as a preset on the level 1 presets, so it seems like level 2 settings take precedence then?

Do you think in the next build, there may be a way that applies the h264 and crop shut off automatically when you turn off RAW video? Currently I think it confuses a few people as I saw on MLV Facebook group a few other people were getting this also.

It's a great build otherwise though!

The original h264 video clips for reference.

https://streamable.com/2fpvqm

https://streamable.com/o5ac0l

https://streamable.com/2fpvqm



Ah, yes, now I know your issue. Look. My version originally was thought to only inherit raw video capabilities but after some consideration I decided to be able and use h264 mode. But by turning of raw video still won´t shut off crop rec presets so all those regs are still applied. Including focus pixel issues. The workaround is to enable h264 from within the preset menu here which also shuts off crop rec:


2
General Development / Re: Dealing with Focus Pixels in raw video
« on: September 28, 2021, 03:13:16 PM »
Hello Danne! Thanks for all the work you've done so far- really enjoyed learning to shoot RAW.

These are 3 stills taken from 3 bits of h264 footage. First two shots from the window of a train, third one the focus pixels a little fainter but can be seen on the pavement, I'll find a site to upload the videos shortly.   

https://ibb.co/kKWSbnB
https://ibb.co/mzkWn6s
https://ibb.co/WDJ9kPK







So far, from what I've gathered when I proactively select the H264 preset, it does not have the focus pixel problem. It's when the preset is not selected, and RAW video is turned off it seems to have that problem ie you can shoot h264 in more than one preset, but not having the h264 turned on seems to cause the problem.


It's not known exactly what your issue is about so upload a file which clearly shows the issue before asking for other builds.

3
General Development / Re: Dealing with Focus Pixels in raw video
« on: September 28, 2021, 12:40:32 PM »
Okay, that makes sense, and I'll report it to that thread shortly. I did see on another forum, referring to an older build that Zeek thinks it's something to do with the bitrate. Some of my h264 footage has no focus pixel problem whatsoever and I did change the bitrate a couple of times throughout the day so I'll run some tests to see what correlation i can find.

Can you reccommend, apart from the Vanilla nightly, what else is a most stable previous, recent ML build pherhaps where this problem is not known to occur?

I meant to "share" short H.264 clip has the problem, just to make sure what kind of focus pixels you are having.

Actually I saw multiple EOS M users are reporting same problem with H.264 video with Danne build, most people didn't have the problem, it must be a quirk happening in specific cases, I don't have EOS M so can't test/help you much

This thread is about fixing focus pixels in RAW videos, you maybe want to report the problem in this thread:
https://www.magiclantern.fm/forum/index.php?topic=25781.0

In normal H.264 videos you shouldn't have focus pixels by default.

4
General Development / Re: Dealing with Focus Pixels in raw video
« on: September 28, 2021, 10:33:16 AM »
Canon EOS M and Danne's June build I'm using.

I'll upload a still image shortly illustrating the problem.

So you're saying short h.264 clips sometimes do have the problem? Or did you mean to say "(share a clip) a short H.264 clip (which) has the problem"


>> also a short H.264 clip has the problem

@dragonsfire1981

Which camera, which build? share a image showing the problem, also a short H.264 clip has the problem

5
General Development / Re: Dealing with Focus Pixels in raw video
« on: September 28, 2021, 10:31:18 AM »
They are definately focus pixels because when I played them back on the computer they are seen, so no not just live view.

Are you seeing this in Liveview only, or do you see them when you play back recordings?  It is normal for focus peaking indicators to show in liveview (they should not be recorded).  Also, focus peaking is not the same things as focus pixels, so you're asking in the wrong thread ;)

6
General Development / Re: Dealing with Focus Pixels in raw video
« on: September 23, 2021, 05:46:29 PM »
For some reason, I am sometimes also getting the focus pixels on standard HD H264 mode when I have magic lantern function turned on. I did not load any modules except Focus peaking, Global liveview. Is this normal?

7
I'm having this exact same problem with no files whatsoever appearing in my folders after exporting from MLV App to H264.

And before you ask, I have no folder in cyrillic or any other funny letters or symbols, and all the original installation files are present and correct in the MLV app folder, it just won't save the exported files at all. What's going on?

EDIT: I solved it after I figured out Avast antivirus was blocking the applications. I added exceptions to the MLV folder and all MLV .exe files. Woohoo!

My bet: you deleted ffmpeg from MLVApp path. Otherwise more information needed.

8
Raw Video / Are the custom presets are only for RAW mode?
« on: September 21, 2021, 01:23:56 PM »
I've noticed when trying to record using one of the custom presets e.g 2k, 2.5k- basically any function outside of 1080p, when RAW recording is disabled, my Canon EOS M will just crash. Is it the case that these modes are ONLY for RAW recording? I have not seen this explicitly stated anywhere but assume this is the case since these modes don't work withour RAW video mode turned on.

9
I only have the EOS M, so I was asking the question based on getting the Viltrox speed booster, to fake a full frame resolution, of which the Viltrox mount is EF to EF-M. I was looking at the FD lenses simply because I saw some relatively cheap/old prime lenses listed on Ebay. I already have a bunch of EF lenses, which is the easiest solution anyway, but was just looking at the other lens options.

I'll consider an FD to EF-M adapter as well, as I was unaware there was one. 

>>Full frame RAW never was a problem. All cameras able to record MLV/RAW can do.
Are you saying there is another way to generate a full frame image with the EOS M with ML, can you clarify this statement?

Also do you have any idea about the original Adaptall lens mount? After a quick search, I couldn't find anything, though there was an Adaptall II to EOS-M mount.

Full frame RAW never was a problem. All cameras able to record MLV/RAW can do. Problem is what happens with the pixels. (And recording bandwidth = Continuous or not). It has absolutely nothing to do with lenses or lens mounts/adapters as long as image circle is bigger than sensor diagonal and flange distance is met.

And because most FD-to-EF adapters do have a disputable image quality because of mediocre glass inside: Why not using a FD-to-EF-M adapter? M mount comes with a very short flange distance and adapters are quite cheap and some people prefer working with EOS M cameras and vintage lenses.
If you ask because you own an EF or EF-S camera: If you are happy with a certain amount of image degration using a lens equipped FD-to-EF Bob is your uncle.

Caveat: All FD-to-EF adapters without optical element will make focus to infinity impossible.

10
Hi everyone,

So I came across a couple of videos where the EOS M owner achieved a full frame RAW video with ML. Using the Vitrox speed booster. https://amzn.to/2VGRxZp

In this video the guy says he's using a a Tamron adaptall 35-70mm f3.5. I found out the adaptall is a very old manual lens that requires a seperate adaptor (or two?) to be able to fit an EF mount.

https://www.youtube.com/watch?v=rJsMftoZ6KA&t=2s

So assuming this is the case, there would be no problem doing something similar with an old FD Canon lens with an FD> EF converter which is much more common?


11
Camera-specific Development / Audio monitoring
« on: April 23, 2015, 07:43:49 PM »
Hi there,

I only recently installed ML. I read before that the audio monitoring function for the AV cable out port didn't work before, is that still the case? or is there an alternative solution?

Pages: [1]