Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Messages - kosmarnik

Pages: [1]
1
Camera-specific Development / Re: Canon EOS M
« on: October 06, 2017, 10:36:30 AM »
Would some of the devs  please take a look at the Advanced bracketing issue?
I't doesn't work with audio remote shot (as described in my earlier post). It also has issues when used with the intervalometer.

I grabbed the source to take a look at shoot.c, but it's a bit too much for me to grasp at a glance.


2
Camera-specific Development / Re: Canon EOS M
« on: October 03, 2017, 09:02:20 PM »
I did reply to this in the other posting on the same subject by the same OP in the GH Q/A section but if it helps here.
Did a quick test also with the 'M' and got in first 6 images at 3 stops. 320,320,40,40,40 and 40 second try I got 320,2500,40,40,1.6 and 1.6
Russ
Yeah, saw that one, but as it may be an EOS-M specific issue, it might be useful to have it here too.

3
Did a quick test also with the 'M' and got in first 6 images at 3 stops. 320,320,40,40,40 and 40 second try I got 320,2500,40,40,1.6 and 1.6
Russ
So it's seems like it is confirmed that it's a bug?

4
Camera-specific Development / Re: Canon EOS M
« on: September 24, 2017, 03:12:40 PM »
Anyone else having issues with Advanced bracketing?
My setup:
EOS-M with the latest nightly (magiclantern-Nightly.2017Sep15.EOSM202)

Manual mode, manual lens, 6exp 3ev from 1/4000.

Most of the times I get the expected exposure range:
1/4000
1/500
1/60
1/8
1"
8"

But not always.
Sometimes I'll even get more than 6 shot.
If I use Audio remoteshot (audio gain set to manual), I never get the expected range, just a bunch of random exposure values that changes every time:
1/4000
1/4000
1/500
1/500
1/500
128"

Or
1/4000
1/500
1/60
1/8
1/4000
1/4000

Or
1/30
1/4
1/30
1/30
127"
10"


Seems like a bug in the Advanced bracketing module, and using Audio remoteshot makes it worse.
Would someone please try it out, using at least 5 exposures?
Thanks!

5
Trying to do a shoot using only the Advanced bracketing and the 2 sec delay.
It seems sometimes even the Advanced bracketing will cock up.

I just got exposure values all over the place, and it shot more than 6 shots.

6
Canon audio gain is set to manual.
Audio remoteshot is set to 20dB.

If I trigger with the shutter button, I get the expected exposure values:
1/4000
1/500
1/60
1/8
1"
8"

When triggered by Audio:
1/4000
1/4000
1/500
1/500
1/500
128"

Or
1/4000
1/500
1/60
1/8
1/4000
1/4000

Or
1/30
1/4
1/30
1/30
127"
10"

So just random exposure settings.

Would you please do a quick test to confirm?

7
General Help Q&A / Advanced bracketing not working with Audio remote shot?
« on: September 24, 2017, 01:40:40 PM »
Hi!
I can't get Advanced bracketing to work properly when using Audio remoteshot to trigger.
Using the shutter button, Advanced bracketing works as expected, say 6 exposures at 3 EV, but when triggered by Audio remote shot I would get exposures all over the place with half of them being the same.

I has been happening with a lot of builds for the last couple of years, but I found a workaround, using the Canon AEB, but it only supports 3 exposures 2 EV apart.
But now, I need the Advanced bracketing, but also remote triggering.
As I'm using the EOS-M with the latest nightly (magiclantern-Nightly.2017Sep15.EOSM202), Audio remoteshot is the only way to remotely trigger.
Using a manual lens, no AF in manual mode.

Can someone please try and confirm the bug? Please use at least 5 exposures.

Thanks!

8
Camera-specific Development / Re: Canon EOS M
« on: May 26, 2016, 03:26:38 PM »
Shoot preferences: pics at once set to 3
Using the Audio remoteShot, only 2 pics are taken.

Weird. I set it up to 4 pics at once, it takes 3.
Testing some more, and it does 2-3 pics.
Inconsistent.
Seems to be related to shutter speeds.
Set it at 5 pics per shot, so far it does 3, but remains to be seen if it will actually be reliable.


9
Camera-specific Development / Re: Canon EOS M
« on: May 26, 2016, 03:10:52 PM »
Hi, I'm having issues with Advanced bracketing.
I set it up for 3 x 2ev, +++ , Exposure, no delay, no iso shift.
The results are chaotic.

Test:
Drive mode set to single:
2 photos, 0, +2ev, exposure left untouched
4 photos, 0, 0, +2ev, +4ev, exposure changed to 0+2ev
4 photos, 0, 0, +2ev, +4ev, exposure changed to 0+2ev
2 photos, 0, +2ev, exposure left untouched
4 photos, 0, 0, +2ev, +4ev, exposure changed to 0+2ev

At this moment I remembered I should use the latest nightly :-
Switched to Nightly.2016May16
Getting this results:
2 photos, 0, +2ev
3 photos, 0, 0, +2ev
2 photos, 0, +4ev
3 photos, 0, 0, +6ev

Everything is set to default settings.
4 photos, 0, +2ev, 0, +4ev

Such behavior makes the ML bracketing useless for me.






10
Camera-specific Development / Re: Canon EOS M
« on: August 29, 2015, 12:18:50 PM »
I'm a bit silly, but how does one record video with a manual lens (using a mechanical lens adapter)?

Silly indeed. Under Custom Functions (C.Fn), select no. 7 (C.Fn IV): Operation/Others Release Shutter w/o lens, enable.

11
Camera-specific Development / Re: Canon EOS M
« on: March 10, 2015, 03:59:41 PM »
The one compiled by you.
I was under the impression that if was merged in the main branch from which the nightlies are compiled?


12
Camera-specific Development / Re: Canon EOS M
« on: March 10, 2015, 03:06:11 PM »
Hi,
using magiclantern-Nightly.2015Mar03.EOSM202 I still get only old silent pictures, no FRSP.
What version has the FRSP?

13
Camera-specific Development / Re: EOSM-Updated ML for 2.02 firmware
« on: August 01, 2014, 05:56:14 PM »
Hi!
I installed ML just fine. 2.02 FW, magiclantern-Nightly.2014Jul30.EOSM202.

All video and interface tweaks work fine, except I can't shoot regular photos.
In photo or intelligent photo mode the the camera just focuses but won't fire with a full press.
If I turn on the 'touch to shoot' it will try to shoot and lock up the interface, no button or screen presses work, only taking out the battery.

Any ideas?
Using a sdcard without ML it works fine.
I can post dumps/logs later when I get home.

Pages: [1]