Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Messages - ADJ

Pages: [1]
1
Camera-specific discussion / Re: Canon 50D
« on: January 15, 2017, 11:58:15 PM »
Does anyone know a way of formatting the card with a 50D without pulling the battery?

2
Camera-specific discussion / Re: Canon 50D
« on: October 11, 2016, 12:16:34 AM »
Quote from: a1ex link=topic=9852.msg171070#msg171070
Here's a test anyone can run: load selftest.mo and run the redraw test. It's an infinite loop, and it may or may not be obvious whether it's actually running. If you run this test at the same time (in parallel) with the rectangle test, it will be obvious it's running, as the rectangles will disappear quickly.

While running this test, try to navigate Canon menus (it should not crash) and check whether the camera shuts down and restarts fine (without having to take the battery out).


For those who like me struggle without newbie level detail:

Download the lua script from http://www.magiclantern.fm/forum/index.php?topic=17027
Save the Reb_Modu.lua script onto the card in the ML\SCRIPTS folder.
From Magic Lantern Modules menu enable lua to run on reboot.
Restart the camera.
Scroll down on the Modules menu and Reboot now appears at the bottom of the list. (works for me).
In ML/Modules enable selftest to run on reboot.
Restart the camera.
On Debug Menu scroll down to Self Tests. Use the Func button to select “redraw tests (infinite)”.

A1ex, sorry for the late reply. I'm on holiday today so have more time.

When I use the redraw tests I get four flashes from the blue LED. I can navigate to Canon menu and select format. The screen reads “magic lantern restored” and then the screen goes black and the camera hangs with the red and blue LEDs lit and I need to pull the battery.
I get the same outcome if I select rectangle test just after redraw test with the camera hanging with the red and blue LEDs lit and I need to pull the battery.

I hope that helps narrow things down.

3
Camera-specific discussion / Re: Canon 50D
« on: October 11, 2016, 12:05:28 AM »
ADJ,

I've had this crash thing going on too using the powergrip. I stopped using the power grip and now its no longer happening.

I tried it today without the battery grip and the effect is the same.

4
Camera-specific discussion / Re: Canon 50D
« on: August 20, 2016, 11:38:53 PM »
I have been testing this issue tonight, been guided by A1ex on IRC.
I'm glad to hear someone's able to help. I've never compiled ML nor have I used IRC so it would take me a while to get up to speed.

5
Camera-specific discussion / Re: Canon 50D
« on: August 18, 2016, 11:23:44 PM »
 :-[
Sorry I missed that.

The script reboots fine!

6
Camera-specific discussion / Re: Canon 50D
« on: August 18, 2016, 10:25:36 PM »
Does this Lua script work for you?

Thanks a1ex
I've never used a Lua script before but it loaded when I turned the camera on. On formatting I got the same effect as before with the camera hanging. Hope that helps and I didn't miss something.

7
Camera-specific discussion / Re: Canon 50D
« on: August 18, 2016, 07:53:09 PM »
I thought I'd check with other users before submitting a bug report. Is anyone else having problems with the last two nightlies? With the new files it seems to hang the camera for me when I format the camera. As usual it says "magic lantern restored :)" but then the new step "restarting camera" executes buts does not complete. The red and blue lights stay on and the camera hangs. It won't restart until I pull the batteries. I'm using a grip. I've tried it on 3 different Komputerbay cards all 1000x.

8
Hardware and Accessories / KOMPUTERBAY 1000x price drop on Amazon uk
« on: June 03, 2015, 08:33:57 PM »
I got an email from camelcamelcamel about a pricedrop on Amazon uk for KOMPUTERBAY 1000x CF cards.

http://uk.camelcamelcamel.com/Komputerbay-Professional-1000x-COMPACT-Extreme/product/B009JS61MK

£30 for a 32GB 1000x card
£55 for a 64GB 1000x card

Other sizes have similar reductions.


9
General Development Discussion / formatting CF card to ZFS
« on: April 01, 2015, 08:38:51 AM »
Following A1ex's post http://www.magiclantern.fm/forum/index.php?topic=14847.msg143774;topicseen#msg143774
I can also report I  had some limited success with other operating systems. I've been running PC-BSD on an old laptop since M$ stopped supporting XP. http://www.pcbsd.org/

PC-BSD uses the ZFS filesystem. You can read about how to format a usb stick to ZFS here https://forums.freebsd.org/threads/zfs-on-an-usb-stick.22379/

Recently I tried formatting my Compact Flash card to ZFS. I then transferred the files from another card and restarted my 50D. Actually it bricked my camera but I had another 50D and when I tried it on that I found that it worked just fine.

I haven't had much time to test it out but it means the 4GB limit which came from the FAT32 is no longer a problem. We 50D users can't format the cards as exFAT. The camera now can record H264 continuously up to the 30 minute limit.

Interestingly enough it also produced less heat. I shot some MLV raw video at 1984 x 830 and the temperatures were about 20-30 % lower than before I reformatted to ZFS. I shot some video at my porcine ornithology club but I haven't had time to go process it all yet but I can confirm it does load in Davinci Resolve.

Maybe someone more technical than me here or on the FreeBSD or PC-BSD teams will be able to make further progress. You can also use the ZFS filesystem on a Mac and Linux so this one might fly.

10
Camera-specific discussion / Re: Canon 50D
« on: March 06, 2015, 08:00:20 PM »
I was looking at the latest Nightly and saw that the 50D Changelog includes:

"df0bbfe | g3gg0
mlv_rec: major fixups for card spanning and preallocated file names"

It was my understanding that the 50D can't do exFAT or card spanning. I think it therefore has a one second or so pause when recording all formats H264, MLV or RAW. For stock settings of H264 the limit is reached at 4GB which is about 17 minutes into a recording. Am I missing something?

11
Shoot preparation / Partial Solar Eclipse - Glasgow 20th March
« on: March 04, 2015, 09:54:51 PM »
I was thinking of shooting a timelapse of the partial eclipse on the 20th March. Does anyone have an suggestions to make the most of the opportunity?

http://www.timeanddate.com/eclipse/in/uk/glasgow

12
Post-processing Workflow / Lightworks 12 beta on a mac
« on: June 11, 2014, 08:20:32 AM »
I noticed lightworks have released a beta of version 12 for the mac. I'm on windows and ubuntu so can only get version 11.5.1

http://www.lwks.com/index.php?option=com_lwks&view=download&Itemid=206

13
There was one article online which talked about a June date for release of version 11. Today 10.1.5 was released but it's a fairly minor update rather than the major release that a lot of people are waiting for.

14
Post-processing Workflow / Re: UFRaw-mod - a tweaked version of UFRaw
« on: April 24, 2014, 08:47:46 PM »
Thanks A1ex for offering to take a look. I uploaded some files to https://www.dropbox.com/sh/myapniqklu5fm8k/cizAKnZQDm

File 7294 is probably the one to look at. I was just using the intervalometer for the first time and so had a go at a sunrise. I can improve the bad photography but the pink highlights are beyond me.

15
General Help Q&A / Re: EOS 300D
« on: April 24, 2014, 06:56:25 PM »
I have an old 300D. It will not run ML and the only extra functions come from the UnDutchables hack which re-writes Canon owned code.

ML does not do that and is very careful to respect Canon's right. Unlike ML I don't think it offers much in terms of increased functionality. I think you might be able to get ISO 3200 and it allows you some control over the brightness of the flash. From what I remember the 3200 was so noisy it was hardly worth the trouble. My advice would be to upgrade your camera to something that will run ML.

16
Camera-specific discussion / Re: Canon 50D
« on: April 19, 2014, 10:21:51 AM »
I...am using a Lexar UDMA 7 card reader USB 3.0 

All my other footage is OK except this one file and its an important shot that we need.  Any other help would be greatly appreciated...

It might not be the card especially if it's reading the other files properly. It's just that I was reading this http://www.magiclantern.fm/forum/index.php?topic=9747.msg93779#msg93779 which does mention your card reader. I've had files which have refused to copy 3 or 4 times but with persistence have copied properly. I don't know why. I also have some corrupt mov files I'd like to rescue but can't find a way of doing it.

17
Post-processing Workflow / Re: UFRaw-mod - a tweaked version of UFRaw
« on: April 18, 2014, 11:21:09 PM »
Works very well on Windows 7 - 64bit.
I was trying to use Alex's patches tonight but cannot get them working. Maybe I'm doing something wrong. There are two sets of files which I could download at https://bitbucket.org/a1ex/ufraw-mod/downloads
I assume I should just download the most recent zip, extract the files, and overwrite the Ufraw versions. This is not working for me. I have some ETTR timelapes and I have some pixels going pink/magenta in the overexposed areas. The files are working fine with UFRAW except for the magenta areas. I tried the other zip but that's not doing much either. I did reboot after overwriting the files.

Is there something obvious I'm doing wrong?

RenatoPhoto maybe you'd like to update 1. for windows users from the UFRAW WORKFLOW section

"...I used the windows for dummies version from here:
http://sourceforge.net/projects/ufraw/files/ufraw/ufraw-0.19.2/ufraw-0.19.2-2-setup.exe/download"

to mention Alex's updates?
I'm using Windows7 x64 Home Premium SP1, i3 CPU, 8GB RAM. The camera is a 50D on a fairly recent nightly.

18
Camera-specific discussion / Re: Canon 50D
« on: April 18, 2014, 07:04:57 AM »
Why would it play fine and look normal in the MLV player then when put on the computer be all messed up?

I suspect it's your card reader. Try and use a usb3 card reader if possible. I have a CF card reader on the front of my machine but it messes up stills and video from my Komputerbay cards which work fine from a card reader plugged into the USB3 port at the back. Other than that try transferring the file again or recovering it if it's been deleted but not overwritten.

19
I see 10.1.4 was made available yesterday but version 11 isn't downloadable just yet. It was reported that it will be available as a download in June.

The main features are summarised here. http://www.blackmagicdesign.com/products/davinciresolve/compare

20
I found the above method didn't work with some of my files so after a bit more looking found MyMP4box gui
 http://www.videohelp.com/tools/My-MP4Box-GUI

I had trouble installing it on my w7 x64 system but got it working once it was installed in c:\Program Files (x86)\

as described on http://forum.videohelp.com/threads/329598-Can-t-open-up-My-MP4Box-right-after-installation

Once working, this allows very speedy demuxing of the 50D mov files made with exact fps override. These can be changed from 30 fps to one of the presets (15, 23.976, 24, 25, 29.970, or 30fps) before muxing to mp4 without transcoding.

Lightworks http://www.lwks.com/ seems to accept these mp4 files once the fps issue is sorted out and reports them as 1920 x 1080 rather than 1920 x 1088. Hopefully lightworks will relent in the future and go back to allowing output greater than 720p for free.

Sorry to be replying to my own posts but maybe it will speed someone else up in the future. Thanks to everyone on these boards for their contributions.

21
In case it's useful for someone else I tried this workaround which seems to work on windows 7 x64:

demux the .mov from the camera to m2ts using tsMuxeR http://www.videohelp.com/tools/tsMuxeR

mux the resultant m2ts file using MkvToMp4 http://www.mediafire.com/download/1a0oc04u539b5eg/MkvToMp4_0.224.zip

if you double click on edit track it lets you change the fps to 25.

The m4v file which results will import into Lightworks and displays as 25fps.

This is a LOT faster than transcoding.

There has to be a better way.

22
I have some H264 footage shot yesterday on a 50D, 5D2 and 60D. I want to edit in Lightworks. The 50D footage was shot with fps override set to 25fps which is what the other cameras were set at. Lightworks erroneously reports the 50D footage as 30fps since that's what the metadata says. I can't get the 50D footage to import into Lightworks without transcoding the mov files which is time consuming.

Is there any freeware which will change the metadata in post without transcoding everything? Maybe there's a global setting or if the first frame is changed to 25fps maybe the software will accept it?

On Windows I can transcode with Eyeframe Converter http://www.videohelp.com/tools/EyeFrame-Converter
or WinFF http://winff.org/html_new/downloads.html
or Shotcut http://www.shotcut.org/bin/view/Shotcut/WebHome

If transcoding is necessary, what would be the best setting to use in terms of speed without degrading the video too much?

I did a search through the forum but the nearest I could find was this:

http://www.magiclantern.fm/forum/index.php?topic=7038.0

Is everyone on the 50D shooting raw all the time or does anyone shoot H264?

23
Dan Dennedy(of Kino and MLT fame) released the first peek of the new multitrack timeline function of his free, cross-platform NLE called Shotcut.

It shows great promise, so check it out!


Thanks for that tin2tin. It does look like the best hope for a free NLE that isn't a hook for a payware product since Lightworks have restricted their free output to 720p.

IVSedits http://www.ivsedits.com/default/compare.aspxalso have software which can open targa (from raw) and output at higher than 720p but they won't accept H264 mov input for free which is a disappointment  to users like me who also shoot canon 1920 x 1088.

24
Share Your Videos / Re: Oh my deer - 5D Mark III Raw Clip
« on: February 07, 2014, 08:04:11 PM »


The moods were captured with the Canon 5D Mark III

You captured some beautiful images. Thanks for sharing them.

Pages: [1]