Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Messages - Molinsky

Pages: [1] 2
1
Tragic Lantern / Re: 50D and 40D Raw video
« on: October 16, 2013, 10:31:59 PM »
Fixed that compile error.

Flashing? When?

Remember the flickering in the menu? I posted a video showing the issue after load the module. I believe it's a similar problem.

2
Tragic Lantern / Re: Raw video on 50d and 40d
« on: September 03, 2013, 10:59:10 PM »
Did he get himself banned again?

Surprised?

3
Tragic Lantern / Re: Raw video on 50d and 40d
« on: August 23, 2013, 01:55:33 PM »
Hi guys,

More informations about my previous problem (perhaps similar to Molinsky).

With the latest Tragic Lantern 2.0, when I switch from photo mode to live view, the screen come black and the dslr not responding (only the LCD control panel display av,tv,iso..). The solution is to remove battery for reuse.

So, I disable all module and activate one by one and switch from photo mode to live view to identify which one cause trouble. I've the problem when I activate raw_rec module. When it's disabled, no problem appears.

I also had a problem when I leave the live view to return to camera mode (when raw_rec disabled), I get a vsync error.

Do you have some suggestions ? Could I try something to help you ?

Thanks for your works!

[sigh] Yesterday, I had all problems possible and wasn't able to post here other tests or the config file.

But it's hard anyway when no one else has reproduced the bug.

4
Tragic Lantern / Re: Raw video on 50d and 40d
« on: August 22, 2013, 01:43:33 PM »
Can you upload your magic.cfg and raw_rec.cfg files?

Oh boy, not now. Just when I get home. :P

Its not doing it to me. I think an extra black bar is drawing with raw_rec + movie mode.

I did find some display filters fight with the grayscale preview, ie defish.

I have no ideas anymore. Having problem with all the previews.

I copied Modules folder under ML directory, however nothing happens. Please let me know what shall be done in order to enable it in my 50D. Do I have to copy the files raw_rec.o, raw_rec.mo & magic.sym in another folder?

Did you loaded the modules after started the camera?

5
Tragic Lantern / Re: Raw video on 50d and 40d
« on: August 22, 2013, 03:12:32 AM »
Thanks for the reply, @1%. But it's flickering with any of the previews. Actually, I made a very extensive evaluation sequence here and I noticed that it's really something in the raw module only. I let every other module loaded (but the raw_rec.mo), and it's ok.

But load the raw module and try to use it... BAM! I have to shoot without any ML overlay, totaly blind about the right framing, histogram and stuff.

A friend of mine says that I like to play with "Flickr", the camera. Pun intended.


I laughed, but I'm getting frustrated.

6
Tragic Lantern / Re: Raw video on 50d and 40d
« on: August 21, 2013, 08:38:27 PM »
While at job, I've been making some research and found that my issue (Canon gui flickering over ML overlay) is not new in the 50D raw environment.

for those following along at home, the empire strikes back and the canon gui is showing up during raw recording in my recent build.
you do NOT want the canon gui during raw recording as it will slow it down.
ideally you'd want to use magic lantern histogram and spot exposure during raw recording.
(waveform is based on YUV not raw so it may not be entirely accurate during raw recording)

Active and moving? that's not quite good.

The only easy solution that I see right now is to try globaldraw on and all other things disabled.

Or... hack the CONFIG_KILL_FLICKER code so Canon GUI can be disabled from some other tasks too. Not sure what is the best way to implement this; maybe a reference counting like LV RAW mode from raw.c.

Seems there is a CONFIG_KILL_FLICKER ifdefs somewhere (found it instantiated at internals.h?), because the problem occurs when I load the modules. I also tried some stuff already recommended, but nothing solves the bug. Since only myself, apparently, is having this problem and I keep deleting the config file, is there something I have to set in the Canon menu?

ps¹.: funny thing, I also found a lot of overlay bugs reports (i.e. http://www.magiclantern.fm/forum/index.php?topic=3697.msg36245#msg36245 and http://www.magiclantern.fm/forum/index.php?topic=1886.0 )
ps².: if someone is not aware of the problem I'm dealing with, watch this video:

.

7
Tragic Lantern / Re: Raw video on 50d and 40d
« on: August 21, 2013, 03:30:31 AM »
Dammit, the overlay is flickering all over again! It only stops in two situations: either turn the Global draw off or turn the raw video mode off.

8
Tragic Lantern / Re: Raw video on 50d and 40d
« on: August 21, 2013, 03:12:41 AM »
Molinsky try this download Andy's Tragic 7 build after you do don't change anything from it, than simply add the 50D firmware in that folder that's it.  That should solve all your problems..

@Andy600 & @goldenchild9to5

Thank you so much, guys, for all the help. I'm sorry about this late reply. Unfortunately (or not), I work all day and only have the night to test everything in the camera.

I deleted everything I would not use in the card: pdf files, other cameras firmwares, config files... and it works for now after I tested some customized videos.

The thing is: I use a very crappy card. It sucks so bad, has only 29mb/s of write speed. That's why I didn't posted any test, I'm waiting (forever) for my Transcend card. It is possible this card be the reason of such instable interface overlay?

9
Tragic Lantern / Re: Raw video on 50d and 40d
« on: August 20, 2013, 04:36:58 AM »
A lot can happen in a week so it's worth keeping up to date ;) but I don't think your problem is related to the build you are using. It must be something in your settings.

Well, did everything from scratch. Formatted card, updated to ML 2.3, changed the ML folder and the autoexec.bin with the ones in the build and... everything ok until I change something.

I'll try again tomorrow.

10
Tragic Lantern / Re: Raw video on 50d and 40d
« on: August 20, 2013, 03:19:05 AM »
The only builds I used was the ones from August 4th and 12th. I'll download the latest now.

11
Tragic Lantern / Re: Raw video on 50d and 40d
« on: August 20, 2013, 03:09:50 AM »
@Andy600

My screen is all messed again. Everything changed back to default after deleting the configuration file. Then I changed the FPS override to 24, exact FPS. The overlay keeps changing as in the video.

12
Tragic Lantern / Re: Raw video on 50d and 40d
« on: August 20, 2013, 03:05:18 AM »
So, I don't have to worry about WB anyway?

13
Tragic Lantern / Re: Raw video on 50d and 40d
« on: August 20, 2013, 02:56:05 AM »
@Molinsky - Have you tried deleting your config files?

Thank you very much, @Andy600! Everything is normal now.  :D

Also, I noticed in your video that you have UniWB? Is anyone else missing this on the 50D because I don't seem to have it on mine  ???

I found the UniWB by accident. I was checking the RGB from a overexposed white picture and adjusted the white balance by the R/G/B multiplier. While the values differ, setting RGB to 1015, 1015 and 1103 respectively made me find the UniWB.

Yes I'm missing the UniWB on my 50D.  What does it stand for, or what function does it have?

It stands for "universal white balance". It means, basically, that I don't have to worry about it. My histogram for RAW is as close to reality as possible. I found this answer very good:

http://photo.stackexchange.com/questions/664/what-is-universal-white-balance-uniwb

14
Tragic Lantern / Re: Raw video on 50d and 40d
« on: August 20, 2013, 01:22:17 AM »
Hi, guys! I'm having a problem when I'm loading the modules with Tragic Lantern. It's impossible to use with the Global Draw and I don't how to check my histogram anymore.

I tried some builds and the one in this video is the first build with dual iso.


What do I have to do to fix it?

p.s.: sorry about the quality, two hands to record AND manage the 50D.

15
Tragic Lantern / Re: Raw video on 50d and 40d
« on: August 20, 2013, 01:15:45 AM »
Loving the new and improved site. I think it is going to be much easier for the newbies to find their way around installation and downloads. 8)

Yeah, great surprise today! It's very beautiful.

16
Tragic Lantern / Re: Raw video on 50d and 40d
« on: August 19, 2013, 03:58:59 PM »
the thing that surprises me
that there is only 40-100 times downloads for each of the builds

is it just 40 people sticking around over this forum topic?

Yeah, I was very curious about this number. I always thought that the 50D was kind of "winning the world" now.

And my Transcend card never arrives... I think I'll post some tests I made with a 30mb/s "top speed" card. Because it's what I got now.

17
Tragic Lantern / Re: Raw video on 50d and 40d
« on: August 16, 2013, 03:50:03 PM »
Looks identical to me... probably because it is  ::)

...and ISO 1250 will no doubt look the same too

Nah, 3200 looks tightly better to me - or less worse. There's almost a red block above the "1600" tag. But, then again, in this image. Probably, like you said, the higher ISOs are not practically different.

18
Tragic Lantern / Re: Raw video on 50d and 40d
« on: August 16, 2013, 02:15:04 PM »
Here, I did a 50D ISO test. Click on the image to see in full-res.


ISO test with RAW set to normal exposure.


ISO test with RAW Exposure set to 5+

Looks like ISO 100 and 200 are very close. Hope this helps!

The 3200 looks better than 1600.  ???

19
Tragic Lantern / Re: Raw video on 50d and 40d
« on: August 14, 2013, 07:02:44 PM »
You will have to tell us a little bit more about your noisy footage. Anyway, usually, to avoid noise you will try to expose (changing the shutter speed and aperture) to the maximum, and use the lowest iso you can. This will give you the best you can get in terms of noise.
If you are trying to film a concert or anything dark, get another camera.

Well, that sure answers my question. Thanks! Since I'm a day worker, all my test footages had been shot at night. And I exposed to the limit of acceptable, not to the maximum. Looks like it works like the BMCC footage.

20
Tragic Lantern / Re: Raw video on 50d and 40d
« on: August 14, 2013, 06:34:23 PM »
Or is it a good idea to use the embeded 50d profile first (i work with cdng from raw magic) to denoise and sharpen, export in dng and run through camera raw again with your profile and adjust the highlight/shadow areas if needed?

Oh, wait! I didn't know about a 50D profile. My test footages are all super-noisy. Where can I find a way to deal with it? Everyone says something different.

21
Tragic Lantern / Re: Raw video on 50d and 40d
« on: August 13, 2013, 11:05:40 PM »
Ah thanks! Didn't know that. Is 1080p recording in no crop something realistic to archive or more like something impossible? :p

It's impossible. I know it's hard to find answers in such big topic, but that was explained: the RAW image is from the LiveView image, which uses only one line of pixels at each three lines. So, 4752/3 is 1584.

22
Tragic Lantern / Re: Raw video on 50d and 40d
« on: August 12, 2013, 01:44:29 PM »
You also have to interpret the footage as 24fps in you NLE.

Thanks too, I was getting confused about the fps in my NLE.

23
Tragic Lantern / Re: Raw video on 50d and 40d
« on: August 09, 2013, 10:29:56 PM »
Just a general comment to anyone reading this. Before you ask questions please credit the developers of ML with some intelligence. You may have a bright idea but the chances are they have already been there, done that and bought the t-shirt. They are already pushing the cameras way beyond the limits of what Canon themselves envisaged.

I don't know if that was indirectly addressed to me because of my question, but my doubt was to anyone that can answer me.

I don't have anything to say to the devs, but "thank you". Man, yesterday I made a video with my 50D with an old CF card (get to 30mb/s write speed) and I managed to achieve 1152 x 540 some times. Blowed my mind, I can't wait my 64gb 1000x Transcend to arrive.

But I made a question about the 2000px of width because:

1-
H.264 is line skipping just the same as non-crop mode is with raw video then upscaled to 1080p. It's not resolving full 1080p. Crop mode records 1:1 pixels from a portion of the sensor. There is no inbetween capability. It's not adjustable.

And the sensor in 50D have 4752 pixels of width.

2-
There is a comment in the code that says:

Quote
resolution should be multiple of 64x32 or 128x16
this way, we get frame size multiple of 512, so there's no write speed penalty

So, I want to understand the 2000px width, not questioning the reason. Just seams that 2048px would make more sense and I'm not finding an answer in this 100+ pages topic.

edit: I just tried the crop mode. Two seconds on some great resolutions... and there is 2048px there. My bad. So I guess there is no need for answers, although I don't understand everybody writes "2000" instead of "2048".

24
Tragic Lantern / Re: Raw video on 50d and 40d
« on: August 09, 2013, 08:56:48 PM »
Since @pulsar124 is making those questions, I have a question too about the limit of available resolutions in the 50D.

Why you can select the width up to only 2000px in crop mode (it's not even 2048)? It's because of the sensor or something? I mean, I could use a 3:1 ratio with large width, no?

25
Tragic Lantern / Re: Raw video on 50d and 40d
« on: August 09, 2013, 03:29:51 PM »
I shot some low light tests last night and processed everything in Raw Therapee (AMaZE demosaicing), output Jpeg and rendered in AE. The debayering and upscale is very good in RT and doesn't seem to have the flicker problems that ACR has.

These shots don't have any noise reduction. I only balanced and slightly sharpened, not even graded yet  :). It was actually a lot darker than it looks.

Do you apply sharpening before or after upscaling the image in the RT?

Pages: [1] 2