Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Messages - kaco

Pages: [1] 2 3 4
1
General Chat / Re: The 'when' question
« on: April 26, 2019, 07:44:17 PM »
a1ex, just wanted to say ML changed my life completely. Thanks to a ML raw I have been able to quit my corporate job, start my own business, learn a LOT about image processing, color grading a professional tools/workflow while 98 % of the colleagues have been buying new DSLRs every year. Most times I see some pretty good film on vimeo made by independent or a single creator, it has been shot in ML raw.

My 5Dm3 is a small alexa, served my amazingly for 5 years and I was not able to find any better tool for my job.

Cannot thank you more for all what you did. Doesn't matter that much if the development continues, you have already made a huge impact on the in-depended and young film makers (and even a high budget cinematography).

2
General Chat / Re: Nikon Z RAW video
« on: January 11, 2019, 11:17:24 AM »
don't get fooled. prores raw is not raw.

It is in fact. There's also a theoretical chance of build prores raw to DNG convertor, only Apple will never allow this.

3
Think about getting g3gg0 involved, too. He had the suggestion to sync the other way round using camera's LED to trigger stepper motor. Short mention about it in linked thread.
Requires a custom build, though.

That's basically what my setup is doing. Remote controller cable connected to arduino doing half and full press, simple photoresistor reading camera LED and a optical trap stopping stepper motor when the film is at correct position.

4
Hello Aileron!
The short answer is that I don't think your camera can be synced to the projector with Canon or ML settings.  Mostly because the projector speed is not as precise or consistent as your digital camera.  The banding is most likely the projector shutter partly blocking the frame when the exposure is made in your camera.  The best video I have found to explain the projector operation is by the engineerguy you can check it out here https://www.youtube.com/watch?v=En__V0oEJsU

Thank you Walter Schulz for mentioning my project!  There are a couple more forum members that have built projects working along the same lines as mine.  I have not gotten back to my projector in a while, I still plan to and to post additional details on how and why I built it the way I did.  I also have a good 8MM/ Super 8 projector still to build for ML movie capture. 

If you only have a few film reels and you already have preview copies made you might consider looking for a hi-quality transfer service since a build like I did is time-consuming. If you search my previous posts there are some notes on setting up the 5D3 for frame by frame capture.  The biggest change that I need to make on my machine is to replace the reed switch trigger (not easy to get working right) with a hall sensor.  Good luck!
 
Mike

Dear Mike,

is there any convenion way how to get in touch with you and discuss your telecine? I have built a similar telecine for 8mm, arduino powered stepper with optical trap and canon camera running ML for frame by frame capturing. However, I have few questions to ask, maybe sharing of knowledge would help?

Thank you!

5
Feature Requests / Re: FPS override to 36fps
« on: September 29, 2018, 10:35:07 AM »
Done (crop_rec_4k build).

Hi a1ex, could we have this also in raw_video_10bit_12bit_LVState branch? I find 36fps much more useful for 10bit and I still use this over crop_rec.

Thank you!

6
Raw Video / How to get a proper crop_rec 1080p48 preview?
« on: September 02, 2018, 04:07:39 PM »
Hi!

Thank you everyone involved in development of ML, I am shooting raw since the very beginning it came out (www.vankusik.com, www.kacofilms.com). Almost every week I shoot approx 2-5 Tb of data.

Squeezed 48p is still great, but the resolution is not much.

I would love to switch to crop_rec 48p 3x3 binning, only not sure how you work with the preview? With the BW low resolution preview in is really hard to focus.

Is there any chance to port this new module to 5D3 FW 1.2.1 and then use HDMI viewfinder? And then ultimately hack the HDMI feed with some red cross when not recording (Since I experience frame skipped from time to time, it would be great to know from the feed if the camera is recording or not).

Thanks!

7
You can also setup "disable global draw" on half-pressed shutter. This is how I work with 3x3. I have a choppy preview (anamorphic desqueezed) and if I need better realtime preview, I just halfpress the shutter.

8
Feature Requests / Re: FPS override to 36fps
« on: January 23, 2018, 11:07:49 AM »
... it got lost near a line break and nobody noticed (back in 2014).

Wow, sounds promising. I have created ticket request, unfortunately that is the only thing I know (and shooting in ml_raw) :)
https://bitbucket.org/hudson/magic-lantern/issues/2835/fps-override-to-36fps

9
Feature Requests / [DONE] FPS override to 36fps
« on: January 23, 2018, 10:03:28 AM »
Hi!

Is there any fundamental reason why FPS override settings is disabled to the value of 36? (When you scroll on FPS override it jumps from 35 to 37)

Having 36fps would mean better workflow for documents - 150 % for slowmo, blending every third frame for real speed. Realtime playing back 35/37fps footage in 24fps sequence brings much more problems.

Thank you,

10
General Chat / Re: C200 RAW 4K internal
« on: September 08, 2017, 10:52:28 PM »
Would really like to know if cinema raw light goes native with Davinci Resolve? I can't have a camera that needs poorly canon software. Thanks for a reply!

I had few sample C200 raw files. It works in Davinci 14 beta. The only problem (probably a matter of time) is that it is being interpreted as some log (canon log probably?) and the raw panel is not working. So you have to adjust your exposure and white balance with 3 color wheels. But the data is there (highlights, etc).

11
Post-processing Workflow / Re: Warning Davinci Resolve 14 bugges
« on: September 08, 2017, 10:48:55 PM »
It is beta! But it is working for me, also with project imported from Davinci 12.5.
In first two or three public betas my power grade gallery was not being imported correctly, but now most of things work for me just fine.

Cheers.

12
Raw Video / Re: 5Dm3 10-bit aperture moving while shooting
« on: July 31, 2017, 03:38:37 PM »
Actually I found the problem with the Expo Override ON. So for me, the solution was found. If the aperture should do this when ON, you can delete this thread and accept my apologise.

13
Raw Video / Re: 5Dm3 10-bit aperture moving while shooting
« on: July 31, 2017, 03:31:21 PM »
As I'm unable to reproduce it, and it sounds like a pretty unusual bug, you'll have to narrow it down:

- does it happen without FPS override?
- does it happen with other lenses?
- does it happen with a manual lens? (if yes, it's not aperture flicker)
- does it happen when recording H.264?
- does it matter whether you use mlv_rec or mlv_lite?
- does it help if you disable small hacks?
- did you use exposure override in ML?

Hi,

tested with another 5D with same results. Also I have two 35mm F/2 IS both "breathing". It is not related to the IS -- it breathes even when IS switch on the lens is OFF.

- does it happen without FPS override?

- does it happen with other lenses?
I've tested few more:
- Canon 85mm f/1.8 -- no breating
- Canon 100mm f/2.8 IS -- BREATING
- Canon 24mm f/1.4 II -- no breating
- Canon 70-200 f/4 IS -- no breathing
- Tamron 45 mm f/1.8 VC -- no breathing

First I thought it's the IS lenses doing it. But 70-200 IS is not breathing. Also Tamron has it's vibrance compensation and works fine.


- does it happen with a manual lens? (if yes, it's not aperture flicker)
No flickering/breathing with manual lens.

- does it happen when recording H.264?
- does it matter whether you use mlv_rec or mlv_lite?
I can see the aperture moving in live-view, does not need to start recording. If I take ML card out, there is no aperture moving. I have disabled all modules, restarted, but the aperture is moving. So probably problem of some core ML features?

- does it help if you disable small hacks?
No

- did you use exposure override in ML?
Yes. Turning it off actually solved the problem. :D

14
Raw Video / 5Dm3 10-bit aperture moving while shooting
« on: July 31, 2017, 01:11:20 PM »
Hi,

I've been using MLraw a long time for a weddings. Since january I started using 10bit 37fps instead of squeezed 48p. I found a little flickering in the image, but I though it is some kind of a problem with FPS override.

I found out that the aperture is slightly changing it's size while shooting. You can see the problem here, pay attention to how the aperture is floating all the time.

Tested also with the latest build 2017-07-02 22:47 and the problem is still there.

Set-up:
5D mk3, FW 1.1.3.
Lens: Canon 35mm f/2 IS (IS turned off for this test)
FPS override: desired 37, optimize for Exact FPS, actual fps 37.001
I can see the problem on f/2.2, f/2.4, f/3.2, f/3.5, f/4.5, f/4.9, f/7.0, f/9.1...
The aperture is okay (fixed, not moving) when on f/2.8, f/4, f/5.6, f/6.4, f/8,...

Second problem: Sometimes I am not able to change aperture while shooting. In the bottom-left corner I see a sign "BUSY" and the aperture changing does not work. When I press "Q button", the "BUSY" sign will get away and everything starts working again. See the problem here:


15
Raw Video Postprocessing / Re: MLVProducer
« on: April 18, 2017, 12:18:39 PM »
@AWPStar, great tool, thank you!

Bug:
1. Could you please add scrolling to the Media queue window? Sometimes I have like 500+ files and it will not fit into the window.

Feature requests:
2. Any plans in implementing 14bit lossless files?

Thank you!

16
Respect to a1ex and the whole magiclantern team.
No more excuses for not producing world class imagery.

17
Or would it be to complicated to change the mlvfs so that it will automatically start indexing all of the files after mounting?

18
There is a maximum size for the HTML generated by the MLVFS webgui. You can make it bigger if you like.  More work, but also possible would be to dynamically allocate that buffer, eliminating the limit.

If you don't put so many files in a single folder you shouldn't have this issue, and you also shouldn't have to force MLVFS to generate index files using the webgui like you are doing. When you browse to a folder in the virtual file system, all the MLV files in the corresponding real directory have to be indexed before that operation can complete. Did windows explorer actually crash or was it just taking a long time and you gave up and killed it? It may take quite a while to index 1000+ MLV files.

With Resolve, if the file is big (sometimes single file can be 100Gb+), it takes longer then Resolve can wait and it imports not all of the cdng. With no warning. So that is why I generate index files via webgui.

Also with Windows Explorer, if I copy not indexed files from mounted drive (sometimes I need to copy cdng for postproduction studio), for some very big files it will copy empty folder (probably the windows explorer copy function has some timeout?).

Would you be so kind and help me where to change the size of html?

19
That is a very old and irrelevant comment that only has to do with the old pismo version which doesn't exist anymore.

Are you saying that the webgui will only show you the first 345 files if you have more than that in a single folder? Have you tried a different set of files? Is the limit still 345? Could you be more precise about what exactly is happening and maybe include screen shots? Have you looked at the console output? Have you tried separating the files into sub folders so there's not so many in a single folder?

Windows 10, 64bit, RAID drive, exfat, folder with more then 345 files (1000+):
1. mount the folder with mlvfs, console shows nothing
(if I will open mounted drive in Resolve or under Windows Explorer, it will hang and then crash, because files are not indexed yet. MLVFS will however start to index those being opened by Resolve/Explorer)
2. when called locahost:8000, it will start to index. However, it will index only first 345, it will also print only the first 345 on the localhost page. Console displays just indexing info, nothing unsual. All files are valid. Same behaviour for different folders.
All files are in the root folder, no subfolders.

So for now, I have to run mlvfs, call localhost, let index first 345, move indexed files to another folder and then refresh localhost to let another 345 files to index.

Let me know, what could I do to help. Record youtube video?

20
I have no clue what you are talking about. Could you reference what source file and line number you are referring to?

Comment for this file: https://bitbucket.org/dmilligan/mlvfs/src/9f8191808407bb49112b9ab14c27053ae5022749/mlvfs/index.h?at=master&fileviewer=file-view-default
Windows: IDX files no longer created upon mounting

The problems with 345 files limit is not on macOS, I am working under WIN10 64bit, disk formatted in NTFS.

21
The file limit displayed (which means also indexed) by localhost is 345.

In the source code I have found that you have disabled indexing after files are mounted. What was the reason for this? For me, it would be much better to mount, wait until everything is indexed and then start working with it.

Now it crashes even Windows Explorer, if I try to open big not indexed files.

22
Hi,

I have a problem with windows port.
When called on a lot of files (1000+), after calling localhost it will process/index only approx first 500. first 345. The rest will start indexing after I open the mounted folder, which crashes the Resolve while waiting for the folder to list.

I think this must be some kind of hardcoded file limit? Is there a chance to higher this number? I get hunders of files from every shooting day. :)

23
On 5D3 and probably all other recent cameras, latest mlv_dump requires --black-fix=2048, regardless of ML build (since this post).

With latest ML bulid from the Experiments page AND latest mlv_dump, there should be no need to change the black level (since this post).

Great! However I still find batch calling mlv_dump much better then mlv-fs. Is there any way how to make real cdng from mlv_dump? So that Resolve could read audio and correct fps? Or this wouldn't work because mlv_dump is not indexing the files?

Thanks

24
BTW, may I process *all* files with --black-fix=2040, even those which have correct value? If I want to process only those wrong ones, I need to extract all and visually check.

25
Hi guys,

on Saturday, I've sucesfully shot 2TB of MLV's in 10bit. From 1400 filex, approx 150 had wrong black level. Since calling mlv_dump 150 times and then sorting all the files would be too complicated, I've wrote little windows batch script. I am not a programmer so finding the first file in a folder and even the iteration is very very messy. But works. :)

Code: [Select]
@echo off
setlocal EnableDelayedExpansion
set mypath=%~dp0
set workingDir=E:\footage\mlv\
set fixDir=E:\footage\cdng-fixed\
set moveDir=E:\footage\mlv-processed\


E:
cd %workingDir%
for /r %%i in (*) do (
set file=%%i

!mypath!\mlv_dump.exe --black-fix=2040 --dng "!file!"

for %%A in ("!file!") do (
set foldername=%%~dpA
set filename=%%~nxA
)
echo !filename!

cd "!fixDir!"
md "!filename!"
cd "!filename!"

for /r "%workingDir%" %%f in (*.dng) do move "%%f" >nul
for /r "%workingDir%" %%f in (*.wav) do move "%%f" >nul

move  "!file!" "!moveDir!"
)
D:
cd %mypath%

Pages: [1] 2 3 4