Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Messages - tajino

Pages: [1] 2
1
Raw Video / Re: RAW+FPS override=error every second frame
« on: May 01, 2018, 12:18:58 AM »
@a1ex This is way beyond my league, hoping that you or g3gg0 could take a look if possible. Thanks!

2
General Development Discussion / Re: mlv_dump on steroids
« on: May 01, 2018, 12:15:26 AM »
Thanks bouncyball & g3gg0  :D looking forward to the feature addition.

3
General Development Discussion / Re: mlv_dump on steroids
« on: April 27, 2018, 09:18:19 PM »
How about -f "frameslist.csv" ?
make the -f switch when referencing a user generated .csv to only include those frames listed in it.


4
General Development Discussion / Re: mlv_dump on steroids
« on: April 27, 2018, 05:42:24 PM »
Yeah... unfortunately this is not supported by mlv_dump directly (MLV -> MLV).

What's wrong with exporting DNGs and just picking the needed ones?

Nothing wrong with it, that's what I did. It is just that I would usually keep the source MLV, just in case in I need to re-dump the MLV with a newer/better mlv_dump with improved vertical banding removal, etc. maybe who knows.


5
Raw Video / Re: RAW+FPS override=error every second frame
« on: April 27, 2018, 05:32:26 PM »
Don't use 10x zoom.

What do you mean don't use 10x zoom? I get this issue in 1x zoom.

I have this issue on my 5D2 from magiclantern-v2.3.NEXT.2014Feb16.5D2212 to the recent magiclantern-Nightly.2018Feb04.5D2212
Details in my post here https://www.magiclantern.fm/forum/index.php?topic=11205.msg200609#msg200609


6
Camera-specific discussion / Re: Canon 5D Mark II / 5D2
« on: April 27, 2018, 05:27:00 PM »
Have tested with raw_rec.mo on the magiclantern-v2.3.NEXT.2014Feb16.5D2212 or just mlv_rec ?

Yes, tested both, same results.

did you try the latest nightly build , I think it's Feb/2018 ?

Yes, tested that too. same issue.

If you feel like living on the bleeding edge , maybe try this on the Highly Experimental  raw_video_10bit_12bit_LVState-wip ? see Reply #681
caveat : only works in pure ISO's (100,200,400,800,1600,3200) All digital ISO (160,300,320,500, etc. ...) cause a Lockup/cam freeze , need's a battery pull to unlock.

Will check it out.

If truly the frames are out of order at 1 fps then a1ex or g3gg0 are the ones that need to look at this , it's way above my pay grade  ;)

Any idea how to get a1ex or g3gg0 informed about this fps override and mlv_rec/mlv_lite issue?

There a few different development ml builds I made for research  in my bitbucket downloads you could try magiclantern-10bit_12bit_raw_twk_crop_rec.2016Dec01.5D2212 ,
magiclantern-Nightly.Compressed.Raw.Bit.Reduction.2017.May11.5D2212 or magiclantern-adtg_gui.2017Apr04.5D2212
there all work but have special tools to help in reverse engineering .

Will definitely check that one out.

Edit: A light bulb just came on , does still happen if you don't ramp ISO or change it ? while filming -- I seem to remember something about back in 2013 on the old 5d2 thread.

The issue with fps override and frame duplication/jumbled happens with just raw recording, without any shutter speed/aperture/ISO change while recording.

Edit 2: RAW+FPS override=error every second frame reported in September 21, 2013

Looks like this issue is known long ago, either that it is not fixable or just not yet being looked into.

@reddeercity Can you test the 1fps override on your 5D2 just to confirm that it is indeed a problem with mlv_rec/mlv_lite and not my settings. Thanks!

1. Find somewhere with constant traffic flow, expose so that it is good enough to see the headlight trails
2. fps override = 1fps (mode : exact, lowlight doesn't really matter)
3. make sure LV is at 1x crop mode.
4. enable mlv_rec.mo and record for 30 seconds (you should get 30 unique frames)
5. check the recorded MLV, step through each frame, you'll see that only odd frames are recorded, even frames are the duplicate of the odd frames.
6. repeat the test with mlv_lite.mo, you'll get jumbled and repeated frames all over the sequence.

Looking forward to your results.



7
Camera-specific discussion / Re: Canon 5D Mark II / 5D2
« on: April 26, 2018, 11:54:51 PM »
I've tried rolling back to the previous nightly and it seems that this has been broken all the way back to Nightly.2015Mar29.5D2212

When recording to MP4 with the same fps override, all frames were written correctly, no duplicates, jumbled or backward frames.

I can be pretty sure that the fault is in mlv_rec and mlv_lite, and not the fps override.

Can anyone test this to confirm? Please refer to these posts for details :

https://www.magiclantern.fm/forum/index.php?topic=11205.msg200609#msg200609
https://www.magiclantern.fm/forum/index.php?topic=11205.msg200425#msg200425
https://www.magiclantern.fm/forum/index.php?topic=11205.msg200371#msg200371

Hope a1ex or g3gg0 can take a look at this issue.

Thanks!

Update : I've also tested the older build magiclantern-v2.3.NEXT.2014Feb16.5D2212, it is also exhibiting the same issues with 1fps frame override in 1x crop mode.

8
General Development Discussion / Re: mlv_dump on steroids
« on: April 26, 2018, 11:01:23 PM »
Is there any way I could save only odd or even frames out from an input MLV file and output that into a new MLV file?

I need to do this to save some space of redundant duplicated frames of some MLV written by mlv_rec.mo that wrote duplicated frames in 1fps frame override mode in 1x crop on 5D2.

I tried -f switch but that only allows input of frame or frame range, not comma delimited frame numbers, -f 0,2,4,6,8 for example.

Any ideas would be appreciated. Thanks!

9
Is there any way I could save only odd or even frames out from an input MLV file and output that into a new MLV file?

I need to do this to save some space of redundant duplicated frames of some MLV written by mlv_rec.mo that wrote duplicated frames in 1fps frame override mode in 1x crop on 5D2.

I tried -f switch but that only allows input of frame or frame range, not comma delimited frame numbers, -f 0,2,4,6,8 for example.

Any ideas would be appreciated. Thanks!

10
Camera-specific discussion / Re: Canon 5D Mark II / 5D2
« on: April 26, 2018, 07:43:26 PM »
Question , why are you using  "FastTV mode" ? you get better results with "exact" frame rate .

I need the shutter speed to be faster than the overridden fps, for bright scenes without ND filters, and to reduce motion blur for specific purposes.


One last thing , is your cam set to "PAL" or "NTSC" ? I never tested if this issue is related to that -- I'm in NTSC land .

Mine is set to NTSC, does that affect MLV frame timing or just capping the max at 25fps in PAL mode?


If you are recording1856x1044 @15fps why do you need to use mlv_lite ? There no advantage to use mlv_lite unless you are recording @ 23.976P for extended record time
(1856x928 23.976p is continuous) and if the reason is to have overlays/GD in full mlv (mlv_rec.mo) all you need to do is enable "Allow Global Draw" when recording mlv .

mlv_lite allows aperture/shutterspeed changes during recording, useful for pseudo timelapse of sunrise/sunset where you need to manually ramp the aperture and shutter speed to compensate with the extreme dynamic range. I do exposure changes in tethered Canon EOS utility while recording without touching the camera.

mlv_full ignores aperture/shutterspeed changes while recording.

11
Camera-specific discussion / Re: Canon 5D Mark II / 5D2
« on: April 26, 2018, 06:47:34 PM »
@reddeercity, my camera is set to NTSC.

Does the Canon menu 'Movie rec. size' 24p or 30p setting makes any difference to MLV_full or MLV_lite? I've tried both, they seems to exhibit the same back-frames/skipped-frames/dupe-frames issues in either mode.

Upon further investigation on fps override in 1x crop mode, I've found that if you set the fps override to 1fps (exact or lowlight doesn't matter), with :
MLV_Full(mlv_rec) : only odd frames are recorded, even frames are the duplicate of the odd frames. Liveview shows every frame correctly while recording.
Check this MLV_Full(mlv_rec) 1x crop 1fps (exact) sample : https://www.dropbox.com/s/kpqaflhi0ra464x/M26-2351_mlvfull_exactfps.zip?dl=0

MLV_Lite(mlv_lite) : recorded frames is a mess, besides skipping even frames, there is also intermittent duplicated previous frames in the sequence.
Check this MLV_Lite(mlv_lite) 1x crop 1fps (exact) sample : https://www.dropbox.com/s/yh8hyj38u8wml0w/M27-0006_mlvlite_exactfps.zip?dl=0

- the end of the headlight trails should be the start of the trail in the subsequent frame, but you can clearly see that the frame sequencing is a total mess, try following a trail, you can't.

- you can quickly scrub through the sample MLV frame by frame in MLVProducer https://sourceforge.net/projects/mlvproducer/ without dumping it to dng

- I suspect this doesn't only apply to 1fps override, any other low fps override would also exhibit this issue in 1x crop mode. I'll do more tests and report back here when time permits.

Magic Lantern version : Nightly.2017Sep15.5D2212
FPS override 1fps (Exact mode)
1x crop mode @ 1856x1044
shutter speed : 1s
bit depth : 14bit Raw


In 3x crop mode though, both MLV_Full and MLV_Lite seems to be recording correctly with frame override set to 1fps, or any other fps in any fps mode (exact, lowlight, fasttv, lowjello).

@reddeercity, would you be able to test this 1x crop 1fps override issue in both MLV_full and MLV_lite, to confirm my findings. Thanks!


12
Camera-specific discussion / Re: Canon 5D Mark II / 5D2
« on: April 23, 2018, 02:45:32 PM »
@reddeercity, I don't have HDMI connected, just standalone 5D2.

Your frame tearing and corruption issues looks more severe, what I got from MLV_lite was duplicated backwards frames in the sequence.
The frame sequence it will go like this 0,1,2,3,2,5,6,7,8,7,10,11,12, instead of writing frame 4, it is writing frame 3 at frame 4 location omitting frame 4 completely.

I had to fix a few shots with these backward and missing frames with Twixtor pro, luckily there were only subtle movements in the shot which could be saved with generated motion vector interpolates.

Here is the new link to the source MLV in Dropbox this time : https://www.dropbox.com/s/nokr8gttksfgfne/M18-1427_mlv-lite_1x_15fps_bkf.zip?dl=0

Strange that you couldn't access the previous link https://goo.gl/txLJoN, it was a directly link to my webhost.

There is no mlv_lite.mo in the old core right (Magic Lantern v2.3.NEXT.2014Feb15.5D2212 (54a967d0c228 (unified) tip))?

14
Camera-specific discussion / Re: Canon 5D Mark II / 5D2
« on: April 22, 2018, 12:15:23 AM »
I've noticed that when using mlv_lite.mo (Raw video v1.1 (MLV Lite)) with FPS override FastTV mode, when recording RAW in 1x crop mode on 5D mark II, it will contain intermittent backward frames.

Watch this https://youtu.be/m1_FBnhzXCs
There are 2 backward frames in this sample sequence, they are marked and should be easy to notice.

Here is the source MLV : https://goo.gl/txLJoN

Magic Lantern version : Nightly.2017Sep15.5D2212
mlv_lite.mo (Raw video v1.1 (MLV Lite))
FPS override 15fps (FastTV mode)
1x crop mode @ 1856x1044
ISO100
aperture : f/8
shutter speed : 1/60s (16ms)
bit depth : 14bit Raw

The sequence will contain more backward frames with slower shutter speed, for example FPS override of 15fps and shutter speed of 1/17s will produce about 20+ backward frames scattered randomly in a 2000 frames sequence.

However, the same settings works correctly with mlv_rec.mo (Raw video v2.0(MLV)) Nightly.2017Sep15.5D2212

This issue doesn't occur in 3x crop mode with the same fps override setting.

Hopefully it could be fixed. Thanks!

15
I've noticed that when using mlv_lite.mo (Raw video v1.1 (MLV Lite)) with FPS override FastTV mode, when recording RAW in 1x crop mode on 5D mark II, it will contain intermittent backward frames.

Watch this https://youtu.be/m1_FBnhzXCs
There are 2 backward frames in this sample sequence, they are marked and should be easy to notice.

Here is the source MLV : https://goo.gl/txLJoN

The sequence will contain more backward frames with slower shutter speed, for example FPS override of 15fps and shutter speed of 1/17s will produce about 20+ backward frames scattered randomly in a 2000 frames sequence.

However, the same settings works correctly with mlv_rec.mo (Raw video v2.0(MLV))

Hopefully this could be fixed. Thanks!

16
@mothaibaphoto - Use Davinci Resolve 12 beta, set it to use YRGB color managed (setting panel). Set input colorspace to linear, set workspace to ACES and output colorspace to linear (also in the main setting panel) then export half float .exr. This is a common professional compositing practice. If you want to work in another colorspace just change the workspace colorspace to something else i.e. sRGB/Rec709. The .exr file will retain the DR.


Tried your suggested settings, the resulting .exr doesn't retain the DR, input is a .CR2 file. Are you referring to Project Settings > Master Project Settings > Color science > Davinci YRGB Color Managed? Then in Color Management > Input Color Space > Linear , Color Management > Output Color Space > Linear?

DR is clipped in the output .exr.

17
I did the test again on more lenses, here are my findings :

Lenses that work :
Canon 24-105mm f/4 L IS USM mark I
Canon 16-35mm f/2.8 L USM mark II
Canon 50mm f/1.4 USM
Sigma 8mm f/3.5 EX DG Circular Fisheye

Lenses that do not work :
Canon 100mm f/2.8 L macro USM Mark I
Canon 70-200mm f/2.8 L IS USM Mark II

This sort of concludes that the newer USM lens could be using STM which doesn't work with Expo Override.

You can try FRSP in video mode. as far as I remember, it works, just not possible to set exposures longer than framerate.

FRSP isn't allowed in video mode on 5D mark II, or is there a workaround to that? Only SSP (simple silent pic) works in video mode.

3K/UHD 5D2 Raw development and Other Digic IV Cams  
Contributions are Welcome

Interesting thread, will look into it.

18
Hi a1ex, thanks for your reply.

STM has issue is one thing, but why are my 5D2 + USM combination also having the same issue?

When you have time, can you try this out :
0. put the camera into M mode, set Expo Override to ON
1. Set AV to f/22, TV at 1/30 s, ISO at 100
2. Start LV, set LV mode to photo ExpSim, leave the LV mode menu open, so you could later flip between photo and movie with the thumb wheel
3. Look at the aperture opening from the front of lens
4. Switch between photo ExpSim and movie mode with the thumb wheel while observing the aperture opening.

Did you see any changes to the size of the aperture opening while flipping between the 2 modes? If no change in aperture size, what are the lenses that works?

Finally, is there a possibility of a crop_rec_4k build for 5D2? If not possible is it due to 5D2 hardware and the lack of pixel binning in movie mode?


19
After some searching, found this post, 5D3 + EF 24mm f/2.8 IS USM, aperture in Expo Override does not work.

https://www.magiclantern.fm/forum/index.php?topic=12523.msg148354#msg148354

Any chance to have this looked into?
Sorry to ask if this is already a known unfixable problem/limitation.

20
General Help Q&A / Re: Silent Picture & Aperture
« on: October 08, 2017, 05:30:12 PM »
I can confirm that this also affects USM L lenses, not just STM lenses.

http://www.magiclantern.fm/forum/index.php?topic=20645.0

Is there a crop_rec_4k build for 5D2?

21
This is known issue for STM lenses.
Canon 16-35mm f/2.8 L II works pretty well for me with FRSP.

Which camera are you using it on?

Can you confirm if Expo Override did set the aperture correctly while in LV Photo ExpSim mode?

Try this :
0. put camera into M mode, set Expo Override to ON
1. Set your 16-35mm AV to f/22, TV at 1/30 s, ISO at 100
2. Start LV, set LV mode to photo ExpSim, leave the LV mode menu open, so you could later flip between photo and movie with the thumb wheel
3. Look at the aperture opening from the front of lens
4. Switch between photo ExpSim and movie mode with the thumb wheel while observing the aperture opening.

Did you see any changes to the size of the aperture opening while flipping between the 2 modes?

Thanks in advance!

22
Since it is documented here https://wiki.magiclantern.fm/userguide#expo_override which enables "Full-time DOF preview in photo mode, without blocking certain keys."

I'm just curious if there are any undocumented exceptions to watch out for, like certain combination of camera and lens, like for example in my case a 5D2 + EF USM L lens?

Hope someone can shed some light on this, thanks!

Looks like this issue has been brought up in this post https://www.magiclantern.fm/forum/index.php?topic=12523.msg145567#msg145567

23
Anyone with 5D mark 3 or other model able to get Expo Override to set aperture correctly while in liveview Photo ExpSim mode? Just curious.

Can anyone please try this : While in liveview Photo ExpSim mode, set Expo Override On, turn the AV dial while looking at the lens aperture from the front of lens, see if there are any changes to the aperture opening?

Thanks!

24
On 5D mark II and USM lens, in Liveview Photo ExpSim with Expo Override set to On, the aperture does not get set correctly. For example a f/32 would only drive the aperture to f/5.6.

Tested on ML nightly 5D2 212 2017-10-03 all the way back to 2016 builds, all showing the same results.

Lens tested :
Canon 70-200mm f2.8 L IS II
Canon 24-105mm f4 L IS
Canon 16-35mm f/2.8 L II
Canon 100mm macro f/2.8 L

Is this a known issue?

I'm trying to get this working for FRSP macro focus stacking, can't untwist the lens because need ML to drive focus.

25
Scripting Corner / Re: Lua Scripting (lua.mo)
« on: September 10, 2017, 05:10:13 PM »
Would it be possible with the current ML lua API to get the current running intervalometer countdown time until the next shot is fired? I know we can get/set interval.time but how to know the time remaining until the next shot is fired.

What I'm trying to accomplish is to resume live view a few user defined seconds before the next interval.time is reached, to allow some time for auto ETTR to do its work. This only applies to shooting simple silent pic with LV power saving turn on. Currently when LV resumes for the next silent pic, there is not enough time for ETTR to work before the silent pic is taken.

Or there is a better way of doing this? Thanks.

Pages: [1] 2