Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Messages - Shield

Pages: [1] 2 3 ... 9
1
USA only all, thanks...

2
General Chat / Selling a bunch of CF cards that will shoot raw on the 5d3
« on: November 01, 2014, 09:25:23 PM »
3 x 64 GB card (1 Lexar and 2 Komputerbay)  + 1 32GB Lexar 1000x.

Not sure if this is allowed on this forum or not; just wanted a fellow ML fan to pick these up.  I bought a Sony a7s and no longer shoot ML raw on my 5d3, but all of these cards worked just fine.

If any of the developers could use these for development, please let me know.

Thanks, Shawn

3
Just ordered two of these; says a 2 week back order.  Will report back in.

4
Oh yes, I'm not sure how to handle that.

You could try one of the processors from this section.

I tried concatenating the files and no go.

Here's what I found to fix this:

Use the EXFAT option, then on the CF you get "moviename.mlv" and on the SD card "moviename.m00".


5
Dump all of the files together on a HDD.  Use "mlv_dump --dng".

I have a 900 meg file on the SD card and a 4 GB one on the CF with the exact same filename though.

6
Can anyone help?  Been shooting raw for about a year; happily with various builds.  My 64 1000x computerbay card is not quite writing as fast as it used too, despite low level formats and trying all sorts of things.

So I pulled down the May 24 build for the 113 5d3 and decided to enable spanning.

On my CF card, I have:
M26-1853.MLV
M26-1853.M00
through
M26-1853.M08

all 4GB files except for the last, where I ran out of space.

On my SD card I have:
M26-1853.M00 (almost 1 gb)
M26-1853.M01
trhough
M26-1853.M08 (all 1k in file size)

Normally in the past I used mlvbrowsesharp.exe and just right clicked - extract with dng + wav.

Now what do I need to do to put this all back together again, and especially the M26-1853.M01-.M08 (1k size) files on my SD card?

I've tried searching and will continue to do so.

Thanks,
Shawn

7
Camera-specific discussion / Re: Magic Lantern for 5D Mark III 1.2.3
« on: April 17, 2014, 10:06:44 PM »
Regarding the 04/16 build 1.2.3:

As soon as I hit record all the overlays disappear except for the recording time.  No focus peaking, audio meters, shutter/ISO information etc.  Any ideas?

8
Camera-specific discussion / Re: Magic Lantern for 5D Mark III 1.2.3
« on: March 17, 2014, 11:04:56 PM »


Uninstallation:
1) Run Firmware Update from your ML card.
2) Follow the instructions.

What's hot:
- bootflag issue solved! (p.s. some bloggers got it wrong, you still enable it in the camera, but you can disable it by uninstalling)


Silly question (maybe?) - I run 1.1.3 and toggle between 1.2.3 prior to this release - no problems.  If I wanted to completely remove the bootflag from my camera can I just install and then uninstall this version?  Then go back to Canon's OEM firmware and there's absolutely no remnants of ML anywhere?  (This is in case I need to send the camera in for repair or decide to sell it).

Thanks!
Shawn

9
on my tests using 7D and 5DmkII using various resolutions the results are always as follows.

when recording MLV+SND, the wav file would always be
LONGER by 7-10 frames.
It would be ahead by 1-2 frames from the video so it needs to be nudged back to sync.

Knowing this and you won't have problems syncing in post. H264 was also off by 1-2 frames so this is not an ML issue.

However, if your recording stops ABRUPTLY, due to card full for instance, the VIDEO would be LONGER and the WAV file much shorter.

The 5d3 is different; never once had the audio (at least lately) not sync up perfectly with the video.  This wasn't an issue of running out of card space, lockup, heat, anything else.  Let's say in the span of 15 minutes I recorded 4 two-three minute clips all without shutting off the camera.  Clips 1,2,4 were fine.  Clip 3 the audio shut off about 10 seconds early.  No idea why.

10
Out today shooting some 2-4 min clips.  One clip was 3:16 and the associated .wav file was 3:07.  It just didn't record the last 10 seconds for some reason.  I was able to sync it up with my external source so I was able to determine that was the problem.  Clips just before and after this were fine, and there was no lockup or any other problems.
Would anyone like me to upload the mlv file somewhere?

11
Started a new thread on this, but perhaps it just belongs here.

Recording typical 1920x1080 video tonight; nothing too crazy.  For some reason ML locked up, which is no big deal, but after the restart the Canon menu's audio became disabled so I lost some good audio tonight.

I normally notice the audio meters but tonight I didn't see them.

Here's my question - back in the day in order to use the 3x mode one had to set "FPS override" (in my case I set it to 23.976).  However if you do this now, one cannot see the audio meters at the top.  I have the "Raw Histobar" at the top.  Once I disable the FPS override the audio meters come back.

So, do I still need to do the FPS override trick?  All I care about shooting is 1920x1080 @ 24FPS in normal mode as well as 3x crop/zoom mode.  In the past it was recommended to set the Canon menu for 30 FPS then dial down the FPS override to 23.976.

Also, if it's still required, is there any way to get the audio meters back with it on?  When shooting handheld stuff I just set the Canon audio menu to "auto"..

Thanks guys.

12
Raw Video / Re: Question about manually setting ISO or "exposure lock"
« on: January 12, 2014, 08:34:37 PM »
When shooting raw, ISO can be changed in full stops only.

If you want a fine transition, you can fake it by changing the white level in the DNG files.

Gotcha - I can work around it in post; I'm going to see if hitting the * exposure lock does what I need it to do.

13
Raw Video / Question about manually setting ISO or "exposure lock"
« on: January 12, 2014, 08:18:32 PM »
My favorite way to shoot non-raw video is manual shutter and F/stop, and let the camera pick the ISO.

With raw video, I find the ISO changes too abrupt.  Does everyone just shoot video with their ISO set manually?  Would it be possible to toggle the exposure lock * and get the same effect?

I've briefly fooled around with one of the ISO modules probably like last June - is this any better now?

Thanks, and sorry if this has been answered already.

14
Raw Video / Re: Real world use of RAW video on DSLRs?
« on: January 09, 2014, 04:44:48 PM »
Agreed, raw will NOT work for weddings, but would be nice for stock footage shoots.

When the 5d3 came out I considered it but lack of flip-out screen was a no-go for me.

Get a small HDMI monitor and mount it on the hotshoe, or build a small rig.  Can still be done handheld.

15
Raw Video / Re: Real world use of RAW video on DSLRs?
« on: January 09, 2014, 04:43:22 PM »
yeah I figured the ability to make more corrections, but still, with most cameras capable of only a second or two of RAW video that really seems to limit the possibilities eh?

hopefully future bodies will have much faster card slots and allow much longer takes. if either of my cameras were even capable of 5 seconds of 1080p RAW video I would put it to work immediately on stock footage shoots.

Second or two?  I get 12+ minutes straight with a 64GB card + 5d3.

16
Share Your Videos / Re: 5dmkIII raw - slow motion at Santa Monica Pier
« on: January 09, 2014, 04:41:09 PM »
Absolutely wonderful video and equally bad audio.  :)

17
I think you can download the regular nightly build for your camera here http://builds.magiclantern.fm/#/
Then you just add the mlv_rec.mo and mlv_snd.mo from g3gg0 build from the first page in this thread. Conflict occurs if you load both raw and mlv recording in camera. At least this is what I have done lately.
Alternative is to download and install g3gg0 build removing the other nighly build.

Correct me if I,m wrong here
//D

That's pretty much what I did too.  Seemed to work out fine for me.

18
On 6D/7D it works fine with canon audio off as long as the IC is powered (wav mode), tap on the mic and if the meters move you're good

Maybe related to the dma flags. Which resolutions did it?

Oh something stupid like 2.5k - I was just bored and curious to see how long I could get it to go.  I'll be sure to keep my eye on the meters.
The problem is the Magic Lantern software is too smart - it remembered that in 3x mode I was higher than 1920x1080.  I'm used to software being much more stupid.  I also periodically get a "Error -1" at the top, then I realized it was set to write to the SD card (Card 2).  You guys have thought of just about everything; well done!

19
Just a heads up from my experience - I have been testing and diddling with this all day.  I'm the geek type that will change just one setting and exhaustively see what difference it makes - anyway, I was fooling around with the resolution settings for the 3x crop mode, and forgot that I set it above 1920x1080 - shooting normally it was fine, but when I went above that it would lock the camera up.
Not a big deal - pull the battery and start over.

But...inexplicably this lockup disabled audio recording in the Canon menu.  If you go off the wrong path as I did please be sure to verify the audio is still enabled.  Got some fantastic footage of the kids tonight, and the audio file (while there) was dead silent.  Went through all the menu settings and sure enough, the Canon menu had it disabled instead of the usual "auto".

Just wanted to share my experience.  I would like to thank all the developers and testers; the MLV format is amazing and the ability to have accurate, synch able reference audio is a huge benefit.  Thanks again guys - think how far you've come since last May.

Another side note - I let it record until the CF card filled up - it shut off "automagically" and everything was recoverable in post too.

20
try mlv_dump -v file.mlv > file.txt

That works, but far too verbose.  Just looking for exposure, lens, camera info.  Don't need hundreds of lines that have this stuff:
Block: RTCI
  Offset: 0x000002a4
    Size: 44
    Time: 41.330000 ms
     Date:        07.01.2014
     Time:        11:21:22 (GMT+0)
     Zone:        ''
     Day of week: 2
     Day of year: 6
     Daylight s.: 0

Here's what I get by right clicking on my .dng file with my exiftool registry hack:

File Name                       : M07-1017.MLV.frame_000000.dng
Camera Model Name               : Canon EOS 5D Mark III
Lens Model                      : EF24-70mm f/2.8L II USM
F Number                        : 2.8
Shutter Speed                   : 1/40
ISO                             : 2000
Focal Length                    : 50.0 mm
Light Value                     : 4.0
Exposure Compensation           : 0
Frame Rate                      : 23.976
Date/Time Original              : 2014:01:07 10:17:38
Orientation                     : Horizontal (normal)
Image Size                      : 1920x1080

21
uhm the output of mlv_dump is readable, right? ;)

It's mostly gibberish with a few words that are relevant, and not formatted in any easy to use way. 

22
mlv_dump -v

Still not getting a file that is readable in notepad.  I'm going to setup a batch for exiftool to just grab the info from the dng's extracted from the MLV browser.  What would really be slick is an option in MLV browser to "Export selected files as .dng +.wav +.txt"...I realize you're busy, but wow, things are really close.  The audio sync is perfect now.

23
Quick question for the meta-data - I ran mlv-dump (-m -o) and successfully exported it to another MLV file that is meta-data only (no video) and I was able to read the information in MLV Browser.  However, if I try to read that metadata in notepad it's garbled.

How can I dump the following information into a text file?  Would be very handy for quick reference.


24
Looks good - took an empty card and let it run until the end.  No problems and the audio synched up perfectly.  Now to just fine tune my settings.

Thanks guys for the wonderful update!  Shawn

25
if I would dare guess that the mkIII is the same in MLV menu as the mkII then you go to MLV menu  and turn DISABLE G.DRAW to ON.

I know, its mislabeled and I was wracking my brains as I thought turning it on would do as it say, but it actually does the opposite and DOES NOT turn Gdraw off when it is ON.

Hope a developer can change this.  :) I already reported this in an earlier post #1093.

Thanks Ted - I'm sure that will be it.


On another note, I'm going to do some long recordings today with audio as well as have my Zoom H1n recording simultaneously mounted on the shoe.  Then I'm going to pull it into Vegas and run Pluraleyes - if I get a sync I'll be super happy - that's all I've wanted was a reference audio with my raw....

Will report back in.
Shawn

Pages: [1] 2 3 ... 9