Magic Lantern Forum

Using Magic Lantern => General Help Q&A => Camera Emergency Department => Topic started by: KristoffMiro on December 10, 2021, 02:30:27 AM

Title: [Solved] Eos 550D doesn't work with SD card insert
Post by: KristoffMiro on December 10, 2021, 02:30:27 AM
Hi there.

Context: Today I am having a problem with my 550D/T2i. When I tried to turn it on the screen was compleatly black but I realized that if I press the shutter button the autofocus started moving. After that I tried many things that I found on internet like resetting the camera or formating the SD card with no luck.

But, when I took out the Sd card, took out the battery, inserted the battery again and turning on the camera without the SD card in it, boom it turned on. It is when I try to turn on the camera with the SD card in it that something happends that the screen turns compleatly black.

More context: I had this problem when I tried to connect my camera with my Pc with an HDMI cable that this happened. Before this everything was working perfectly.
Title: Re: Eos 550D doesn't work with SD card insert
Post by: Walter Schulz on December 10, 2021, 02:43:48 AM
Remove card, remove battery.
Copy extracted nightly build contents to card.
Insert card.
Insert battery.
Close compartment doors.
Try to startup cam.

Report back.

BTW: Which OS on your PC?
Title: Re: Eos 550D doesn't work with SD card insert
Post by: KristoffMiro on December 10, 2021, 02:59:38 AM
Hi thanks for the reply. I have tried it in the same order and still same, screen black but with autofocus working.

I have Windows on my Pc.
Title: Re: Eos 550D doesn't work with SD card insert
Post by: Walter Schulz on December 10, 2021, 03:04:52 AM
Locate ML\Logs directory on card. Are there ROM0.BIN and ROM1.BIN?
Title: Re: Eos 550D doesn't work with SD card insert
Post by: KristoffMiro on December 10, 2021, 03:21:38 AM
No, there isn't a folder called log and any of the files that you mentioned eather.

As I mentioned, one of the posible solutions that I found around forums is formating the SD card, so now I have my SD card clean of any of the folders and files that the camera creates like DCIM or MISC. It only have the uncompressed nightly build files.
Title: Re: Eos 550D doesn't work with SD card insert
Post by: Walter Schulz on December 10, 2021, 08:13:53 AM
Remove card and battery.
Download EOScard from https://pel.hu/eoscard.
Insert card into cardreader and run EOScard.
Make sure your card is selected.
Set checkmarks for "EOS_DEVELOP" and "BOOTDISK".
Press "Save" button.
Eject card.
Insert card and battery.
Close compartment doors.
Try to startup camera.
Check ML\LOGS again.

Report back, please.
Title: Re: Eos 550D doesn't work with SD card insert
Post by: kitor on December 10, 2021, 10:52:59 AM
Quote
As I mentioned, one of the posible solutions that I found around forums is formating the SD card, so now I have my SD card clean of any of the folders and files that the camera creates like DCIM or MISC.
If you really formatted your card (right click -> format on explorer) and not just deleted folders from it, try pressing "DISP" first?
If display is still black and AF works, see if you have anything visible in viewfinder?

Quote
More context: I had this problem when I tried to connect my camera with my Pc with an HDMI cable that this happened. Before this everything was working perfectly.
Examine HDMI connector closely. Maybe it got broken and camera thinks cable is connected. Symptoms would be the same. And per description this is more likely over a software issue.

Try plugging in/out cable on camera "turned on" in that bad state - but after you check connector for physical damage.
Title: Re: Eos 550D doesn't work with SD card insert
Post by: Walter Schulz on December 10, 2021, 10:55:28 AM
Kitor, cam works without card ...
Title: Re: Eos 550D doesn't work with SD card insert
Post by: KristoffMiro on December 10, 2021, 02:03:41 PM
Remove card and battery.
Download EOScard from https://pel.hu/eoscard.
Insert card into cardreader and run EOScard.
Make sure your card is selected.
Set checkmarks for "EOS_DEVELOP" and "BOOTDISK".
Press "Save" button.
Eject card.
Insert card and battery.
Close compartment doors.
Try to startup camera.
Check ML\LOGS again.

Report back, please.

Hi, I have already done that and nothing has changed, it still frozen on black screen when I insert the SD card.
Title: Re: Eos 550D doesn't work with SD card insert
Post by: theBilalFakhouri on December 10, 2021, 02:22:30 PM
Maybe try another SD card without ML, does it work?
Title: Re: Eos 550D doesn't work with SD card insert
Post by: KristoffMiro on December 10, 2021, 02:32:38 PM
If you really formatted your card (right click -> format on explorer) and not just deleted folders from it, try pressing "DISP" first?
If display is still black and AF works, see if you have anything visible in viewfinder?
Examine HDMI connector closely. Maybe it got broken and camera thinks cable is connected. Symptoms would be the same. And per description this is more likely over a software issue.

Try plugging in/out cable on camera "turned on" in that bad state - but after you check connector for physical damage.

Tried to do that but still nothing, SD card is inserted and no signal on both screens. I should say that if I switch on the camera without the SD card in it and connected to my pc by HDMI, it works perfectly, the monitor shows everything what would it be on the LCD screen as it should.
Title: Re: Eos 550D doesn't work with SD card insert
Post by: KristoffMiro on December 10, 2021, 02:38:17 PM
Maybe try another SD card without ML, does it work?

Yeah, I'll try to get another SD card along this afternoon or tomorrow, so I'll keep you up with this.
Title: Re: Eos 550D doesn't work with SD card insert
Post by: KristoffMiro on December 10, 2021, 02:44:28 PM
BTW a newbie question, how can I post pictures in here? I think I could illustrate better the problem showing it to you.
Title: Re: Eos 550D doesn't work with SD card insert
Post by: names_are_hard on December 10, 2021, 03:54:21 PM
You can use imgur.  Upload there, get the raw url for the image, use that inside img tags (remove \, can't get it to display nicely): \[img\]http://[/img]
Title: Re: Eos 550D doesn't work with SD card insert
Post by: KristoffMiro on December 10, 2021, 04:44:21 PM
Hi, I just uploaded a video trying to explain the situation showing you the camera and how it works fine without the SD card and also working connected with my PC. Excuse my english haha.

Title: Re: Eos 550D doesn't work with SD card insert
Post by: Walter Schulz on December 10, 2021, 05:40:18 PM
Possible cause: Something about adapter. Cams with microSD adapter behave just this way if you insert adapter without microSD inserted.
Can you retest with a "full-size" card? Doesn't have to be a fast card and size doesn't really matter. Anything > 32 MByte will do.
Title: Re: Eos 550D doesn't work with SD card insert
Post by: KristoffMiro on December 10, 2021, 07:52:23 PM
I'll try to get one of those, thanks!
Title: Re: Eos 550D doesn't work with SD card insert
Post by: KristoffMiro on December 10, 2021, 09:52:36 PM
Hi, quick update about this. I could tried to turn on the camera with a different SD card and it works almost perfect. The weird thing is that my own SD card inserted on a different camera works too, so I think something is going wrong between my camera and my SD card. Separately both works fine.
Title: Re: Eos 550D doesn't work with SD card insert
Post by: Walter Schulz on December 10, 2021, 10:02:18 PM
As expected! Thanks for update.
Get yourself some adapters. Clean microSD's contact plate. Microfibre and some isopropanol will do fine.
I have some adapters not working well for whatever reason.
Title: Re: Eos 550D doesn't work with SD card insert
Post by: KristoffMiro on December 10, 2021, 10:08:54 PM
Yes, it is so strange. Thanks for everything! Any suggestions next time I try to connect my camera to my Pc using ML for a clean video output and not messing another SD card in the process? hahaha
Title: Re: Eos 550D doesn't work with SD card insert
Post by: Walter Schulz on December 10, 2021, 10:16:14 PM
Try crossing your fingers! ;-)