Magic Lantern Forum

General Discussion => General Chat => Topic started by: Sylvio on December 06, 2021, 07:14:21 PM

Title: Canon 7D firmware version 2.06 will work on Magic Lantern?
Post by: Sylvio on December 06, 2021, 07:14:21 PM
Hi there, hope everything is Ok
I want to install Magic Lantern on my Canon 7D, I have the latest firmware version from my camera model, that is the 2.06, but I see that Magic Lantern website specifies that it only will work on 2.03 firmware version, that would be an earlier firmware version from I have.
The question is if Magic Lantern only works in the 2.03 firmware version and nothing else.
Thanks in advance
Title: Re: Canon 7D firmware version 2.06 will work on Magic Lantern?
Post by: Walter Schulz on December 06, 2021, 08:36:46 PM
https://wiki.magiclantern.fm/glossary#firmware_update_upgrade_downgrade
Title: Re: Canon 7D firmware version 2.06 will work on Magic Lantern?
Post by: Sylvio on December 06, 2021, 10:05:38 PM
Hi, thanks for your answer, yes, I had already tried several times to download the firmware with the Magic Lantern link, unfortunately doesn't work. It seems that the file no longer exists, I will look for it elsewhere. About the info on downgrading the firmware version to install Magic Lantern it helped me a lot, thanks!
All this leads me to a new question; after installing Magic Lantern, can the firmware be updated again?
thanks in advance
Title: Re: Canon 7D firmware version 2.06 will work on Magic Lantern?
Post by: Walter Schulz on December 06, 2021, 10:16:11 PM
Sorry for that! https://web.archive.org/web/20160305194849/http://pel.hu/down/eos7d-v203-win.zip

https://wiki.magiclantern.fm/faq
Title: Re: Canon 7D firmware version 2.06 will work on Magic Lantern?
Post by: Sylvio on December 07, 2021, 12:42:44 AM
Hi! cool, thanks!