Magic Lantern Forum

Using Magic Lantern => Raw Video => Topic started by: LICK_THE_BUTTER on May 09, 2018, 01:22:11 AM

Title: Weird orange and blue stripes issue I'm having with a wheel
Post by: LICK_THE_BUTTER on May 09, 2018, 01:22:11 AM
Here is a cropped screenshot from when i was viewing it in MLVApp (unedited)


(https://www.magiclantern.fm/forum/proxy.php?request=https%3A%2F%2Fthumb.ibb.co%2Fb03dTn%2Fwheel.jpg&hash=6b4c2ddd420d92efde7d59011084535b) (https://ibb.co/b03dTn)


The spokes more so on the right seem to have orange and blue stripes. Not sure if it's an exposure issue, a bug, and if it can be corrected. I don't know what to call this problem, the zebras looked fine on the spokes and i only made an exception for the bright sky. Probably struggling with a narrow transition from highlights to darks. Any ideas?

EDIT: Duh, it's moire. Not sure if there is something to help control it in ML. If i can't find a solution then i need to get a much wider lens and shoot in 5x crop (pans would be super shaky on my 35mm x5!). Kind of an annoying workound... again suggestions are super appreciated!
Title: Re: Weird orange and blue stripes issue I'm having with a wheel
Post by: a1ex on May 09, 2018, 11:12:43 AM
This kind of moire is interesting; mind sharing a few DNG frames?

These might help:
https://www.magiclantern.fm/forum/index.php?topic=20999
https://www.magiclantern.fm/forum/index.php?topic=20995
https://www.magiclantern.fm/forum/index.php?topic=21089
Title: Re: Weird orange and blue stripes issue I'm having with a wheel
Post by: Danne on May 09, 2018, 11:35:34 AM
Yes, a few frames or a MLV would be great. Recently rewrote aliasing handling to this script meant to be used in Mlv App but there are a few quirks with command script handling in there atm.
https://bitbucket.org/Dannephoto/mlv-app-danne/downloads/tif_clean.command
Title: Re: Weird orange and blue stripes issue I'm having with a wheel
Post by: ilia3101 on May 09, 2018, 04:21:16 PM
Right click in MLV App -> Debayer for Preview -> AMaZE
Title: Re: Weird orange and blue stripes issue I'm having with a wheel
Post by: LICK_THE_BUTTER on May 09, 2018, 10:57:09 PM
This kind of moire is interesting; mind sharing a few DNG frames?

These might help:
https://www.magiclantern.fm/forum/index.php?topic=20999
https://www.magiclantern.fm/forum/index.php?topic=20995
https://www.magiclantern.fm/forum/index.php?topic=21089

Here is the MLV. Kind of embarrassed about this shot to be honest, didn't turn out the way I wanted but it's going to be re-shot anyways  :-\ ignore my stupid voice

http://www.mediafire.com/file/h8k6pb52e3t1jf1/M08-0153.MLV
Title: Re: Weird orange and blue stripes issue I'm having with a wheel
Post by: LICK_THE_BUTTER on May 09, 2018, 10:57:55 PM
Yes, a few frames or a MLV would be great. Recently rewrote aliasing handling to this script meant to be used in Mlv App but there are a few quirks with command script handling in there atm.
https://bitbucket.org/Dannephoto/mlv-app-danne/downloads/tif_clean.command

Here is the MLV

http://www.mediafire.com/file/h8k6pb52e3t1jf1/M08-0153.MLV
Title: Re: Weird orange and blue stripes issue I'm having with a wheel
Post by: LICK_THE_BUTTER on May 09, 2018, 10:59:51 PM
Right click in MLV App -> Debayer for Preview -> AMaZE

Wow that's pretty cool! Seems to have desaturated the moire but i would still like to get rid of the stripes. Thanks for the tip! Definitely less noticeable.
Title: Re: Weird orange and blue stripes issue I'm having with a wheel
Post by: Danne on May 09, 2018, 11:52:00 PM
Downloading the mlv. Rather big. I suggest you shorten it in Mlv app and upload a smaller MLV file. Think something like 50 frames will do.
Title: Re: Weird orange and blue stripes issue I'm having with a wheel
Post by: Danne on May 10, 2018, 01:01:43 AM
Still working on fixing some parts of my script but here is an example:

Original
(https://www.magiclantern.fm/forum/proxy.php?request=https%3A%2F%2Fs9.postimg.cc%2F5qg8phk1r%2FM08-0153_000020_800px.jpg&hash=16307ac134d9a934d38d9c288ddc4828)

Scripted
(https://www.magiclantern.fm/forum/proxy.php?request=https%3A%2F%2Fs9.postimg.cc%2Fh2su79l0v%2FM08-0153_000020_2_800px.jpg&hash=bba4792e212b12fd0d667aedd1724397)

Zoomed:
Original
(https://www.magiclantern.fm/forum/proxy.php?request=https%3A%2F%2Fs9.postimg.cc%2Fpmc84y8rz%2FScreen_Shot_2018-05-10_at_00.53.14.png&hash=9283051e1fe29dfd36f52ac57d049f0a)

Scripted
(https://www.magiclantern.fm/forum/proxy.php?request=https%3A%2F%2Fs9.postimg.cc%2F6h8yv6me7%2FScreen_Shot_2018-05-10_at_00.52.48.png&hash=1e8c1b187ea237dd0827cf15d97b2706)

Title: Re: Weird orange and blue stripes issue I'm having with a wheel
Post by: dfort on May 10, 2018, 01:58:54 AM
Danne does it again with his magic scripts.

Big improvement. Don't notice it until you zoomed way in. Wonder what it looks like in motion. Aliasing artifacts are uglier in video than in stills.
Title: Re: Weird orange and blue stripes issue I'm having with a wheel
Post by: Danne on May 10, 2018, 02:03:03 AM
Right now I´m trying several passes on a file. Takes a while to perform testing but I´ll upload any improvements...
Title: Re: Weird orange and blue stripes issue I'm having with a wheel
Post by: Danne on May 10, 2018, 02:17:34 AM
Here´s original vs 5 passes:

tif originals:
https://bitbucket.org/Dannephoto/magic-lantern/downloads/tifcleaning.zip

Original
(https://www.magiclantern.fm/forum/proxy.php?request=https%3A%2F%2Fs9.postimg.cc%2Fzd9jutccv%2FScreen_Shot_2018-05-10_at_02.14.45.png&hash=948ae8fcac2b3157b842d0e25b7ee2b0)

5 passes
(https://www.magiclantern.fm/forum/proxy.php?request=https%3A%2F%2Fs9.postimg.cc%2Fqi8pkafun%2FScreen_Shot_2018-05-10_at_02.14.26.png&hash=e23bb59cf610be73dbd30f8410891546)

Title: Re: Weird orange and blue stripes issue I'm having with a wheel
Post by: LICK_THE_BUTTER on May 10, 2018, 04:07:18 AM
Here´s original vs 5 passes:

tif originals:
https://bitbucket.org/Dannephoto/magic-lantern/downloads/tifcleaning.zip

Original
(https://www.magiclantern.fm/forum/proxy.php?request=https%3A%2F%2Fs9.postimg.cc%2Fzd9jutccv%2FScreen_Shot_2018-05-10_at_02.14.45.png&hash=948ae8fcac2b3157b842d0e25b7ee2b0)

5 passes
(https://www.magiclantern.fm/forum/proxy.php?request=https%3A%2F%2Fs9.postimg.cc%2Fqi8pkafun%2FScreen_Shot_2018-05-10_at_02.14.26.png&hash=e23bb59cf610be73dbd30f8410891546)

whoa thank you so much for tackling this! is this something that will eventually be part of MLV App? and sorry for the file size, I'm still new to this and wanted to leave it untouched in case I did something wrong that i'd be unaware of.
Title: Re: Weird orange and blue stripes issue I'm having with a wheel
Post by: Danne on May 10, 2018, 07:47:39 AM
Yes, as a post script solution. I will try and refine it a little further and hopefully masc fix implementation after holidays.
It's a processor heavy process but I guess it will be worth the extra time for critical recordings.
Title: Re: Weird orange and blue stripes issue I'm having with a wheel
Post by: andy kh on May 10, 2018, 08:07:28 AM
#LICK_THE_BUTTER which camera do you use
Title: Re: Weird orange and blue stripes issue I'm having with a wheel
Post by: LICK_THE_BUTTER on May 10, 2018, 10:21:24 AM
Yes, as a post script solution. I will try and refine it a little further and hopefully masc fix implementation after holidays.
It's a processor heavy process but I guess it will be worth the extra time for critical recordings.

ok cool, I really love you guys and what you're doing. wish I could give something in return.

I'm also looking at Mosaic Engineering anti-aliasing/anti-moire filters but they're out of stock.
Title: Re: Weird orange and blue stripes issue I'm having with a wheel
Post by: LICK_THE_BUTTER on May 10, 2018, 10:21:46 AM
#LICK_THE_BUTTER which camera do you use

Canon 6D
Title: Re: Weird orange and blue stripes issue I'm having with a wheel
Post by: keepersdungeon on May 10, 2018, 10:55:28 AM
Here´s original vs 5 passes:

tif originals:
https://bitbucket.org/Dannephoto/magic-lantern/downloads/tifcleaning.zip

Original
(https://www.magiclantern.fm/forum/proxy.php?request=https%3A%2F%2Fs9.postimg.cc%2Fzd9jutccv%2FScreen_Shot_2018-05-10_at_02.14.45.png&hash=948ae8fcac2b3157b842d0e25b7ee2b0)

5 passes
(https://www.magiclantern.fm/forum/proxy.php?request=https%3A%2F%2Fs9.postimg.cc%2Fqi8pkafun%2FScreen_Shot_2018-05-10_at_02.14.26.png&hash=e23bb59cf610be73dbd30f8410891546)
Damn this is incredible Danne ! Thank u! Wonder how it look in the video

Sent from my Pixel using Tapatalk

Title: Re: Weird orange and blue stripes issue I'm having with a wheel
Post by: keepersdungeon on May 10, 2018, 11:07:20 AM
Do we have to use it with MLVapp Or can we execute it by itself?

Sent from my Pixel using Tapatalk

Title: Re: Weird orange and blue stripes issue I'm having with a wheel
Post by: Danne on May 10, 2018, 08:41:56 PM
Here is a version of Mlv App with the tif_clean script included.
Just select the script from within export settings then export to any format:
(https://www.magiclantern.fm/forum/proxy.php?request=https%3A%2F%2Fs9.postimg.cc%2F92awva727%2FScreen_Shot_2018-05-10_at_20.35.43.png&hash=c5e2b0e2f8c4b83b48f39fe64986d5ea)

MLV_App_tif_clean.app
https://bitbucket.org/Dannephoto/mlv-app-danne/downloads/MLV_App_tif_clean.app.zip

If anyone tests please share results. For best results use it on footage with moderate motion but do test any footage to see if it helps...
Title: Re: Weird orange and blue stripes issue I'm having with a wheel
Post by: LICK_THE_BUTTER on May 11, 2018, 05:09:47 AM
Here is a version of Mlv App with the tif_clean script included.
Just select the script from within export settings then export to any format:
(https://www.magiclantern.fm/forum/proxy.php?request=https%3A%2F%2Fs9.postimg.cc%2F92awva727%2FScreen_Shot_2018-05-10_at_20.35.43.png&hash=c5e2b0e2f8c4b83b48f39fe64986d5ea)

MLV_App_tif_clean.app
https://bitbucket.org/Dannephoto/mlv-app-danne/downloads/MLV_App_tif_clean.app.zip

If anyone tests please share results. For best results use it on footage with moderate motion but do test any footage to see if it helps...

Is this also available for Windows?
Title: Re: Weird orange and blue stripes issue I'm having with a wheel
Post by: 50mm1200s on May 11, 2018, 07:04:58 AM
This is quite amazing Danne. What method is it using? It's like Tlsophote, where he has a edge-detection algorithm and them blurs the areas or it's something more complex like superresolution?
Title: Re: Weird orange and blue stripes issue I'm having with a wheel
Post by: Danne on May 11, 2018, 07:52:34 AM
@50mm1200s
When it works it can be really good.
It's an idea based on a1ex thread pointed at above:
https://www.magiclantern.fm/forum/index.php?topic=20999

 In my script I use programs based on this:
https://www.magiclantern.fm/forum/index.php?topic=21089.msg193622#msg193622

How does it work? Speculating enfuse average surrounding images yielding the positive side effect of reducing aliasing rather effectively.
Caveat. Motion will increase the effect while to much motion might cause side effects as bluriness. Can be reduced by weighing more pixels from enfuse base image which my latest script does atm.
Sorry, only mac for now @LICK_THE_BUTTER
Title: Re: Weird orange and blue stripes issue I'm having with a wheel
Post by: IDA_ML on May 11, 2018, 02:34:25 PM
This is really amazing, Danne!  I can't wait to test it on Win x64.  Now that the 100D works so well with the overclocked SD-card interface, I expect your script to be God sent for improving moire at higher frame rates in critical high-contrast situations.  Congratulations to another excellent result!
Title: Re: Weird orange and blue stripes issue I'm having with a wheel
Post by: Danne on May 11, 2018, 02:51:28 PM
Yes, overclocking is great.
I would recommend anyone wanting this for windows to check into powershell or cmd scripting. I could give some pointers about the general idea but don't see myself digging into windows anytime soon.
Title: Re: Weird orange and blue stripes issue I'm having with a wheel
Post by: 50mm1200s on May 11, 2018, 10:36:33 PM
We could maybe use bash and then run with the new compatibility (https://blogs.windows.com/buildingapps/2016/03/30/run-bash-on-ubuntu-on-windows/) in Windows 10. It's dirty, I know, but the same script would run on linux and windows, so maintaining the script would be easier...
I don't have much experience with bash, besides managing servers, but I perhaps could help in some way.
Title: Re: Weird orange and blue stripes issue I'm having with a wheel
Post by: Danne on May 11, 2018, 10:39:13 PM
Yes, might work but I'd say learn align_image_stack and enfuse basics through cmd or powershell and it wouldn't be too far from a basic windows workflow.
Title: Re: Weird orange and blue stripes issue I'm having with a wheel
Post by: qqqavi on May 29, 2018, 07:13:56 PM
I've just tried the MlvApp and "tiff_clean script" command activated on mac and something weird happened every time the file was created:

When I export to any Prores, the .mov is created on the hdd. Then, the script runs automatically and a .tiff sequence is created. After the process is completed, the folder automatically deletes itself. Why's that? Anyone know?


Title: Re: Weird orange and blue stripes issue I'm having with a wheel
Post by: Danne on May 29, 2018, 09:40:09 PM
Because the script is designed that way. Right now it removes the intermediate tiffs and keeps the prores created. If you want to keep the tiffs it's however easily fixed.
Open up the script inside MLV App.app here:
MLV App.app/Contents/MacOS/TIF_CLEAN.command
Open up the TIF_CLEAN.command script with your text editor and change following:
Code: [Select]
#check for matching MLV or else do not remove
check="$(cat /tmp/TIFCLEAN | head -1 | cut -d '/' -f2 | cut -d "." -f1)".MLV
if grep "$check" <<< $(cat /tmp/mlvapp_path/file_names.txt)
then
if grep './' /tmp/TIFCLEAN
then
rm -r ../$(cat /tmp/TIFCLEAN | head -1 | cut -d '/' -f2 | cut -d "." -f1)
fi
else
mv *.{mov,MOV} "$(cat /tmp/mlvapp_path/output_folder.txt)"/
fi
to simply:
Code: [Select]
mv *.{mov,MOV} "$(cat /tmp/mlvapp_path/output_folder.txt)"/