Magic Lantern Forum

Using Magic Lantern => Raw Video => Raw Video Postprocessing => Topic started by: PlantDaniel on October 06, 2017, 07:13:21 PM

Title: Canon 6D 10bit 60fps RAW Video - Colour and Aliasing Issues
Post by: PlantDaniel on October 06, 2017, 07:13:21 PM
I have issues with my 6D recording 10 bit 60fps RAW Video.
Since 10 bit raw was released recently I wanted to see if I could get some nice slow motion footage, now that I am able to record for more than just a few seconds. I ran into two problems:

1. Extreme Aliasing: I have only shot 24fps RAW on a 70D before, which had pretty crippling aliasing already. The 6D tops it though - I don't know whether that is a known issue of the 6D or if it is due to the stretching I have to apply in post when working with Slow Motion footage. Anyways - any suggestions on how to decrease aliasing (in camera or in post)?

2. Weird Colour Artifacts: In Landscape shots, where a lot of the scene is in focus, I get weird colour lines of purple/blue and orange colour in my image. They seem to be only present in the area where the focus sits. Is that a known issue, if so: What can I do about it?

Here is a video showcasing the problems, pay attention to the structure of the rock, where the focus sits:
I am using the 10 bit/12 bit nightly build fro Aug21 2017.

Post processing was as follows: Convert MLV to DNG via raw2cdng 1.7.9 - import into Davinci Resolve 14. No colour correction was added, the clip was slowed down to 24fps in post. Resolve is not the issue - I have rendered it with After Effects too, same problems.
Title: Re: Canon 6D 10bit 60fps RAW Video - Colour and Aliasing Issues
Post by: viral kapadia on January 06, 2018, 06:36:21 AM
here is image I convert. i used 6D. shoot on 10bit.

I dont know what is problem
(https://www.magiclantern.fm/forum/proxy.php?request=https%3A%2F%2Fthumb.ibb.co%2Fh2DyRb%2FMLV_A002_051805_C00008_000000.jpg&hash=24f052f7b4aea152a98308841b791328) (https://ibb.co/h2DyRb)


can anyone help me to resolve it. what are the best settings?
Title: Re: Canon 6D 10bit 60fps RAW Video - Colour and Aliasing Issues
Post by: Walter Schulz on January 06, 2018, 12:12:40 PM
Build used?
Cam settings used?
Postprocessing workflow?
Unprocessed samples?
Title: Re: Canon 6D 10bit 60fps RAW Video - Colour and Aliasing Issues
Post by: Levas on January 06, 2018, 05:19:43 PM
Without further info my best guess would be wrong(too old) MLV converter software.
10 bit is rather new and not all MLV converter options can handle it properly.
And I believe this also happens if cold pixel fix is used in the converter/MLVdump

The MLV format is about 4 years old.
The 10 and 12 bit options came available 1 year ago.
Not all MLV converters out there can handle the 10/12 bit files.

Try using MLV dump, newest builds are available on the experiments page in the section with 4K raw video recording; lossless compression.
http://builds.magiclantern.fm/experiments.html (http://builds.magiclantern.fm/experiments.html)
If you're already using MLV dump, don't use cold pixel fix and stripe fix...by adding this in your command line
Code: [Select]
--no-fixcp --no-stripes
So nothing wrong with your MLV files, but it goes wrong in the conversion step.