Magic Lantern Forum

Developing Magic Lantern => General Development => Topic started by: ludenus on August 12, 2012, 02:37:55 PM

Title: how to patch firmware files when building v2.3 from sources?
Post by: ludenus on August 12, 2012, 02:37:55 PM
new here

I've been trying  to build v.2.3 from sources following these instructions http://magiclantern.wikia.com/wiki/Build_instructions/Unified . After just a few manipulations "make" and "make zip" succeeded and I've got zip archive with autoexec and ML folder. The sad thing was that zip package had no *.fir files inside. I've tried to run "make fir" but got the following error message:

Code: [Select]
python: can't open file '../../../dumper/build_fir.py': [Errno 2] No such file or directory
Grepping sources finds several lines that use build_fir.py script for patching firmware:

Code: [Select]
./installer/50D.109/Makefile: python ../../../dumper/build_fir.py -r ../../../dumper/50D00109.FIR updater.bin $(UPDATE_NAME)
but there is  no build_fir.py script in magic-lantern sources fetched from hg repository.

QUESTION:
Can someone please clarify whether it is possible to patch firmware and if it is - how to do it?
Title: Re: how to patch firmware files when building v2.3 from sources?
Post by: JYves on August 13, 2012, 03:54:12 AM
Had the same problem. Used the *.fir from the last release and copied all of them on the root of the SD.
I also had to move the FONT.dat file to the root of the SD.

JY.