Magic Lantern Forum

Using Magic Lantern => General Help Q&A => Topic started by: ds.trias on April 18, 2014, 10:47:17 PM

Title: 5D-MARKIII Camera won't turn on after switching CF cards
Post by: ds.trias on April 18, 2014, 10:47:17 PM
Hey there,

Few months ago I installed ML on my MARK-III in order to shoot RAW video. Everything worked well until today, by mistake, I took out my 64gb LEXAR CF card and put a transcend 32gb card instead. The Transcend card has ML installed for my other camera, a 7D.
After I put the transcend card in the 5D, it simply won't turn on anymore.. I've tried putting back the original card, changing batteries etc', nothing works. Camera is simply dead. Am I in big trouble?

Thanks so much in advance for the helpers!
Title: Re: 5D-MARKIII Camera won't turn on after switching CF cards
Post by: Walter Schulz on April 18, 2014, 10:55:18 PM
Tried to power up without any card inserted after removing/reinserting both batteries?
Title: Re: 5D-MARKIII Camera won't turn on after switching CF cards
Post by: ds.trias on April 18, 2014, 11:21:50 PM
Tried to power up without any card inserted after removing/reinserting both batteries?

Hey Walter,
Thanks for the response!
Yes, it doesn't power up even without the card and after changing the battery (I don't have the extended grip).
Title: Re: 5D-MARKIII Camera won't turn on after switching CF cards
Post by: Walter Schulz on April 18, 2014, 11:33:52 PM
There are two batteries in each cam. The big one and a small one. Removal of the small one is described here:
http://protogtech.com/cameras/canon-5d-mark-iii-clock-battery-location-removal/
Remove this one for at least half an hour. If cam doesn't come up again after reinserting and power up (again: No card inserted) you have to ask for a1ex' assistance unbricking your cam.

Ciao
Walter
Title: Re: 5D-MARKIII Camera won't turn on after switching CF cards
Post by: ds.trias on April 21, 2014, 12:23:17 AM
There are two batteries in each cam. The big one and a small one. Removal of the small one is described here:
http://protogtech.com/cameras/canon-5d-mark-iii-clock-battery-location-removal/
Remove this one for at least half an hour. If cam doesn't come up again after reinserting and power up (again: No card inserted) you have to ask for a1ex' assistance unbricking your cam.

Ciao
Walter

Thanks Walter, this worked!
Title: Re: 5D-MARKIII Camera won't turn on after switching CF cards
Post by: jlpeifer on December 28, 2018, 11:57:06 AM
There are two batteries in each cam. The big one and a small one. Removal of the small one is described here:
http://protogtech.com/cameras/canon-5d-mark-iii-clock-battery-location-removal/
Remove this one for at least half an hour. If cam doesn't come up again after reinserting and power up (again: No card inserted) you have to ask for a1ex' assistance unbricking your cam.

Ciao
Walter

Can concur. I experienced a panic moment this morning when my camera went from working fine to not working at all (wouldn't power on). I had been inserting an SD card that contained ML while the camera was powered on. Suddenly the camera was dead. I pulled the small battery, waited, then re-inserted. Camera powered on just fine.  SD card now appears to be bricked.

Thanks Walter! You saved me a trip to the camera repair store.