Porting ML to XSi (450D)

Started by rwl408, September 06, 2013, 06:07:43 AM

Previous topic - Next topic

0 Members and 1 Guest are viewing this topic.



I'm having a hard time getting the mentioned version to run on my 450D (1.1.0). I keep getting the blinking blue led on the camera. @alin.cocos, sorry for asking, but what do you mean by 'pressing the Recycle button' ?

I'm on macOS Ventura and can't use the EOSCard utility, so I used the MacBoot script. Can you maybe share an image of your SD card (with the ML version you used) ?

Got it working, now figuring out how the Live View option works via my MacBook Pro....

Best regards,



Hey guys, I'm having a hard time trying to install ML on my 450D. I've tried everything mentionned in the forums and in the instal guide, but still nothing but a blinking blue led.
I tried with 3 different versions of ML (2018, 2019 and 2021) using EOSCard to make the sd card bootable but nothing.
I also tried formating the card with the camera or with the windows formating tool but it doesnt work either.
And I used 3 different cards thinking they were just not working but no.

None of my solutions worked and what happens is this:
- Screen turns black with blue led turning on
- Screen turns on to firmware update for a split sec
- Then goes back to black with the blinking led
- Autofocus with apperture and shutter speed still work in the viewfinder

If anybody could help me that would be great. Thanks guys

Walter Schulz

I installed ML on a 450D lately.

Use a small card (SD or SDHC) and retry.
First make sure your card is properly prepared:
Run EOScard and make sure both checkboxes are enabled after start. If not: You should run EOScard as admin, enable both boxes (BOOTDISK and EOS_DEVELOP), press SAVE button.

Report back


Okay so here are the steps I used:

- Format the card from the camera with low level format enabled
- Turn off the camera, remove the card
- Plug the card in the pc, extract magiclantern-Nightly.2021Aug07.450D110 inside it.
- Run EOSCard as admin, click refresh, select ML and hit save
- Place the card in the camera, turn on, go to the update page, hit ok

Result: Instant black screen and flashing led

Sometimes this happens and other times it shows up the firmware updating screen and then turns off + blinking led

Walter Schulz

Quote from: Troncature on April 12, 2024, 11:51:39 PM- Run EOSCard as admin, click refresh, select ML and hit save

Redo from scratch but don't use "ML" icon. Select BOOTDISK and EOS_DEVELOP checkboxes and press SAVE button on top.


Nope, same thing, when I manualy select EOS_DEVELOP and BOOTDISK it selects ML by itself. And this time it has the blinking led, its not constantly on

Walter Schulz

Quote from: Troncature on April 13, 2024, 02:06:20 AMAnd this time it has the blinking led, its not constantly on
Please clarify!
"And this time" implies you have had other results after installation.
Do you get LED burning constantly in the end?


As I said in the my second post, there are two results: either the led blinks with the firmware update flashing for a sec or just an instant black screen with the blue led flashing constantly.

This time the second result happened. Sorry for not clarifying well enough.

Walter Schulz

Visit https://eoscard.pel.hu and download Canon firmware 1.1.0 for 450D.
Wipe card by formating inside cam.
Extract e5kr4110.fir to card and run firmware update in cam.

After that retry ML installation.


I already updated it to this version, but I tried again anyways. This time, I tried keeping the 1.1.0 firmware inside the card alongside the ML files, and it gave me the choice to update either from the original firmware or the ML one, when I choose the ML one it, for some reason tells me confirm the update from 1.1.0 to 1.0.9. I press ok nonetheless and I get a firmware update error screen and I have to remove the battery to fix it.

The error is the following: Update file error. Please check the memory card and reload the battery and try again. ; Is the build I'm using broken? Its the one I downloaded from Ant123's repo.

Also, since I started these experimentations i've been getting some color flickering in the menus, they turn green yellow and red but it goes away when I change menu.


Hmm weird, I did nothing special but now when I put the card in the camera it doesnt want to turn on (except for the viewfinder and auto stuff). I have to remove the card then the battery to make it work again.

I formated the card from the pc and now its working again.


So after some further looking in the sd card i've found that with the last method I used (keeping the two firmware files) the instalation starts but gets interrupted by something as I can see a log file getting created with some logs inside it. I can see that it usually stops at "Scanning modules" but it managed to make some progress before getting stopped once but I forgot to save the log file.

Walter Schulz

Which is actually nice.
Because it indicates cam is prepared for ML.
Now make sure to have Canon firmware 1.1.0 and not 1.0.9 installed.
If so:
Use EOScard to enable EOS_DEVELOP and BOOTDISK. Copy extracted Nightly Build content to card (wipe anything else on card before).
Insert card into cam, startup cam and wait for some time until LED calms down. Then press trashcan button to access ML menu.


Oh my god I am so stupud, I completely forgot that I had to press the recycle button to go to the ML menu, I kept trying to install it from the firmware but theres no need to do that with EOSCard why didnt I think about that earlier lol.
But its not finished yet, I managed to go to the ML menu but I still have the weird color flickering that happens everytime now and its pretty annoying, and when live view is on it just happens constantly and not just for colors but even for menus, when I'm in live view and I press the ML button, it switches between LV, ML and the WB menu very fast so I can't do anything. Also the camera just freezes sometimes and I have to remove the battery to reset it. I dont know if these issues are just for me or because its still in developpement but thanks anyways mate, at least I got it working somehow


Today I spent several hours installing and now my camera won't turn on

Walter Schulz

Remove battery, remove card.
Insert battery.
Close all doors.
Startup cam.
Report back.