Author Topic: Canon 7D Mark I  (Read 527049 times)

arrinkiiii

  • Hero Member
  • *****
  • Posts: 1096
  • ML ADDICTED 7D
Re: 7D ML backporting from TL
« Reply #25 on: February 04, 2014, 04:43:44 PM »

Where some stuff from ML that don't exist or not working correct,

-Zoom 10x  stay hang, pressing play button it get out of that freeze state.
-No MLV
-No Audio
 

I have made some tests with raw_mo but i don't know if it's worth to write here or to do more tests... Wait for the MLV?  Other stuff looks to work good. I need more modules for try out, this build/version  just have this modules.

raw_mo
dual_iso.mo
ettr_mo
autoexpo.mo
file_man.mo
pic_view.mo

 

1%

  • Developer
  • Hero Member
  • *****
  • Posts: 5936
  • 600D/6D/50D/EOSM/7D
Re: 7D ML backporting from TL
« Reply #26 on: February 04, 2014, 07:39:45 PM »
Easiest on the list
*Audio
*Display filters (just like 5DII/50D)

Harder:

Headphone from slave --- it has to be toggled on, there is no way to detect connection
FPS override for H264 -- It can be done from slave, needs help with unexpected video stops

ted ramasola

  • Moderators
  • Hero Member
  • *****
  • Posts: 1246
Re: 7D ML backporting from TL
« Reply #27 on: February 04, 2014, 10:24:33 PM »
If I use EOSCard from Pelican to make new bootable card for 7D, it already includes an MLV.mo, I still updated the install from jenkins Jan 21 build which does not have an mlv.mo.

Is this MLV mo from eoscard considered from ML or TL? so I'd know if I should test it and report.

This build Lacks:

Audio:
 -The option to choose channels
 -Headphone monitoring
 -External mic controls
 -Gain controls
 -MLV Sound

Movie:
 -FPS Override
 _don't know yet if MLV from eoscard is TL or ML so holding report on this.
5DmkII  / 7D
www.ramasolaproductions.com
Texas

arrinkiiii

  • Hero Member
  • *****
  • Posts: 1096
  • ML ADDICTED 7D
Re: 7D ML backporting from TL
« Reply #28 on: February 04, 2014, 10:38:38 PM »
I think is just the modules that are in the folder. From EOScard is from TL... but for sure that someone will tell better then me.

1%

  • Developer
  • Hero Member
  • *****
  • Posts: 5936
  • 600D/6D/50D/EOSM/7D
Re: 7D ML backporting from TL
« Reply #29 on: February 04, 2014, 11:57:58 PM »
I thought EOScard went ML->TL->ML... really I don't think it should be downloading any builds, just making the card bootable/etc. Maybe verify file/folder placement instead.

So for this, just make another repo from the current tree and add the audio/display filter? Then I guess we can see how to port the other things which are left... also the dual ISO preview never made it into main + what is the word on named bracketing like B01, etc... it was much more reliable than dual ISO custom prefix.

After 2.03 is brought up to par... I guess can move to porting 7D. 205

arrinkiiii

  • Hero Member
  • *****
  • Posts: 1096
  • ML ADDICTED 7D
Re: 7D ML backporting from TL
« Reply #30 on: February 05, 2014, 12:04:43 AM »
After 2.03 is brought up to par... I guess can move to porting 7D. 205

Yes  :D

1%

  • Developer
  • Hero Member
  • *****
  • Posts: 5936
  • 600D/6D/50D/EOSM/7D
Re: 7D ML backporting from TL
« Reply #31 on: February 05, 2014, 12:21:18 AM »
I'm not that excited with 205... I don't think they modernized any parts of the FW. Im predicting it will just be like 6D112 -> 6D113, a bunch of changed addresses and thats it.

5DIII going to 123 has completely changed stuff.

arrinkiiii

  • Hero Member
  • *****
  • Posts: 1096
  • ML ADDICTED 7D
Re: 7D ML backporting from TL
« Reply #32 on: February 05, 2014, 02:08:59 AM »

I think that your talking about ML stable version and not canon fw. The fw 2.05 i think just have one update, having to do with  FTP with a USB cable and WFT-E5 transmitter.


1%

  • Developer
  • Hero Member
  • *****
  • Posts: 5936
  • 600D/6D/50D/EOSM/7D
Re: 7D ML backporting from TL
« Reply #33 on: February 05, 2014, 03:42:32 AM »
Both... 2.03 needs all features in main and then 2.05 update needs to be ported over in both.

arrinkiiii

  • Hero Member
  • *****
  • Posts: 1096
  • ML ADDICTED 7D
Re: 7D ML backporting from TL
« Reply #34 on: February 08, 2014, 10:41:41 AM »
Where can we find the new builds for the updates in ML Nightly 7D (with MLV_MO) ? It was removed from here http://builds.magiclantern.fm/#/ 

1%

  • Developer
  • Hero Member
  • *****
  • Posts: 5936
  • 600D/6D/50D/EOSM/7D
Re: 7D ML backporting from TL
« Reply #35 on: February 08, 2014, 05:37:56 PM »
You'd have to compile. 7D was never that far behind, could have had a nightly for people to chose, stable, experimental. The first pull request is up with 90% of audio. Just needs headphone ported and the wav is disabled because it can't use the memory backend or the memory leak gets out of control.

arrinkiiii

  • Hero Member
  • *****
  • Posts: 1096
  • ML ADDICTED 7D
Re: 7D ML backporting from TL
« Reply #36 on: February 08, 2014, 06:00:40 PM »

Ok, thanks 1%  Sometimes i think i understand and then... nikles.  I think that wend dev's start to porting stuff from TL 2 ML it show up here http://builds.magiclantern.fm/#/   


Anything that i can help for putting the 7D ML on the branch/nights/main/maintenance  just let me know.

1%

  • Developer
  • Hero Member
  • *****
  • Posts: 5936
  • 600D/6D/50D/EOSM/7D
Re: 7D ML backporting from TL
« Reply #37 on: February 08, 2014, 06:21:24 PM »
give it a go when someone compiles it.

7Dphotos

  • New to the forum
  • *
  • Posts: 9
Re: 7D ML backporting from TL
« Reply #38 on: February 08, 2014, 07:31:51 PM »
Which version is suggested for bracketed HDR work?

1%

  • Developer
  • Hero Member
  • *****
  • Posts: 5936
  • 600D/6D/50D/EOSM/7D
Re: 7D ML backporting from TL
« Reply #39 on: February 08, 2014, 08:01:54 PM »
Besides the naming of bracketed shots to B01 they should be identical for this feature.

7Dphotos

  • New to the forum
  • *
  • Posts: 9
Re: 7D ML backporting from TL
« Reply #40 on: February 08, 2014, 11:32:11 PM »
Sorry for the totally NOOB question but where do we dl most recent version of ML for the 7D?

arrinkiiii

  • Hero Member
  • *****
  • Posts: 1096
  • ML ADDICTED 7D
Re: 7D ML backporting from TL
« Reply #41 on: February 08, 2014, 11:50:42 PM »

You need to compile... or wait that someone compile it.

7Dphotos

  • New to the forum
  • *
  • Posts: 9
Re: 7D ML backporting from TL
« Reply #42 on: February 09, 2014, 07:01:15 AM »
What is the latest compiled version and where to find it?

Stedda

  • Hero Member
  • *****
  • Posts: 504
Re: 7D ML backporting from TL
« Reply #43 on: February 09, 2014, 08:03:15 AM »
You need to compile it yourself or wait for someone to share their build but someone already to you this....
5D Mark III -- 7D   SOLD -- EOS M 22mm 18-55mm STM -- Fuji X-T1 18-55 F2.8-F4 & 35 F1.4
Canon Glass   100L F2.8 IS -- 70-200L F4 -- 135L F2 -- 85 F1.8 -- 17-40L --  40 F2.8 -- 35 F2 IS  Sigma Glass  120-300 F2.8 OS -- 50 F1.4 -- 85 F1.4  Tamron Glass   24-70 2.8 VC   600EX-RT X3

7Dphotos

  • New to the forum
  • *
  • Posts: 9
Re: 7D ML backporting from TL
« Reply #44 on: February 09, 2014, 08:37:34 PM »
You need to compile it yourself or wait for someone to share their build....

Then what is this?

https://bitbucket.org/hudson/magic-lantern/downloads/magiclantern.7D.203.Alpha2.zip

a1ex

  • Administrator
  • Hero Member
  • *****
  • Posts: 9907
  • 5D Mark Free
Re: 7D ML backporting from TL
« Reply #45 on: February 09, 2014, 08:41:39 PM »
the wav is disabled because it can't use the memory backend or the memory leak gets out of control.

Nope, the memory backend catches the bug, and by disabling the memory backend you are simply ignoring the error message (and the bug is still there).

Moreover, this bug causes the wav recorder to write on unallocated memory => undefined behavior.

Walter Schulz

  • Hero Member
  • *****
  • Posts: 5487
Re: 7D ML backporting from TL
« Reply #46 on: February 09, 2014, 08:45:32 PM »
Then what is this?

File date 23. Dec. 2012

1%

  • Developer
  • Hero Member
  • *****
  • Posts: 5936
  • 600D/6D/50D/EOSM/7D
Re: 7D ML backporting from TL
« Reply #47 on: February 09, 2014, 09:30:50 PM »
Quote
Nope, the memory backend catches the bug, and by disabling the memory backend you are simply ignoring the error message (and the bug is still there).

Then why no crashes and missing memory? With the back-end on I get an error 70 from canon after the memory counts down. Without it, looks like all or most memory is released and no ERR70. Wavs record for a long time. I know the leak is still there for like a few kb but its not the monster that happens otherwise. Either way it will need a fix as the cameras make a really nice sound recorder. Esp. if you have more than one and no digital recorder.

a1ex

  • Administrator
  • Hero Member
  • *****
  • Posts: 9907
  • 5D Mark Free
Re: 7D ML backporting from TL
« Reply #48 on: February 09, 2014, 09:36:23 PM »
The effects of undefined behavior range from nothing noticeable to anything you can imagine.

http://blog.llvm.org/2011/05/what-every-c-programmer-should-know.html

1%

  • Developer
  • Hero Member
  • *****
  • Posts: 5936
  • 600D/6D/50D/EOSM/7D
Re: 7D ML backporting from TL
« Reply #49 on: February 09, 2014, 09:45:15 PM »
Hope there is a way to solve this properly.

edmac memcpy will cause issues while writing H264 since the channels will probably be in use.