Author Topic: Canon 7D Mark I  (Read 486701 times)

Brawl

  • Member
  • ***
  • Posts: 198
Re: Canon 7D Mark I
« Reply #1325 on: January 22, 2017, 12:07:24 AM »
@DeafEyeJedi it's Nightly.2016Nov25.7D203 but maybe could be the one modified by dfort because I have 10 and 12 bit in MLV Lite module. If I remember well 10 and 12 bit are not yet implemented in the official nightly built because in early stage of developement.

p.s. I did the 60fps test (the one with the tearing) with mlv_rec module. I repeated the test with similar settings at 48fps and I has no tearing. maybe 60fps is too much or it works good to you?  thx

p.s.

I has "force HDMI-VGA: on" in "/display/advanced settings" which is good for taking tearing under control
(for someone who wish to read more info can read this topic: http://www.magiclantern.fm/forum/index.php?topic=13817.0)

a1ex

  • Administrator
  • Hero Member
  • *****
  • Posts: 9559
  • 5D Mark Free
Re: Canon 7D Mark I
« Reply #1326 on: January 27, 2017, 11:37:29 AM »
Is the 7D also affected by this issue?

Roger66

  • New to the forum
  • *
  • Posts: 9
Re: Canon 7D Mark I
« Reply #1327 on: January 27, 2017, 09:51:58 PM »
Hi,

today I tried ML first time on my 7D1 and 100D and am impressed.

But I have to report a bug at the 7D version:

The option Quick Zoom - full zoom on AF point doesn't work correct. It doesn't zoom on AF point, but just in the middle of the picture. That means it does exactly the same as zoom to 100%.

//EDIT: bug reported: #2673


Regards
Roger
7D.203 100D.101

itisipotman

  • Just arrived
  • *
  • Posts: 2
Re: Canon 7D Mark I
« Reply #1328 on: January 30, 2017, 09:33:04 AM »
Yeah, so at some stage HDMI tearing seems to have been fixed. On the latest build I have been recording with an external monitor (not set to force VGA) and no tearing is present. Minor tearing occurred when using crop mode with no FPS over ride. But otherwise no tearing at all. Anyone else want to test and confirm?

Great news if corroborated.

maxotics

  • Hero Member
  • *****
  • Posts: 528
Re: Canon 7D Mark I
« Reply #1329 on: January 30, 2017, 01:36:35 PM »
I don't know if tearing is fixed.  When I use an external monitor and turn off focus peaking and such in ML, letting the monitor do it, it records fine.

DeafEyeJedi

  • Hero Member
  • *****
  • Posts: 2768
  • 5D3 / M1 / 7D / 70D / SL1
Re: Canon 7D Mark I
« Reply #1330 on: January 30, 2017, 05:58:23 PM »
Which build were you using @itisipotman?
5D3.123 • EOSM.203 • 7D.203 • 70D.112 • 100D.101

itisipotman

  • Just arrived
  • *
  • Posts: 2
Re: Canon 7D Mark I
« Reply #1331 on: January 30, 2017, 07:42:14 PM »
Cool, I should have mentioned the following, Jan 27th Nightly. The camera is set to PAL and I'm recording at max res just fine at 25fps with MLV, crop mode is also recording fine at 1080p with 25p. All I did was turn the MLV module and sound module on and hit record, haven't changed any default settings.

Maxotics, care to elaborate? It sounds like things are working for you, but you also mention you don't know if its fixed?

Randallsart

  • New to the forum
  • *
  • Posts: 3
Re: Canon 7D Mark I
« Reply #1332 on: February 16, 2017, 02:03:20 AM »
is there ML for the Canon 7d mk2?

Walter Schulz

  • Hero Member
  • *****
  • Posts: 5304
Re: Canon 7D Mark I
« Reply #1333 on: February 16, 2017, 12:40:34 PM »
No

Jato

  • New to the forum
  • *
  • Posts: 3
Re: Canon 7D Mark I
« Reply #1334 on: February 26, 2017, 09:15:38 AM »
A few questions!
First of all, thank you very much, you developers, for this great work. My 7D is very happy too with ML 'new life' :)
I've tried to read all posts here and related with raw video, etc, but i still have some questions:

I use last stable ML firmware, but these doubts are regarding older versions too:
1) It's definitively impossible to record audio while recording video?
2) I can record continuously without anyproblem (Sandisk extreme pro 160MB/S UDMA7 32Gb) but not in crop mode, where it's allways cut about 20 seconds maximun length.
3) Quite frequently, frame 197-198 is corrupted with magent artifacts

I have tried lots of config, allways trying to get de biggest resolution possible, and now i'm recording fine at 2240x1120, both RAW video and MLV video.
Sorry if my questions are answered in same other topic :/ It's a very HUGE (and INTERESTING) forum! Thanks!


Walter Schulz

  • Hero Member
  • *****
  • Posts: 5304
Re: Canon 7D Mark I
« Reply #1335 on: February 26, 2017, 02:34:21 PM »
First of all: There is no "stable" Version for 7D and never was. "Stable" = outdated and unsupported v2.3.
There are "Nightly Builds".

1. Not at all. What gave you the impression it doesn't work?

2. Sorry but you have to be specific. Any Information about recording times achieved in continuous mode is pretty much pointless without mentioning resolution, frame rate and bit depth. And mentioning recording mode (H.264, MLV/MLV lite, RAW).

I suppose you run into unintentional stopping because crop mode records in 30 fps and therefore requires higher bandwidth.

3. Build used?

Jato

  • New to the forum
  • *
  • Posts: 3
Re: Canon 7D Mark I
« Reply #1336 on: February 26, 2017, 08:56:32 PM »
Regarding sonund recording: i've never been able to record any sound!
With an older Nightly build version, i read a tutorial where set sound off were recommended -maybe to optimize recording mb/s rates while recording, or something... and now, that i use the last Nightly Build available, maybe i have to re-read all info available, and practice more settings combos... but, for instance: yesterday i made some recordings, in MLV, 2240x1120px, and using MLVFS i see one of them says 'sound: YES' but it's not true...

I started using RAW video about 6 months ago, using raw_rec.mo (Magic Lantern Nightly.2016Jul09.7D203), and using the CF card i mentioned (Sandisk extreme pro 160MB/S UDMA7 32Gb) i realised i can record about 20 seconds MAX, without sound, in maximun resolution aparently available (about 1120 pix vertical res. max), and 23,9xx fps.

I installed Magic Lantern Nightly.2017Feb12.7D203 a few days ago, and started trying different video settings, with raw_rec and mlv_rec, mlv_lite... I realised i can record continous raw video in normal -no-croppped- mode, but in cropped mode, y can record about 20 seconds maximun at -theoretically- maximun resolution (2240x1120), but allways without sound, even when i can see 'sound:yes' in MLVFS. :/

It's being VERY interesting this 'new world', my 'old' 7D has a new life, and it's being very useful for me taking wildlife scenes as i do :)

Sorry about my english, and sorry if i'm not clear enough explaining all the facts :D

Thanks for your answer, @Walter.

Regarding 'bit depth', i have rad something about 10-12-14bits raw video, but i cant see 'where' these settings are in ML :/


Baladeva

  • New to the forum
  • *
  • Posts: 25
Re: Canon 7D Mark I
« Reply #1337 on: February 27, 2017, 06:11:33 AM »
When I want to put the new firmware,should I remove the old magic lantern first?or is ok?

Walter Schulz

  • Hero Member
  • *****
  • Posts: 5304
Re: Canon 7D Mark I
« Reply #1338 on: February 27, 2017, 07:13:28 AM »
If you want to use Canon firmware 2.0.6 I recommend to uninstall ML first.

Walter Schulz

  • Hero Member
  • *****
  • Posts: 5304
Re: Canon 7D Mark I
« Reply #1339 on: February 27, 2017, 07:33:17 AM »
Regarding sonund recording: i've never been able to record any sound!

If H.264 recording is not working it is most likely hardware error.
MLV_REC requires MLV_SND for audio recording.

I installed Magic Lantern Nightly.2017Feb12.7D203 a few days ago, and started trying different video settings, with raw_rec and mlv_rec, mlv_lite... I realised i can record continous raw video in normal -no-croppped- mode, but in cropped mode, y can record about 20 seconds maximun at -theoretically- maximun resolution (2240x1120), but allways without sound, even when i can see 'sound:yes' in MLVFS. :/

Maybe you missed the information about crop mode frame rate in my first answer to you above.

Regarding 'bit depth', i have rad something about 10-12-14bits raw video, but i cant see 'where' these settings are in ML :/

Status "experimental". You can use Reddeercity's repository at own risk: https://bitbucket.org/reddeercity/magic-lantern_10-12bit/downloads/
Thread about 10/12-bit: http://www.magiclantern.fm/forum/index.php?topic=5601.msg180056#msg180056

Jato

  • New to the forum
  • *
  • Posts: 3
Re: Canon 7D Mark I
« Reply #1340 on: February 27, 2017, 12:30:24 PM »
@Walter i have some news :)

This morning a was able to record sound! Of course i can with CANON's firmware, so i remembered that resampling bitrate to 23,9xx is causing soundoff, even when it's supossed to be on. (my fault...)

I did some other tests, with both kind of video tools: I thought that each of the video types had a different format (RAW & MLV) but I only got MLV files.


Quote
Status "experimental". You can use Reddeercity's repository at own risk: https://bitbucket.org/reddeercity/magic-lantern_10-12bit/downloads/
Thread about 10/12-bit: http://www.magiclantern.fm/forum/index.php?topic=5601.msg180056#msg180056

Maybe i read a bit more, before asuming that risk, but if it increases cropped video length letting me play a bit with dng files it could be really GOOD!

Thanks again for your kind support Walter! :)

Javi

Walter Schulz

  • Hero Member
  • *****
  • Posts: 5304
Re: Canon 7D Mark I
« Reply #1341 on: February 27, 2017, 03:36:34 PM »
I did some other tests, with both kind of video tools: I thought that each of the video types had a different format (RAW & MLV) but I only got MLV files.

About 2 week ago it was different indeed: https://twitter.com/autoexec_bin/status/830878711423590402
Or select raw_rec.mo in Modules menu and press Q.

jman

  • Freshman
  • **
  • Posts: 74
Re: Canon 7D Mark I
« Reply #1342 on: March 08, 2017, 03:58:25 AM »
Well....Here I got all excited about acquiring Premier Pro CC 2017. So I shot some MLV and used MLV ViewSharp to change the MLV file to .dng with wave file. I go into Premier Pro media browser to import the dng and it won't allow import stating the file is either not supported or damaged. What a load of S*** !! Opens fine in Photoshop and After Effects but NOT Premier. I've searched online for fixes and nothing works. Oh well, just a heads up.
 

Walter Schulz

  • Hero Member
  • *****
  • Posts: 5304
Re: Canon 7D Mark I
« Reply #1343 on: March 08, 2017, 05:14:11 AM »
"MLV ViewSharp"? Sorry, don't know what you are talking about and googleing doesn't help.

jman

  • Freshman
  • **
  • Posts: 74
Re: Canon 7D Mark I
« Reply #1344 on: March 09, 2017, 01:56:10 AM »
Hello Walter...MLV ViewSharp(BrowseSharp) converts mlv's to dngs or raws (with .wav files if you record with sound) ...anyway I got Drastic MediaReactor Workstation and now I can import mlv's directly into Premier Pro. The only problem is if you recorded with sound and want to sync with a master sound file recorded on another device such as a H4N, Plural Eyes 4 does not recognize .mlv video files. So you have sync them outside of Premier Pro.


MLV Viewsharp here...
https://www.youtube.com/watch?v=I-iyiZAG7JI     

dmilligan

  • Developer
  • Hero Member
  • *****
  • Posts: 3126
  • 60Da / 1100D / EOSM
Re: Canon 7D Mark I
« Reply #1345 on: March 09, 2017, 04:01:44 AM »
What a load of S*** !! Opens fine in Photoshop and After Effects but NOT Premier.
Premiere can only open specific "flavors" of CinemaDNG files. There are many MLV converters that support output of Premiere compatible CDNG files, including:
http://www.magiclantern.fm/forum/index.php?topic=13152.0
http://www.magiclantern.fm/forum/index.php?topic=5618.0
http://www.magiclantern.fm/forum/index.php?topic=9560.0
http://www.magiclantern.fm/forum/index.php?topic=18975.0

Baladeva

  • New to the forum
  • *
  • Posts: 25
Re: Canon 7D Mark I
« Reply #1346 on: March 09, 2017, 12:00:30 PM »
Quote
If you want to use Canon firmware 2.0.6 I recommend to uninstall ML first.

there is 2.0.6 now that is cool!but why doesnt the builds say 2.0.6 and is 2.0.3?

Walter Schulz

  • Hero Member
  • *****
  • Posts: 5304
Re: Canon 7D Mark I
« Reply #1347 on: March 09, 2017, 12:04:23 PM »
Yes, after upgrading to 2.0.6 you can't use ML anymore.

Baladeva

  • New to the forum
  • *
  • Posts: 25
Re: Canon 7D Mark I
« Reply #1348 on: March 09, 2017, 12:05:48 PM »
all right,thanks alot.
have you see the new post i posted at the 7d cropped 5*?