Author Topic: Canon 700D / T5i  (Read 586846 times)

dfort

  • Hero Member
  • *****
  • Posts: 1977
Re: Canon 700D / T5i
« Reply #1000 on: March 02, 2017, 01:17:07 AM »
Good to hear it is working. Anyone else with a 700D/T5i running 1.1.5 firmware can give it a try. I'll keep a build on my bitbucket download area until it is merged:

https://bitbucket.org/daniel_fort/magic-lantern/downloads/
EOSM.202 EOSM.203 EOSM2.103 700D.115 5D3.*

neerajkt

  • Just arrived
  • *
  • Posts: 1
Re: Canon 700D / T5i
« Reply #1001 on: March 15, 2017, 08:05:35 AM »
I can't find a stable build for my Canon 700D/t5i running 1.1.4, all I can find are nightly builds which are pretty risky

Please give the link to a stable build or a the build number of a thoroughly tested nightly build as I can't risk bricking my camera(It's just 2 days old)

Thanks <3

jarbi

  • New to the forum
  • *
  • Posts: 9
Bulb ramping is not in the menu ?
« Reply #1002 on: March 18, 2017, 09:20:49 AM »
Hi developers,

First of all thanks for all efforts to make ML work on the700D;-). One of the main reasons I have installed it because I make astro timelapse videos.
After activating ML I don't see where can I do "bulb ramping" on this camera ? I thought I would find it under Intervalometer but it's not there. Am I overlooking something here ?

Cheers,
Janos

techlivemana

  • Just arrived
  • *
  • Posts: 1
Re: Canon 700D / T5i
« Reply #1003 on: March 18, 2017, 03:31:31 PM »
Good to hear it is working. Anyone else with a 700D/T5i running 1.1.5 firmware can give it a try. I'll keep a build on my bitbucket download area until it is merged:

https://bitbucket.org/daniel_fort/magic-lantern/downloads/


Have installed it.. Looks good so far. Will update if I find any issues.


Sent from my iPhone using Tapatalk

Yester

  • Just arrived
  • *
  • Posts: 1
Re: Canon 700D / T5i
« Reply #1004 on: March 20, 2017, 01:03:40 AM »
Hi. Is there ML for version 1.1.5 ??

Audionut

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 3406
  • Blunt and to the point
Re: Canon 700D / T5i
« Reply #1005 on: March 20, 2017, 05:34:46 AM »
I can't find a stable build for my Canon 700D/t5i running 1.1.4, all I can find are nightly builds which are pretty risky

Please give the link to a stable build or a the build number of a thoroughly tested nightly build as I can't risk bricking my camera(It's just 2 days old)

Stable build | Latest builds


After activating ML I don't see where can I do "bulb ramping" on this camera ? I thought I would find it under Intervalometer but it's not there. Am I overlooking something here ?

https://builds.magiclantern.fm/features.html

Hi. Is there ML for version 1.1.5 ??

No.

dfort

  • Hero Member
  • *****
  • Posts: 1977
Re: Canon 700D / T5i
« Reply #1006 on: March 20, 2017, 06:47:54 AM »
Hi. Is there ML for version 1.1.5 ??

Yes. I have a pull request and a test build that you can try out. Please report your findings.

https://bitbucket.org/daniel_fort/magic-lantern/downloads/


Sent from my iPad using Tapatalk
EOSM.202 EOSM.203 EOSM2.103 700D.115 5D3.*

Audionut

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 3406
  • Blunt and to the point
Re: Canon 700D / T5i
« Reply #1007 on: March 20, 2017, 08:37:34 AM »
You're to kind (or I'm to old and cranky).

Page had four posts, two of which had the (correct) answer.

jarbi

  • New to the forum
  • *
  • Posts: 9
Re: Canon 700D / T5i
« Reply #1008 on: March 23, 2017, 08:22:36 AM »
Hi Daniel,

I run ML now with firmware 1.1.4, how can I go over to 1.1.5 and install your build ?

Cheers,
Janos

Walter Schulz

  • Hero Member
  • *****
  • Posts: 5714
Re: Canon 700D / T5i
« Reply #1009 on: March 23, 2017, 08:27:10 AM »
Install Canon firmware 1.1.5 and update card's files with build for 1.1.5.

G4jima

  • Just arrived
  • *
  • Posts: 1
Canon 700D / T5i Pink and Blue focus dots
« Reply #1010 on: March 31, 2017, 02:05:37 PM »
Hi

love magic lantern but cant use raw video on the 700D here in college

no matter what i get RAW focus dots everywhere

tried all softwares shooting in manual just cant work it out

im using firmware 1.1.4

any assistance greatly appreciated

Emich

  • Just arrived
  • *
  • Posts: 1
Re: Canon 700D / T5i can't find and install Raw Rec Module
« Reply #1011 on: April 16, 2017, 02:39:30 PM »
Hello,
I have problem with magic lantern software. I can't find raw rec module inside in software and after install it on my canon 700d.
Please help me find RAW REC Module and correct install it and make a right settings. I try find it inside on other versions for example in 5d /600d and others, but i find it only in magic lanter 1.1.5 wich i find here on your forum. But any way it work with errors and with bugs.
What can i do for my Rabel t5i for star write RAW video on my camera? Give me please correct link and any helpful information.
Thanks for help.

I have 700d with 1.1.4 software for body and 1.5.0 for lens. On youtube i saw a lot videos and all of them have this RAW Rec module, but not i am :(

tihiandrew

  • Just arrived
  • *
  • Posts: 1
Re: Canon 700D / T5i
« Reply #1012 on: April 24, 2017, 03:53:00 PM »
anyone else running on firmware 1.1.5 with magic lantern  ? some feedback ?

TobWag

  • New to the forum
  • *
  • Posts: 7
Re: Canon 700D / T5i
« Reply #1013 on: April 27, 2017, 07:12:26 AM »
Quote from: Emich
Hello,
I have problem with magic lantern software. I can't find raw rec module inside in software and after install it on my canon 700d.
Please help me find RAW REC Module and correct install it and make a right settings.

I have the same problem. Any help is greatly appreciated.

Walter Schulz

  • Hero Member
  • *****
  • Posts: 5714
Re: Canon 700D / T5i
« Reply #1014 on: April 27, 2017, 07:15:48 AM »
Top of page -> Downloads -> Download Nightly Builds -> Features
raw_rec.mo has been replaced by mlv_lite.mo

Fedya

  • New to the forum
  • *
  • Posts: 9
Re: Canon 700D / T5i
« Reply #1015 on: April 29, 2017, 06:31:31 AM »
Hello! Is it possible to return immediately to liveview (bypassing the black screen) after the shot in the mode silent picture. Because this greatly interferes with the remote shutter release (LCDsensor Remote, Audio RemoteShot). Thank you and sorry for my English

badweather

  • Just arrived
  • *
  • Posts: 1
Re: Canon 700D / T5i
« Reply #1016 on: April 30, 2017, 09:57:17 AM »
Yes. I have a pull request and a test build that you can try out. Please report your findings.

https://bitbucket.org/daniel_fort/magic-lantern/downloads/


Sent from my iPad using Tapatalk

Just installed ML for the first time on my 700D 1.1.5. Thank you for the work you did on this version.

I'll give it a try, but I Like it already.

developerphp

  • New to the forum
  • *
  • Posts: 35
Re: Canon 700D / T5i
« Reply #1017 on: May 02, 2017, 10:21:12 AM »
Good afternoon. Is it possible in ML to control the speed of autofocus in the video mode, as in 70D in the standard firmware? I use mostly manual autofocus, but sometimes in traffic when shooting shooting is very short of normal autofocus.

krisdeak

  • New to the forum
  • *
  • Posts: 8
Re: Canon 700D / T5i
« Reply #1018 on: May 03, 2017, 10:32:17 AM »
Good to hear it is working. Anyone else with a 700D/T5i running 1.1.5 firmware can give it a try. I'll keep a build on my bitbucket download area until it is merged:

https://bitbucket.org/daniel_fort/magic-lantern/downloads/

Hey Daniel & devs,

I was curious about your opinion - do you think lossless raw compression will be possible on the 700D anytime soon?
I know you guys are working hard to crack this problem...

I think I can safely say a lot of us are super excited about the prospect of shooting full-width raw video continuously on our 700D's (even if it's just 1:2.35 aspect) - which is not currently possible due to the SD card speed limitation.

Thanks a lot for your hard work and updates! :-)






Walter Schulz

  • Hero Member
  • *****
  • Posts: 5714
Re: Canon 700D / T5i
« Reply #1019 on: May 03, 2017, 12:11:44 PM »
ML development has no schedules, release dates.

esinem

  • Just arrived
  • *
  • Posts: 1
Re: Canon 700D / T5i
« Reply #1020 on: May 03, 2017, 01:14:52 PM »
[3. post your flickering issue at bitbucket providing a link to a short sample video made with your smartphone. No green confirmation box for 700D available.
[/quote]

Here's a camera phone video, uploaded to Google Photos https://goo.gl/photos/uSNzKkPPewfC41cn8, of the flickering on my recently bought 700D. Relieved to find from earlier posts that it's not a camera fault.

I hope it can be sorted on the 700D as I use Magic Zoom a lot on my 550D and love it.

dfort

  • Hero Member
  • *****
  • Posts: 1977
Re: Canon 700D / T5i
« Reply #1021 on: May 03, 2017, 07:51:34 PM »
Hey @krisdeak -- this is an open source project and much of the discussion about new developments are out in the open so please feel free to jump in and see if you can help figure out some of this stuff.

The 700D lossless compression discussion starts about here:

http://www.magiclantern.fm/forum/index.php?topic=18443.msg182973#msg182973

You're more than welcome to look at what I've been trying on bitbucket:

https://bitbucket.org/daniel_fort/magic-lantern/branch/compressed_raw-700D-EOSM#commits

Don't worry if you don't know how to code. I still don't know C, thought I'm learning. Maybe we're almost there and one address is transposed or something like that.
EOSM.202 EOSM.203 EOSM2.103 700D.115 5D3.*

krisdeak

  • New to the forum
  • *
  • Posts: 8
Re: Canon 700D / T5i
« Reply #1022 on: May 04, 2017, 12:43:10 AM »
Thanks Daniel, good to hear the possibility is still there. Fingers and toes crossed!!
I didn't want to sound like I'm rushing anyone - I hugely appreciate your work (and Walter's and of course A1ex's) and just got a bit excited.

I'm afraid I'm no coder at all - I can barely grasp what's being talked about in that thread....
Sounds like it's not as straightforward as a simple porting exercise (not that I could do that), with the model differences and all.
I see it's probably a lot of hit and miss before one can find those right addresses to call.

If I can be of any help outside of actual coding, please do let me know.

jeefo254

  • New to the forum
  • *
  • Posts: 5
Re: Canon 700D / T5i
« Reply #1023 on: May 13, 2017, 12:13:55 AM »
Hello. I seem to have a problem with my 700D. I installed ML a bunch of times, on different cards even one formatted fat32, one exfat32 (didn't know the difference at the time). Yesterday the camera was working, with issues but working. Today it won't start. After much fiddling around I discovered that it's not completely dead. The shutter does work, the flash works, the LCD doesn't. If I leave the button to on, remove the battery and then re-inserted while is still in ON position the shutter will work for 6 or 7 times, the focus works, changing the ISO aperture and shutter speed does work while looking through the viewfinder. Please help me if you can. I hope it is a booting issue because the symptoms are the same with or without the SD cards. Thanks!

Walter Schulz

  • Hero Member
  • *****
  • Posts: 5714
Re: Canon 700D / T5i
« Reply #1024 on: May 13, 2017, 09:08:33 AM »
Backup card's autoexec.bin and copy "portable display test" autoexec.bin to card.
https://www.magiclantern.fm/forum/index.php?topic=2296.0

- Remove battery
- Insert card and close compartment
- Insert battery and close compartment

Does LCD show some info? If not: Remove battery, remove card and report back.