Author Topic: MLVFS folder disappearing/unmounting  (Read 3018 times)

charlesbrepsant

  • New to the forum
  • *
  • Posts: 9
MLVFS folder disappearing/unmounting
« on: December 05, 2015, 03:31:17 PM »
Hi everyone,
Thank you for all the amazing work on Magic Lantern.
I have a problem on MLVFS.
Basically I have quite a big project - 6Tb of data on a Thunderbolt 2 hard drive, on which I use MLVFS on to create a mounted folder with all my files as DNGs.
I then access the data through DaVinci Resolve, find my files, import them, etc. and start editing/colouring. 
After a while, the MLVFS mounter folder just disappears from Finder.  Files in Davinci Resolve don't answer any more, and trying to recreate a mounted MLVFS folder does not work.  There's nothing else to do but unmount/remount hard drive.
This makes it impossible to do the edit with MLFVS as the issue happens regularly and quickly.
The only closely resembling issue i've found are these:
http://www.magiclantern.fm/forum/index.php?topic=13152.200
https://secure.magiclantern.fm/forum/index.php?topic=13152.475
But I couldn't find a definite answer.   
I am on OS X Yosemite 10.10.4, using Fuse 2.8.0
Thanks for your help and sorry if the answer exists out there and I didn't find it.
 

dmilligan

  • Developer
  • Hero Member
  • *****
  • Posts: 3204
  • 60Da / 1100D / EOSM
Re: MLVFS folder disappearing/unmounting
« Reply #1 on: December 05, 2015, 04:15:12 PM »
What have you already tried to fix the issue? There are plenty of suggestions in the responses to those posts you linked.

Things you can try:

- figure out if it is a specific MLV file that is causing the problem (try mounting various combinations of the MLV files you have, a binary search would narrow it down to a single file the quickest)
- check for crash logs in ~/Library/Logs/DiagnosticReports and send them to me
- run mlvfs from the command line and send me any output


squig

  • Senior
  • ****
  • Posts: 498
  • Crash test dummy MK3
Re: MLVFS folder disappearing/unmounting
« Reply #2 on: December 06, 2015, 02:14:44 AM »
I'm having the same problem with a 240Gb MLV folder on my desktop. Yosemite 10.10.3 Fuse 2.8.0 There's a Fuse 2.8.2 update available, I'll try that.
www.gamma-movie.com post-apocalyptic feature now in pre-production.

charlesbrepsant

  • New to the forum
  • *
  • Posts: 9
Re: MLVFS folder disappearing/unmounting
« Reply #3 on: December 07, 2015, 03:38:53 PM »
Trying the same thing.
Nice user DeafEyeJedi has had the same problem in the past. 
He managed to solve it by either downgrading FUSE on Yosemite, or upgrading to El Capitan, upon which his issues were solved....
Will try both of these if upgrading Fuse to 2.8.2 doesn't change anything.   
@squig let me know if something works out on your end

charlesbrepsant

  • New to the forum
  • *
  • Posts: 9
Re: MLVFS folder disappearing/unmounting
« Reply #4 on: December 07, 2015, 05:30:05 PM »
okay so updating to Fuse 2.8.2 does not change things. Still having same problem.

@dmilligan: I've checked the crash files, can't find anything with MLVFS' name on it.  Not sure if it's useful but I have files for "powerstat" and resolve that match the time of the crash.  Let me know if they might be useful.   I'll see if I can find the way to launch MLVFS from the command line, not sure how to do that right now.   I've got hundreds of files so it seems tough to try and figure out which one it is by mounting X folders after X folders, restarting computer etc...

also, I was not very clear on this before, but the folder to which i've mounted MLVFS disappears completely from the finder.   I've checked hidden files and it is not there - I need to reboot the computer itself to make it reappear.

I will try downgrading FUSE first, then if it still does not work,  upgrading to El Capitan.

dmilligan

  • Developer
  • Hero Member
  • *****
  • Posts: 3204
  • 60Da / 1100D / EOSM
Re: MLVFS folder disappearing/unmounting
« Reply #5 on: December 07, 2015, 07:04:07 PM »
the folder to which i've mounted MLVFS disappears completely from the finder.  I've checked hidden files and it is not there - I need to reboot the computer itself to make it reappear.
It's still there, you just have to unmount it before you can see it again (it disappears because MLVFS crashed, but the folder itself remains mounted until you unmount it, and that's why you can't see it in the Finder). You can unmount it with the following command in the terminal (note the missing 'n' in the command, that's not a typo):
Code: [Select]
sudo umount /path/to/mlvfs/mount/

Or if you can't get that to work, you can always just mount to a different folder if you are trying to narrow it down to a specific file(s).


DeafEyeJedi

  • Hero Member
  • *****
  • Posts: 3043
  • 5D3 / M1 / 7D / 70D / SL1
Re: MLVFS folder disappearing/unmounting
« Reply #6 on: December 09, 2015, 04:53:17 AM »
Also I must ask is one of your MLV file larger than 32GB?

This can be really frustrating trying to troubleshoot this bad boy down ... I've tried so many ways in the past and gave up on this by deciding to upgrade to El Captain ... So far no problems but I haven't tried anything with MLV's being larger than 32GB or up yet. So I can't confirm this atm.

However, I've recorded the entire 128GB card with a single MLV file last year while testing out a new Card (KB 128GB 1066x) and if I remember correctly that it took quite awhile in order for MLVFS to spit out an .IDX file so be patience when it comes to large files like this -- not saying this could be the culprit for your issue but if you do then perhaps try taking out those large files and sort them into another "mount folder" separately and try running it again without large files to see if it'll disappear or not?
5D3.113 • 5D3.123 • EOSM.203 • 7D.203 • 70D.112 • 100D.101