Author Topic: Need some help with an error with magiclantern-Nightly.2017Jul03.5D3123  (Read 1240 times)

kokmk2

  • Just arrived
  • *
  • Posts: 2
Hi can some one help me? Im on a Canon 5D mark III
got a message when shooting in 1280X720 in Canon menu and 1280X432.
No problem at recording but when i playback the file in Mlv player :

fixme: please use fio_malloc (in mlv_play_task) 
This message is written many time on the screen, sometime red light is flashing in the same time and screen is flickering.

Help please! there was no problem with the older version.... :(

dmilligan

  • Developer
  • Hero Member
  • *****
  • Posts: 3203
  • 60Da / 1100D / EOSM
There was a bug discovered that occurs with extremely low probability when writing to or reading from files. The message you see is warning about places in the code where this bug needs a proper fix (there is currently a stop-gap measure in place, a proper fix will be a lot of work).

So there actually was a problem with the old version, it was just unknown. Now at least there's a warning.

See:
http://www.magiclantern.fm/forum/index.php?topic=19761.msg186060#msg186060

spto

  • Just arrived
  • *
  • Posts: 1
I got the same warnings.

I was shooting raw with 550D. 640x640.

I activated 3 modules before that: mlv_play, mlv_rec and mlv_snd.

Before the bug appears I tried several parameters to shoot and play, without problem. When I finally tried to shoot with 640x640 for a long time (~ 20 seconds), the warnings came and never go away, even when I try to replay some of the earlier clips.

kokmk2

  • Just arrived
  • *
  • Posts: 2
There was a bug discovered that occurs with extremely low probability when writing to or reading from files. The message you see is warning about places in the code where this bug needs a proper fix (there is currently a stop-gap measure in place, a proper fix will be a lot of work).

So there actually was a problem with the old version, it was just unknown. Now at least there's a warning.

See:
http://www.magiclantern.fm/forum/index.php?topic=19761.msg186060#msg186060

THX a lot for your help !!

cd1234567

  • New to the forum
  • *
  • Posts: 6
Re: Need some help with an error with magiclantern-Nightly.2017Jul03.5D3123
« Reply #4 on: August 06, 2017, 06:24:25 AM »
this error persists in the latest july 31 nightly build as well, FYI. I use  canon 7D

cd1234567

  • New to the forum
  • *
  • Posts: 6
Re: Need some help with an error with magiclantern-Nightly.2017Jul03.5D3123
« Reply #5 on: August 10, 2017, 05:04:33 PM »
august 7th build has the same problem. Could you disable this warning so that the mlv_player can play back the footage? Thanks.

PaulHarwood856

  • Member
  • ***
  • Posts: 240
Re: Need some help with an error with magiclantern-Nightly.2017Jul03.5D3123
« Reply #6 on: August 11, 2017, 01:17:14 AM »
I just recently discovered this on my 7D playing back 1728 x 734 (I believe - it was 2:1 aspect ratio) at 29.97 with Exact fps override. I was using a monitor, and had Global Draw on when recording. Canon Preview and Force HDMI-VGA to have smooth recording. I was still able to playback the footage, but the error makes the playback menu options glitch. I had to restart the camera to playback, and the glitching was still there. I also had mlv_rec, mlv_play, and mlv_sound all enabled.