Author Topic: Silent Picture & Aperture  (Read 1483 times)

Fedya

  • New to the forum
  • *
  • Posts: 9
Silent Picture & Aperture
« on: June 02, 2017, 12:17:01 PM »
Hello!
I encountered a problem: when shooting in silent picture mode, the aperture is always open, and the depth of field is minimal. Please tell me, can I change the aperture value in silent mode?

Walter Schulz

  • Hero Member
  • *****
  • Posts: 5802
Re: Silent Picture & Aperture
« Reply #1 on: June 02, 2017, 12:19:33 PM »
You are in mode M?

Fedya

  • New to the forum
  • *
  • Posts: 9
Re: Silent Picture & Aperture
« Reply #2 on: June 02, 2017, 12:32:41 PM »
Oh sure!

Walter Schulz

  • Hero Member
  • *****
  • Posts: 5802
Re: Silent Picture & Aperture
« Reply #3 on: June 02, 2017, 12:44:54 PM »
Check Expo.Sim and Expo.Override

Fedya

  • New to the forum
  • *
  • Posts: 9
Re: Silent Picture & Aperture
« Reply #4 on: June 02, 2017, 01:40:58 PM »
I tested these functions in all possible combinations, but unfortunately the aperture value during shooting was always 5.6 instead of the set value 14. :(

nikfreak

  • Developer
  • Hero Member
  • *****
  • Posts: 1032
Re: Silent Picture & Aperture
« Reply #5 on: June 02, 2017, 01:49:15 PM »
70D.112 & 100D.101

Fedya

  • New to the forum
  • *
  • Posts: 9
Re: Silent Picture & Aperture
« Reply #6 on: June 02, 2017, 03:40:35 PM »
Yes, I used STM. So the problem has no solution for me?

a1ex

  • Administrator
  • Hero Member
  • *****
  • Posts: 10543
  • 5D Mark Free
Re: Silent Picture & Aperture
« Reply #7 on: June 03, 2017, 12:31:47 AM »
Set the aperture in movie mode. If you use the "classic" full-res version, which only runs in photo mode, untwist the lens after setting the aperture, before switching back to photo mode.

The "modern" full-res version (crop_rec_4k build) only runs in movie mode for now, so it doesn't have this issue.

For reverse engineering: http://www.magiclantern.fm/forum/index.php?topic=17596.0

Walter Schulz

  • Hero Member
  • *****
  • Posts: 5802
Re: Silent Picture & Aperture
« Reply #8 on: June 03, 2017, 12:40:36 AM »
Unfortunately untwisting STM lenses will disable focus motor.

Fedya

  • New to the forum
  • *
  • Posts: 9
Re: Silent Picture & Aperture
« Reply #9 on: June 03, 2017, 10:32:30 AM »
Thank you all for your help! :D The method with the unscrewing of the lens actually works, but the focus may be lost and then it is not possible to adjust it, as Walter Schulz wrote. In this regard, I have a question, is it possible to disconnect the lens programmatically, with the help of some ML module (by clicking on some "magic" button), after focusing? It would be much more convenient than unscrewing the lens :)

tajino

  • New to the forum
  • *
  • Posts: 11
Re: Silent Picture & Aperture
« Reply #10 on: October 08, 2017, 05:30:12 PM »
I can confirm that this also affects USM L lenses, not just STM lenses.

http://www.magiclantern.fm/forum/index.php?topic=20645.0

Is there a crop_rec_4k build for 5D2?