Author Topic: 6D battery drains while camera is off  (Read 1427 times)

Shiranai

  • New to the forum
  • *
  • Posts: 8
6D battery drains while camera is off
« on: May 17, 2017, 06:40:45 PM »
Hello.

I have the following problem since I upgraded ML to the latest version 2017May07 a few days ago. (didn't happen with my last version at least not that I'm aware of)
The battery drains very fast, also while the camera is turned off. It drains approx. 5% every 15-20 minutes, so after a night it drains the battery empty. It happens with and without plugins loaded and I tried it with 3 different batteries and different lenses as well just to rule out other possibilities.

The problem does only happen when ML has been loaded before turning the camera off. If you use an empty SD or press and hold Set, so it doesn't load and switch the camera off, it doesn't happen.
So I think it is definitely a problem of the ML software.

So yesterday I had a shooting and charged the battery before, and put it in the camera. After like 4-5 hours when my model arrived, the battery was empty.
In the evening I put a empty memory card and a 95% charged battery in the camera and started the cam one time before I went to bed. The next day, the battery was still 95% full.
Today I put the ML memory card, loaded ML, turned the camera off and within a little more than half an hour, the battery went from 95% to 80%.
So today after this test, I left the same SD in, but I pressed set, so ML wouldn't load. When I came back after 2 hours it was still at 80%.

a1ex

  • Administrator
  • Hero Member
  • *****
  • Posts: 10444
  • 5D Mark Free
Re: 6D battery drains while camera is off
« Reply #1 on: May 17, 2017, 09:19:20 PM »
You (or other 6D user who has this issue) will have to do some more detective work to narrow it down.

1) Find a quick way to tell whether the battery is draining or not. If 10 minutes give a noticeable difference, that's fine. An ammeter (if you don't mind hijacking an external power supply) should be even quicker. If you have to take the battery out before starting the camera again, that's a very clear sign.

2) Save your ML configuration (ML/SETTINGS directory on the card), then reset ML to defaults. Do you still experience battery drain?

3) Try in-between configurations (between ML default and your usual one) until you find the setting that causes battery drain.

justinbacle

  • New to the forum
  • *
  • Posts: 39
  • DP
Re: 6D battery drains while camera is off
« Reply #2 on: May 18, 2017, 12:50:07 AM »
I had this problem back when I had my 500D. If you shutdown the camera whilst it is saving something (e.g. emptying buffer) or remove the card before powering off first this might happen.
Don't know if this was thix in an update though as I switched from a 500D to another camera.
Hope this helps :)

jackyes

  • New to the forum
  • *
  • Posts: 15
Re: 6D battery drains while camera is off
« Reply #3 on: May 18, 2017, 09:36:15 PM »
my 6d is 99% battery after 3 days.

russellsnr

  • Member
  • ***
  • Posts: 121
Re: 6D battery drains while camera is off
« Reply #4 on: May 20, 2017, 03:20:03 PM »
6D GPS Drains battery when idle

bender

  • New to the forum
  • *
  • Posts: 7
Re: 6D battery drains while camera is off
« Reply #5 on: June 28, 2017, 06:29:22 PM »
sorry for the delay... didnt red the bug tracking list till now.

i have the same problem with mit 6D!
i am using different sd cards and different accus (canon, patona, baxxter) and with every setup i got them.


walter_schulz

  • Senior
  • ****
  • Posts: 376
Re: 6D battery drains while camera is off
« Reply #6 on: June 28, 2017, 06:33:07 PM »
You read about GPS related draining, too?