Author Topic: Will not install, not sure what to do  (Read 710 times)

RRG

  • Just arrived
  • *
  • Posts: 2
Will not install, not sure what to do
« on: February 15, 2017, 05:44:07 PM »
I get a screen that says:

"Incorrect firmware version

Expecting a Canon 550D with firmware version 109.

Please reinstall Canon firmware 109 even if you already have this version"

I have reinstalled 1.0.9 even though the camera was current with firmware and I am still getting the error. I am unsure of what I could be doing wrong.

Walter Schulz

  • Hero Member
  • *****
  • Posts: 5717
Re: Will not install, not sure what to do
« Reply #1 on: February 16, 2017, 07:38:32 AM »
Make sure you are using FIR obtained from Pelican's site: http://pel.hu/eoscard
If it doesn't work you can try to install 1.1.0, then downgrade to 1.0.9 again.
Report back, please.

RRG

  • Just arrived
  • *
  • Posts: 2
Re: Will not install, not sure what to do
« Reply #2 on: February 16, 2017, 04:10:18 PM »
So your first suggestion I could not follow through with because I am on a Mac and the file is for Windows

I was able to upgrade to 1.1.0 and tried downgrading to 1.0.9 but the file I got from http://web.canon.jp/imaging/eosd/firm-e/eosdigital7/download.html is not working. anytime I put the .fir file onto the SD card and try updating firmware it says that the update file cannot be found.

Walter Schulz

  • Hero Member
  • *****
  • Posts: 5717