Author Topic: Canon 5D Mark III / 5D3 / Firmware 1.3.4  (Read 26387 times)

thedada

  • Just arrived
  • *
  • Posts: 1
Re: Canon 5D Mark III / 5D3 / Firmware 1.3.4
« Reply #25 on: June 15, 2017, 04:12:23 PM »
Hi there,

I might be kinda stupid  :o , but where is the Download link  :-X?

thank you in advance,

Regards,

zfairley

  • Just arrived
  • *
  • Posts: 1
Need Advice - Want to Update My Canon Firmware
« Reply #26 on: June 25, 2017, 08:19:46 PM »
Hi guys, I could use some help.

I currently have Canon's 1.1.3 firmware on my Mark iii with ML V2.3. I recently got a SmallHD monitor but I don't have the mirroring option available with my current Canon firmware. I want to upgrade it but I am unsure if that will cause any issues with ML being installed and also not sure how high I can upgrade the firmware. Some advice or things I should consider with completing an update would be great. Thanks!

-ZF

dfort

  • Hero Member
  • *****
  • Posts: 1799
Re: Canon 5D Mark III / 5D3 / Firmware 1.3.4
« Reply #27 on: June 29, 2017, 04:27:19 AM »
...where is the Download link  :-X?

magiclantern-Nightly.2017Feb19.5D3134.zip

Note that this is a work in progress so it might change or disappear. Best if you can start on the first post and read through this topic first.
EOSM.202 EOSM.203 EOSM2.103 700D.115 5D3.*

dfort

  • Hero Member
  • *****
  • Posts: 1799
Re: Need Advice - Want to Update My Canon Firmware
« Reply #28 on: June 29, 2017, 04:55:53 AM »
Hi guys, I could use some help.

...Canon's 1.1.3 firmware on my Mark iii with ML V2.3...

Wrong topic for that discussion. However, you should at least update from V2.3 because that is way out of date. The latest versions are on the downloads sections of this website. I made it really easy for testers to grab the Canon firmware for the 5D3 and posted tutorials on how to update and downgrade your firmware. Once you are on 1.2.3, which is where you probably should be, continue the discussion on the appropriate topic.
EOSM.202 EOSM.203 EOSM2.103 700D.115 5D3.*

dfort

  • Hero Member
  • *****
  • Posts: 1799
Re: Canon 5D Mark III / 5D3 / Firmware 1.3.4
« Reply #29 on: July 02, 2017, 09:29:48 PM »
I found only one issue for me - in the "normal" canon menus the Q button no longer works.

Is there any workaround?

Finally got around to checking up on this and can verify the issue. I'll have to do some digging around to figure out what is going on.
EOSM.202 EOSM.203 EOSM2.103 700D.115 5D3.*

dcpanda

  • Just arrived
  • *
  • Posts: 1
Re: Canon 5D Mark III / 5D3 / Firmware 1.3.4
« Reply #30 on: August 22, 2017, 03:17:02 AM »
Hi I recently bought another camera and my 5D3 has become my backup. I'm super keen to make ML work on it but because other people use the camera I'm hesitant to install if the Q button isn't working. Was there any update to this?

Happy to install and test stuff once it's sorted out :-)

dfort

  • Hero Member
  • *****
  • Posts: 1799
Re: Canon 5D Mark III / 5D3 / Firmware 1.3.4
« Reply #31 on: August 22, 2017, 05:46:00 PM »
Hi @dcpanda -- I haven't figured out the two issues with 1.3.4 which are the Q button not working and the menu flashing after boot up. I've been putting more effort on other projects because there doesn't seem to be much interest from the ML community to update to the latest Canon firmware. I'll get back to this once I get some more experience debugging.

For the best ML user experience I'd recommend downgrading your firmware to 1.1.3 or if HDMI mirroring is important to you, 1.2.3. I zipped up .FIR files and put them on my bitbucket download area - 5D3 Canon Firmware for Testers. You can find how to downgrade from 1.3.4 to earlier versions on this post.
EOSM.202 EOSM.203 EOSM2.103 700D.115 5D3.*

nexiabass

  • New to the forum
  • *
  • Posts: 11
Re: Canon 5D Mark III / 5D3 / Firmware 1.3.4
« Reply #32 on: August 23, 2017, 09:14:01 AM »
That's quite sad to read.
I love ML on my 5dmk3s. And i use the newest firmware.

I use it anyways with ML - but would be totaly happy if my Q button would work the normal way.
Maybe... if you have spare time...  :D  :)


CristianCostaPhotography

  • Just arrived
  • *
  • Posts: 1
Re: Canon 5D Mark III / 5D3 / Firmware 1.3.4
« Reply #33 on: August 24, 2017, 12:40:32 AM »
Hello all,
I write you because I have a very big problem with the ML installing procedure. First of all, I tell you that I have installed on my 5dmk3 the firmware 1.3.4 version.
So, i want to downgrade my firmware, but pc see the camera but eos utility not. Why it's the question, but I don't have any answer for this.
Ok, don't worry I told to me, I'll install the ML firmware 1.3.4. Here I found the problem: there's anybody who can help me with the installing procedure with this firmware? With details, please.
I really need it for my work.
There's somebody who can help me?
Thanks a lot at all.

Cristian

giancarlomo

  • Just arrived
  • *
  • Posts: 1
Re: Canon 5D Mark III / 5D3 / Firmware 1.3.4
« Reply #34 on: August 24, 2017, 08:34:49 PM »
Hi @dcpanda -- I haven't figured out the two issues with 1.3.4 which are the Q button not working and the menu flashing after boot up. I've been putting more effort on other projects because there doesn't seem to be much interest from the ML community to update to the latest Canon firmware. I'll get back to this once I get some more experience debugging.

For the best ML user experience I'd recommend downgrading your firmware to 1.1.3 or if HDMI mirroring is important to you, 1.2.3. I zipped up .FIR files and put them on my bitbucket download area - 5D3 Canon Firmware for Testers. You can find how to downgrade from 1.3.4 to earlier versions on this post.

Hello Dfort, I just registered in this forum, but I have been following it since its inception! There are probably many more people following you too! And we are interested in installing the ML in our 5D3 firmware 1.3.4 hope you can take some time and finish with the development of ML for this firmware. Greetings from Peru!!

dfort

  • Hero Member
  • *****
  • Posts: 1799
Re: Canon 5D Mark III / 5D3 / Firmware 1.3.4
« Reply #35 on: August 27, 2017, 08:10:11 AM »
There is no ML-SETUP.FIR for the 5D3.134 so unless you already had ML installed with the camera boot flag set, you won't be able to install ML onto your camera without downgrading the Canon firmware.

So, i want to downgrade my firmware, but pc see the camera but eos utility not. Why it's the question, but I don't have any answer for this.

Your pc can "see" the camera but EOS Utility cannot? So that means that your USB connection is working. What might be happening is that you have an older version of EOS Utility that isn't compatible with the 1.3.4 firmware. You can get the latest version from the Canon website.

I really need it for my work.

Please understand that ML is more of a hobby project and that the 1.3.4 port still has some issues and not yet part of the main code base. I'd think twice before betting my job on it.
EOSM.202 EOSM.203 EOSM2.103 700D.115 5D3.*