Author Topic: Canon 100D / SL1  (Read 228080 times)

nikfreak

  • Developer
  • Hero Member
  • *****
  • Posts: 1032
Canon 100D / SL1
« on: October 19, 2015, 10:41:29 PM »
Update 02nd Oct 2017:
Please download latest builds from now on here:
https://builds.magiclantern.fm/
Highly experimental builds are available here:
https://builds.magiclantern.fm/experiments.html

--------------------------------------------------------------------------------------
Provide a test report about functionality
Changelog
What's not working
Removing / Uninstall
Credits

Read this before installing:
  • If you decide to follow the installation instructions below then you do this on your own. Don't blame anyone later for what you decide to do to your own cam.
  • Keep in mind that you are trying out a Beta Release. You will may encounter bugs but hopefully contribute back so that we will get it as stable as possible....

Installation Instructions:
  • Download latest release for 100D firmware 1.0.1
  • Extract the zip-file to the root of your sdcard
  • Run the camera firmware update and read / understand / follow the on-screen instructions
  • Restart your camera. Press trash button to access the ML menu. Welcome!

Removing Magic Lantern / Uninstalling
  • Simply run the installer again and follow the onscreen instructions (Hint: watch the bottom screen line)
Source Code:
https://bitbucket.org/nikfreak/magic-lantern/branch/100D_merge_fw101

Gotta Questions?
Do a forum search first.... Let's try to keep on topic. Don't spam my inbox  :P

Bug Reporting (fill in OK / Not OK {e.g. screen flickering or camera crashed while taking a shoot or ........}:
http://www.chiark.greenend.org.uk/~sgtatham/bugs.html
Don't report bugs on the official issue tracker. We can only do so after being rest assured we got a stable release and the necessary source code changes are merged in officially.
Keep in mind: We need to list bugs in a readable and provable way.

  • Overlays
    -Zebras: ____
    -Focus Peak: ____
    - ....
  • Shoot
    -Intervalometer: ____
    -Bracketing: ____
    -.....
  • Included Modules
    - Raw_rec: ____
    - autoexpo: ____
    - ....
  • Other issues:
    _______________________________________
    ....

What's working:
  • You tell me. Don't forget to report like instructed above (fill in OK)
What's not working:
  • You tell me...
Check also Changelog history below for all details and disabled features...

Changelog (noteworthy ones only):
12th July 17: Beta_4b
  • check latest discussions within topic as well as the source code and each commit for all changes.
9th Oct 16: Beta_4b
  • support only firmware version 1.0.1. Please download from Canon's website if you are still running firmware version 1.0.0.
  • Dropping hereby support for previous builds based upon fw 1.0.0.
  • Archiving changelog history to the 2nd post. Please read through it before running ML for the first time.

Credits
  • a1ex and g3gg0 for their time and nerves providing me ML insights  :P
  • Dayton Taylor from digitalair.com for donating the sl1 development body
  • DeafEyejedi for lots of serious private testing
  • Everyone else whom I forgot...
70D.112 & 100D.101

nikfreak

  • Developer
  • Hero Member
  • *****
  • Posts: 1032
Re: Canon 100D / SL1 (Alpha-1a / 19th Oct)
« Reply #1 on: October 19, 2015, 10:42:29 PM »
Archived Changelog
7th Sep 16: Beta_3a
  • synched up all changes from unified branch
  • enabled Flexinfo
  • re-activated Q-menu: til now the Q-menu was disabled by ML. Some people complained about that. A long press on q/set button will now bring back the Q-menu. Please be aware: for this to function you need to set C.Fn IV-> Assign SET button -> 0:Quick Control Screen
  • for all changes check source
13th July 16: Beta_2c
  • merged latest commits from unified branch:
  • updated fir installers
  • scrollwheel mapping L/R fixed in ML menu
  • recording indicators fixed
  • check source for all details

01st May 16: Beta_2b

29th Apr 16: Beta_2a
  • disabled features (buggy): rack focus, focus stacking and trap focus
  • enabled focus patterns as requested by JohanJ

28th Apr 16: Beta_1
  • rock solid for me. Beta status reached. Feels even better than my 70D port  ;)
  • merged latest commits from unified branch
  • re-created all installers (textmods + failsafe C revision)
  • enabled focus features (untested by me). YOU test them in detail. I want full reports on all (sub-)features. No 1-liners or it might get removed in next build again. Up to you!  ;)

27th Apr 16: Alpha_3b
  • enabled Features: Quickzoom, Arrow Shortcuts and Shutter Lock
  • research feature functionalities and please post feedback for all revisions

24th Apr 16: Alpha_3a
  • Added the long awaited support for 100D.100C
  • Removed PRs marked (untested) from previous release (see below). Those will get included automatically by merging unified in next release.

20th Apr 16: Alpha_2a
  • Silent Pictures appears to be broken (SAVE DNG error). Still I have removed all older builds prior to this build. We will have it fixed in an upcoming build again.
  • bleeding edge build containing pull requests from bitbucket
  • tried to fix the "dirty" ML menu which appeared in LV / movie mode. This is what I am mainly after. YOU try hard to get it "dirty" again by switching forth and back from photo mode to LV/movie mode etc and tell us if you encounter it again.
  • raw_rec fixes from a1ex merged (untested)
  • lua_fixes from a1ex merged (untested)
  • ToDo: narrow down buggy features and report them...

14th Apr 16: Alpha_1d
  • synched up with unified branch so check the source over there to see what has changed in the last months (lots of stuff thanx to a1ex). Download only for 100D.100A/B. Revision C has to wait.

20th Nov 15: Alpha_1c
  • this was rather a private testing build

26th Oct.: Alpha_1b
  • Try to fix expo override
  • enable bitrate feature (needs to be tested). Quick test with cap on and cbr 3x showed an increasing filesize for me...

18th Oct 15: Alpha_1a
  • Initial release: This is the first and also an Alpha release. Don't blame anyone later...
  • Q-menu has been "force-overridden" to act as SET button (we need this for ettr etc. Guess we will bring it back by doing a long-press in one of the next releases. For now you have to live with it and make your adjustments by touchscreen in pure photo mode.
  • If you encounter freezes / crashes then take out your battery. Try to reproduce and report your findings.
  • ML menu might have some artifiacts from time to time and you might also see some flickering. my tests show that switching to play mode and back solves that issue in most cases.
70D.112 & 100D.101

DeafEyeJedi

  • Hero Member
  • *****
  • Posts: 3056
  • 5D3 / M1 / 7D / 70D / SL1
Re: Canon 100D / SL1 (Alpha-1a / 19th Oct)
« Reply #2 on: October 19, 2015, 10:43:38 PM »
Excellent timing, Mate!

Now the REAL tests begins...

*amen*

 8)

*Edit* one of the best part is the half shutter magic-zoom... LOVE THIS quick and efficient feature!

It was only limited on the 7D with my line of cameras and now this tiny beast gets it as well...

*wo0o0ot*

*Edit-2* Test Run #1:

-Shot w Nikkor 50mm 1.4 (some of those shots were in crop-mode <-- Really Nice Feature!)
-In 1280x720p (16x9) in exFAT w card warm-up @ 128MB
-Dual-ISO was shot in ISO 100/1600
-HDR Video was shot in ISO 100/1600
-lastly ETTR applied to most, if not all.

Messed around with MLV HDR, Dual-ISO in varieties FPS, converted with MLP and conformed entire timeline into 23.987 in DR 12.
It's not perfect because I need FPS override to work in order to smooth out the flicker in some of the Dual-ISO shots.
Still pretty awesome for a tiny beast that costed less than $300 to scoop up a used body!

https://vimeo.com/142956108

https://vimeo.com/142955388

https://vimeo.com/142968692

•Troubleshoot/Bug reports coming soon
•Video Demonstration coming soon
•Possible ScreenFlow of how to do's regarding Post-Workflow (if necessary) depending on how many user errors.

Thanks to @nikfreak for his never-ending contributions as well as to @a1ex & @g3gg0 for getting him up to speed!
5D3.113 • 5D3.123 • EOSM.203 • 7D.203 • 70D.112 • 100D.101

koenkooi

  • New to the forum
  • *
  • Posts: 6
Re: Canon 100D / SL1 (Alpha-1a / 19th Oct)
« Reply #3 on: October 20, 2015, 12:35:59 PM »
The error message for 100A->100B is a bit misleading:

Magic lantern install by Koen Kooi, on Flickr

Using the 100B version worked like a charm.
EOS-M
EOS 7D
EOS 100D 100D.100B

Xinixato

  • New to the forum
  • *
  • Posts: 7
Re: Canon 100D / SL1 (Alpha-1a / 19th Oct)
« Reply #4 on: October 20, 2015, 06:29:12 PM »
Installed on my camera ("B" build), works fine, i need to familiarize with ML and learn how to use it, i supose that mostly parameters cant change because "Q/SET" button as the same (described in changelog), but hope this will be fixed soon.

Thank you very much for your job, i will test it deeply when i have time.
EOS 100D 100D.100B - 18-55 STM - 50 1.8 MkI - 70-210 f4

DeafEyeJedi

  • Hero Member
  • *****
  • Posts: 3056
  • 5D3 / M1 / 7D / 70D / SL1
Re: Canon 100D / SL1 (Alpha-1a / 19th Oct)
« Reply #5 on: October 21, 2015, 06:31:23 AM »
@Xinixato -- Don't forget you can also push 'Av' button as an enter/back button which can be tricky but works well for the most part.

@koenkooi -- Good catch and Thanks for sharing!
5D3.113 • 5D3.123 • EOSM.203 • 7D.203 • 70D.112 • 100D.101

Xinixato

  • New to the forum
  • *
  • Posts: 7
Re: Canon 100D / SL1 (Alpha-1a / 19th Oct)
« Reply #6 on: October 21, 2015, 01:40:10 PM »
Nice! @DeafEyeJedi, i tried buttons but not noticed AV can do this, thank you!!
EOS 100D 100D.100B - 18-55 STM - 50 1.8 MkI - 70-210 f4

Robin

  • Just arrived
  • *
  • Posts: 2
Re: Canon 100D / SL1 (Alpha-1a / 19th Oct)
« Reply #7 on: October 21, 2015, 02:50:19 PM »
Hi, cool to see ML on the 100D.

I'm new to Magic Lantern, so maybe i did something wrong but i found a crash xD

I wanted to try to capture a dual iso video and could play it in the ML file manager. Then i disabled the "allow Frameskip" in Picture Mode since the ML menu keeps disapearing in Video Mode and upon changing to Video Mode the Camra crashed.

I couldn't reproduce it, maybe because i missed a step (i'm pretty new to ML) or maybe it was a random crash.
I nonetheless hope the logs might help.

Greetings Robin

PS: Seems like I can't attach files. Where should I put them if they might be interesting?
EOS 100D.100B

nikfreak

  • Developer
  • Hero Member
  • *****
  • Posts: 1032
Re: Canon 100D / SL1 (Alpha-1a / 19th Oct)
« Reply #8 on: October 21, 2015, 03:00:38 PM »
dropbox or pastebin or whatever...
70D.112 & 100D.101

Robin

  • Just arrived
  • *
  • Posts: 2
EOS 100D.100B

Felipe

  • Member
  • ***
  • Posts: 229
Re: Canon 100D / SL1 (Alpha-1a / 19th Oct)
« Reply #10 on: October 21, 2015, 04:25:22 PM »
Congratulations nikfreak, So far everything fine ( I don't use modules ), Compared to my T4i, T5i, missing : Arrow set shortcuts and Bit rate increasing
100D.100B
650D-100D

Felipe

  • Member
  • ***
  • Posts: 229
Re: Canon 100D / SL1 (Alpha-1a / 19th Oct)
« Reply #11 on: October 21, 2015, 07:49:59 PM »
DOF settings not working
650D-100D

clivewattsrsa

  • New to the forum
  • *
  • Posts: 8
  • Newbie photographer - Tech Junkie - Software Dev
Re: Canon 100D / SL1 (Alpha-1a / 19th Oct)
« Reply #12 on: October 21, 2015, 10:12:43 PM »
Neither install works for me. Both come up with incorrect firmware version.

Possibly a rare 3rd build?

I would be happy to try dump the firmware if someone could walk me through the process or link me to somewhere to that effect.


@nikfreak, expect a pm has been sent about my fw shortly after I post this.

Thanks for all the hard work either way. I am super envious of all you guys getting ML awesomeness.

Regards
100D.100C?

Felipe

  • Member
  • ***
  • Posts: 229
Re: Canon 100D / SL1 (Alpha-1a / 19th Oct)
« Reply #13 on: October 22, 2015, 04:25:13 AM »
When in ML Menu during Live view the black background is not clean it shows some sort of multiple hot pixels
650D-100D

nikfreak

  • Developer
  • Hero Member
  • *****
  • Posts: 1032
Re: Canon 100D / SL1 (Alpha-1a / 19th Oct)
« Reply #14 on: October 22, 2015, 08:11:49 AM »
Felipe can you update your signature as instructed in 1st post?

@all: After checking @clivewattsrsa's dump I can confirm that there's a 3rd revision of the firmware floating around.
70D.112 & 100D.101

DeafEyeJedi

  • Hero Member
  • *****
  • Posts: 3056
  • 5D3 / M1 / 7D / 70D / SL1
Canon 100D / SL1 (Beta-4a)
« Reply #15 on: October 22, 2015, 09:22:26 AM »
Good catch, @clivewattsrsa and thanks for confirming this @nikfreak!

More fun stuff w HDR Video ... even works with H.264 for those who can't handle RAW.

https://vimeo.com/141305543

https://vimeo.com/141305532

Converted & exported with ease from @Danne's app called MLP which works really well for OS X.
5D3.113 • 5D3.123 • EOSM.203 • 7D.203 • 70D.112 • 100D.101

canneloni

  • Freshman
  • **
  • Posts: 64
Re: Canon 100D / SL1 (Alpha-1a / 19th Oct)
« Reply #16 on: October 22, 2015, 11:02:10 AM »
Not OK

Does not show correct information about about focal length and focus distance (at least with 18-55 IS STM Lens)

https://www.youtube.com/watch?v=SsAlCWm793o&feature=youtu.be

But still, thank you very very much for your great work! Will post other bugs if i find some and help this camera make the best it can be!
100D.100B ; Canon 18-55 STM ; Canon 50 1,8 II ; Canon 75-300 4,0 - 5,6 III ; Sigma 17-50 2,8

clivewattsrsa

  • New to the forum
  • *
  • Posts: 8
  • Newbie photographer - Tech Junkie - Software Dev
Re: Canon 100D / SL1 (Alpha-1a / 19th Oct)
« Reply #17 on: October 22, 2015, 11:39:42 AM »
Not OK

Does not show correct information about about focal length and focus distance (at least with 18-55 IS STM Lens)

https://www.youtube.com/watch?v=SsAlCWm793o&feature=youtu.be

But still, thank you very very much for your great work! Will post other bugs if i find some and help this camera make the best it can be!

Your video is set to private mate. We can't watch it.
100D.100C?

Felipe

  • Member
  • ***
  • Posts: 229
Re: Canon 100D / SL1 (Alpha-1a / 19th Oct)
« Reply #18 on: October 22, 2015, 01:16:07 PM »
nikfreak, I'm sorry just updated my signature
650D-100D

Felipe

  • Member
  • ***
  • Posts: 229
Re: Canon 100D / SL1 (Alpha-1a / 19th Oct)
« Reply #19 on: October 22, 2015, 01:48:51 PM »
DeafEyeJedi, HDR Video looks like a very useful tool. The clip at full 1080 ( So my Anti aliasing Moire filter works ) H264 has to be post processed, to avoid the flickering, What app can do that ?
650D-100D

DeafEyeJedi

  • Hero Member
  • *****
  • Posts: 3056
  • 5D3 / M1 / 7D / 70D / SL1
Re: Canon 100D / SL1 (Alpha-1a / 19th Oct)
« Reply #20 on: October 22, 2015, 04:04:48 PM »
For OS X. I like to use @Danne's app called MLP -- http://www.magiclantern.fm/forum/index.php?topic=13512.0
5D3.113 • 5D3.123 • EOSM.203 • 7D.203 • 70D.112 • 100D.101

Felipe

  • Member
  • ***
  • Posts: 229
Re: Canon 100D / SL1 (Alpha-1a / 19th Oct)
« Reply #21 on: October 22, 2015, 04:19:01 PM »
PC ?AND is not CR2 is H264
650D-100D

DeafEyeJedi

  • Hero Member
  • *****
  • Posts: 3056
  • 5D3 / M1 / 7D / 70D / SL1
Canon 100D / SL1 (Alpha-1a / 19th Oct)
« Reply #22 on: October 22, 2015, 04:21:23 PM »
Not sure?

Try here... http://www.magiclantern.fm/forum/index.php?board=14.0

Let's please try and stay on topic.
5D3.113 • 5D3.123 • EOSM.203 • 7D.203 • 70D.112 • 100D.101

canneloni

  • Freshman
  • **
  • Posts: 64
Re: Canon 100D / SL1 (Alpha-1a / 19th Oct)
« Reply #23 on: October 22, 2015, 06:30:02 PM »
@clivewattsrsa

Video should Work now
100D.100B ; Canon 18-55 STM ; Canon 50 1,8 II ; Canon 75-300 4,0 - 5,6 III ; Sigma 17-50 2,8

nikfreak

  • Developer
  • Hero Member
  • *****
  • Posts: 1032
Re: Canon 100D / SL1 (Alpha-1a / 19th Oct)
« Reply #24 on: October 22, 2015, 07:44:37 PM »
@canneloni: movie crop mode active? Got wrong numbers in LV only, too?
70D.112 & 100D.101