Author Topic: Canon 60D  (Read 88235 times)

Avenger 2.0

  • New to the forum
  • *
  • Posts: 23
Re: Canon 60D
« Reply #75 on: January 10, 2017, 07:46:12 AM »
I need some help!! My camera keeps saying "Incorrect firmware version. Expecting firmware version 1.1.1" I have 1.1.2. Will it not work with 1.1.2? And if it does still work, can you give me help with how to install it properly as I'm not sure if I'm doing it correctly XD
You need 1.1.1. You can just put it on the SD card and run firmware update to downgrade to 1.1.1.
Found working 1.1.1 link on google: http://support-nz.canon.co.nz/contents/NZ/EN/0400055002.html