MLV Lite - The sweet taste of MLV with none of the extra calories™

Lua scripting updated


Twitter: @autoexec_bin    Facebook: magiclantern.firmware    Live chat: [email protected]

Want to help with Magic Lantern development, but have no coding skills?

Author Topic: Canon 5D Mark III / 5D3 / Firmware 1.2.3  (Read 663780 times)

a1ex

  • Administrator
  • Hero Member
  • *****
  • Posts: 8925
  • 5D Mark Free
Canon 5D Mark III / 5D3 / Firmware 1.2.3
« on: March 16, 2014, 03:26:45 PM »
Please discuss raw recording issues in the Raw Video section of the forum.

Raw recorders (mlv_rec, raw_rec) are just apps that run on top of Magic Lantern core, just like Auto ETTR, Arkanoid, Dot-Tune and many other modules. This thread is for issues specific to the 5D Mark III port (in particular, problems introduced in 1.2.3 that did not exist in 1.1.3).

Any messages about RAW/MLV from this thread will be deleted without notice.


It's out!

Not alpha, not beta, nor zeta, just a bleeding edge that happens to work for me. It might work for you or it might not.

(note that my standards are fairly high, so what I call bleeding edge, others may call semi-stable or whatever)



Installation:
1) Format the card from the camera.
2) Make sure you are running Canon firmware 1.2.3.
3) Copy ML files on the card and run Firmware Update.

Uninstallation:
1) Run Firmware Update from your ML card.
2) Follow the instructions.

What's hot:
- bootflag issue solved! (p.s. some bloggers got it wrong, you still enable it in the camera, but you can disable it by uninstalling)
- installation is really easy (simply unzip the files on the card, update firmware and you are ready to go)
- uninstallation is equally easy (update firmware and follow the instructions)
- EosCard is now optional
- ML restores itself after formatting the card (man, that komputerbay card is fast!)
- you may install on any card combination you may think of
- over 300.000 downloads in the last two months :)

What's not:
- unlike most firmware updates which fix minor things, this one changed a LOT, especially on the display side (for example, LiveView is now quad-buffered and most of the display registers were changed).
- watch out for corrupted frames (still an issue?)
- fast zebras not working, but can be fixed
- no full-screen magic zoom (I never used it anyway, but was nice)
- no brightness/contrast/saturation adjutments (registers changed)
- [SOLVED!] HDMI issues
- no documentation (yet).

For photo use (raw overlays, ETTR and so on) it should be just fine (that's how I use it).

Source code:
- the 5D3-123 branch in the main repository.
- feel free to merge it locally with unified or experimental branches to get a sneak peek for the future updates.
- I'll merge it to unified when I'll be confident it's at least as good as the 1.1.3 branch (based on your feedback).

Thanks to:
- chris_overseas for initial porting and testing
- horshack for advice about safely toggling the bootflag
- Audionut for early builds and support in the early porting thread
- marekk, pompeiisneaks, jpaana, rufustfirefly, sinubis and others for early feedback and small fixes
- mk11174 for getting the 700D port in sync in this one
- everyone else who volunteeres their time to make a great community project.

Final notes:
- check nightly builds often and stay up to date! I'll do my best to make sure there are no critical issues in the nightly builds.
- there are quirks and bugs waiting to be fixed (please report them properly, with details on how to reproduce).
- grab the ARM toolchain and start hacking! (start with something easy or just tweak/fix whatever you find interesting).
- If anything goes wrong, we don't pay for repairs. Use Magic Lantern at your own risk!

coming soon: a lot of stuff, including a real sensor upgrade, a C compiler that runs on your camera and other geeky stuff like this
« Last Edit: January 16, 2016, 08:34:54 AM by a1ex »

shahed26

  • New to the forum
  • *
  • Posts: 18
Re: Magic Lantern for 5D Mark III 1.2.3
« Reply #1 on: March 16, 2014, 03:33:25 PM »
Thank you so much for bleeding edge build!!!

Finally a build with simplified installer and uninstaller. Your a legend.

Going to install this tonight and have fun!

Marsu42

  • Hero Member
  • *****
  • Posts: 1533
  • 66d + flashes
Re: Magic Lantern for 5D Mark III 1.2.3
« Reply #2 on: March 16, 2014, 03:37:45 PM »

Stedda

  • Hero Member
  • *****
  • Posts: 504
Re: Magic Lantern for 5D Mark III 1.2.3
« Reply #3 on: March 16, 2014, 03:39:42 PM »
Thanks to everyone who made it possible!





What will people complain about now that the bootflag is solved?  :D
5D Mark III -- 7D   SOLD -- EOS M 22mm 18-55mm STM -- Fuji X-T1 18-55 F2.8-F4 & 35 F1.4
Canon Glass   100L F2.8 IS -- 70-200L F4 -- 135L F2 -- 85 F1.8 -- 17-40L --  40 F2.8 -- 35 F2 IS  Sigma Glass  120-300 F2.8 OS -- 50 F1.4 -- 85 F1.4  Tamron Glass   24-70 2.8 VC   600EX-RT X3

pv25pv

  • New to the forum
  • *
  • Posts: 37
Re: Magic Lantern for 5D Mark III 1.2.3
« Reply #4 on: March 16, 2014, 03:43:34 PM »
wooooohoooooo...first test seems to be working very good.
you guys are legends .many thankssssssss
5Dmk3
24-105mm f/4L _ 16-35mm f/2.8L II _ 50mm f/1.4 _ TS-E 90mm f/2.8 _ Sigma 70-200mm F2.8 EX

chmee

  • Hero Member
  • *****
  • Posts: 1003
  • raw2cdng
Re: Magic Lantern for 5D Mark III 1.2.3
« Reply #5 on: March 16, 2014, 03:48:00 PM »
thanks a lot, guys.

pheu

  • Just arrived
  • *
  • Posts: 2
Re: Magic Lantern for 5D Mark III 1.2.3
« Reply #6 on: March 16, 2014, 04:02:34 PM »
Many thanks! wohoo :D

Going to test it today

arrinkiiii

  • Hero Member
  • *****
  • Posts: 1077
  • ML ADDICTED 7D
Re: Magic Lantern for 5D Mark III 1.2.3
« Reply #7 on: March 16, 2014, 04:07:50 PM »

WOW !!! Don't have a 5D but this is spectacular!!  Indeed, a living legend, a living machine legend!

KurtAugust

  • Freshman
  • **
  • Posts: 73
Re: Magic Lantern for 5D Mark III 1.2.3
« Reply #8 on: March 16, 2014, 04:30:34 PM »
Congratulations! Even more people will be drawn to ML now with the bootflag issue solved.
www.kurtaugustyns.com @HetRovendOog

Marsu42

  • Hero Member
  • *****
  • Posts: 1533
  • 66d + flashes
Re: Magic Lantern for 5D Mark III 1.2.3
« Reply #9 on: March 16, 2014, 04:40:18 PM »
Congratulations! Even more people will be drawn to ML now with the bootflag issue solved.

Indeed we'll see about this, my theory is that some part of people shying away from the missing bootflag removal are too cautious to try ML at all as it's still widely regarded has a "hack".

carlosgaviria

  • Just arrived
  • *
  • Posts: 1
Re: Magic Lantern for 5D Mark III 1.2.3
« Reply #10 on: March 16, 2014, 04:51:14 PM »
is it safe now to install ML on a mark iii ?
thanks

Marsu42

  • Hero Member
  • *****
  • Posts: 1533
  • 66d + flashes
Re: Magic Lantern for 5D Mark III 1.2.3
« Reply #11 on: March 16, 2014, 04:58:23 PM »
is it safe now to install ML on a mark iii?

It's as safe or unsafe as before, it's apparently just easier and and uninstallation is possible.

You're still running bleeding edge nightly code usually just tested by one single person, though as alex wrote he's very concerned with safety and thus nightly appears to be effectively the new rolling stable-ish release.

swinxx

  • Hero Member
  • *****
  • Posts: 597
Re: Magic Lantern for 5D Mark III 1.2.3
« Reply #12 on: March 16, 2014, 05:26:51 PM »
Whow, thx you very much..

meauounji

  • New to the forum
  • *
  • Posts: 10
Re: Magic Lantern for 5D Mark III 1.2.3
« Reply #13 on: March 16, 2014, 06:03:37 PM »
OMG, THANK YOU! for fixing the bootflag. It was a serious problem for me when it comes to shooting stills.

Jolly Roger

  • New to the forum
  • *
  • Posts: 11
Re: Magic Lantern for 5D Mark III 1.2.3
« Reply #14 on: March 16, 2014, 06:06:55 PM »
It works fairly well.

What I noticed so far:

+) when HDMI+LCD mirroring is active, ML acts like it does when Canon displays are ON (so no overlays, neither in camera lcd or in external monitor). Infact, inside ML menu, info bar at the bottom keep saying "Press INFO (outside ML menu) to turn Canon displays off.".


DavidSh

  • Member
  • ***
  • Posts: 135
Re: Magic Lantern for 5D Mark III 1.2.3
« Reply #15 on: March 16, 2014, 06:26:22 PM »
I can tell you that i bout the 5d3 only because of ml raw with 1.2.3.
i waited for that release, refreshing  chris overseas topic "how do i dump 5d3 1.2.3" and the bit bucket branch 100 times a day.
evan started to learn coding c# ( i know some vb and java) for trying to help.
I think that yesterday i was the first one who volunteer installing this version.

As i learned by the time A1ex do not release versions before he test it again and again and again.

Lots of people waited for that moment. truly a happy day.

some of us  should also learn not asking when, if you want to get "when" closer to now, just try to help by testing, by coding, whatever. and move this project forward.



600D | 5D3 | Os X Mavericks | http://www.GentleDogMovie.com

VisualPursuit

  • New to the forum
  • *
  • Posts: 43
Re: Magic Lantern for 5D Mark III 1.2.3
« Reply #16 on: March 16, 2014, 07:01:09 PM »
As stated elsewhere before:

Install with an original Canon battery or a 3rd party battery
that is not requiring you to acknowledge using it,
OR hold your fingers still and wait until the installer finishes
in the background before acknowledging the use of this battery.

rpt

  • Freshman
  • **
  • Posts: 73
  • 5DIII, 24-105, 40 2.8, 100-400, 600EX
Re: Magic Lantern for 5D Mark III 1.2.3
« Reply #17 on: March 16, 2014, 07:23:58 PM »
ML did not load  >:(

Has this to do with the fact that I am using a 64GB SD card?

Please see my post on the CR forum http://www.canonrumors.com/forum/index.php?topic=20051.msg378682#msg378682

albertgarciarue

  • New to the forum
  • *
  • Posts: 5
Re: Magic Lantern for 5D Mark III 1.2.3
« Reply #18 on: March 16, 2014, 07:28:19 PM »
- watch out for corrupted frames (from my limited testing, I'm not fully convinced the issue is fully resolved on 1.2.3 => for serious video use, please consider staying on 1.1.3)

So, if we're mainly using the Mark III for H264 and RAW video, you recommend to stay on 1.1.3 because of the corrupted frames, or it shoudn't happen? Will it be the same as 1.1.3 or worse?

a1ex

  • Administrator
  • Hero Member
  • *****
  • Posts: 8925
  • 5D Mark Free
Re: Magic Lantern for 5D Mark III 1.2.3
« Reply #19 on: March 16, 2014, 07:29:52 PM »
rpt: try with a smaller card

albertgarciarue: did you get pink frames on 1.1.3 with latest builds? I don't see your voice here: www.magiclantern.fm/forum/index.php?topic=10443

rpt

  • Freshman
  • **
  • Posts: 73
  • 5DIII, 24-105, 40 2.8, 100-400, 600EX
Re: Magic Lantern for 5D Mark III 1.2.3
« Reply #20 on: March 16, 2014, 07:39:40 PM »
rpt: try with a smaller card

albertgarciarue: did you get pink frames on 1.1.3 with latest builds? I don't see your voice here: www.magiclantern.fm/forum/index.php?topic=10443
I'll try that tomorrow. Thanks.

DavidSh

  • Member
  • ***
  • Posts: 135
Re: Magic Lantern for 5D Mark III 1.2.3
« Reply #21 on: March 16, 2014, 07:46:31 PM »
after recording number of mlv recording only one was with corrupt frame and it was the first frame.
« Last Edit: March 16, 2014, 07:53:39 PM by DavidSh »
600D | 5D3 | Os X Mavericks | http://www.GentleDogMovie.com

hjfilmspeed

  • Senior
  • ****
  • Posts: 365
Re: Magic Lantern for 5D Mark III 1.2.3
« Reply #22 on: March 16, 2014, 09:25:46 PM »
Do the installation instructions above apply if we are running nightly builds on 1.1.3 and already have the boot flag flipped on? I think Im on a March nightly build on 5d3. With that being said if we uninstall from from the 1.2.3 does that completely remove the boot flag? Sorry if this is a irritating question. I haven't read up on 1.2.3 yet

Jolly Roger

  • New to the forum
  • *
  • Posts: 11
Re: Magic Lantern for 5D Mark III 1.2.3
« Reply #23 on: March 16, 2014, 09:53:52 PM »
Do the installation instructions above apply if we are running nightly builds on 1.1.3 and already have the boot flag flipped on? I think Im on a March nightly build on 5d3. With that being said if we uninstall from from the 1.2.3 does that completely remove the boot flag? Sorry if this is a irritating question. I haven't read up on 1.2.3 yet

If you have the bootflag already enabled, just upgrade to 1.2.3 Canon firmware, power off the camera, put ML (1.2.3 build) on card, et voilĂ .

Djoni_P

  • Just arrived
  • *
  • Posts: 1
Re: Magic Lantern for 5D Mark III 1.2.3
« Reply #24 on: March 16, 2014, 09:55:03 PM »
First of all, THANKS A LOT for your work with ML!

I've been waiting for a 1.2.3 release forever!

I installed it but I can't find the M tab for raw video.
The M tab seems to be replaces with a triangle symbol tab.


I fixed it!

Thanks a bunch!
« Last Edit: March 17, 2014, 10:28:54 PM by Djoni_P »

 

courtesy